gnu: onionshare: Update to 0.9.2 (fixes CVE-2016-5026).

* gnu/packages/tor.scm (onionshare): Update to 0.9.2.
[source]: Remove patch.
[arguments]: Update substitutions for new version.
* gnu/packages/patches/onionshare-fix-install-paths.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Efraim Flashner 2016-12-13 13:11:40 +02:00
parent 991e143d25
commit e5a12fba82
No known key found for this signature in database
GPG Key ID: F4C1D3917EACEE93
3 changed files with 15 additions and 63 deletions

View File

@ -743,7 +743,6 @@ dist_patch_DATA = \
%D%/packages/patches/ocaml-CVE-2015-8869.patch \
%D%/packages/patches/ocaml-findlib-make-install.patch \
%D%/packages/patches/ola-readdir-r.patch \
%D%/packages/patches/onionshare-fix-install-paths.patch \
%D%/packages/patches/openexr-missing-samples.patch \
%D%/packages/patches/openjpeg-CVE-2016-5157.patch \
%D%/packages/patches/openjpeg-CVE-2016-7163.patch \

View File

@ -1,39 +0,0 @@
From 7afdd3366711a0c508bfb9323af8f4268ab77c9b Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Thu, 21 Jul 2016 13:22:45 +0300
Subject: [PATCH] patch
---
setup.py | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/setup.py b/setup.py
index 8ae56fe..8b245c9 100644
--- a/setup.py
+++ b/setup.py
@@ -91,15 +91,15 @@ setup(
include_package_data=True,
scripts=['install/scripts/onionshare', 'install/scripts/onionshare-gui'],
data_files=[
- (os.path.join(sys.prefix, 'share/applications'), ['install/onionshare.desktop']),
- (os.path.join(sys.prefix, 'share/appdata'), ['install/onionshare.appdata.xml']),
- (os.path.join(sys.prefix, 'share/pixmaps'), ['install/onionshare80.xpm']),
- (os.path.join(sys.prefix, 'share/onionshare'), [
+ ('share/applications', ['install/onionshare.desktop']),
+ ('share/appdata', ['install/onionshare.appdata.xml']),
+ ('share/pixmaps', ['install/onionshare80.xpm']),
+ ('share/onionshare', [
'resources/version.txt',
'resources/wordlist.txt'
]),
- (os.path.join(sys.prefix, 'share/onionshare/images'), images),
- (os.path.join(sys.prefix, 'share/onionshare/locale'), locale),
- (os.path.join(sys.prefix, 'share/onionshare/html'), html)
+ ('share/onionshare/images', images),
+ ('share/onionshare/locale', locale),
+ ('share/onionshare/html', html)
]
)
--
2.9.1

View File

@ -138,7 +138,7 @@ networks.")
(define-public onionshare
(package
(name "onionshare")
(version "0.9")
(version "0.9.2")
(source
(origin
(method url-fetch)
@ -147,8 +147,7 @@ networks.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"0pc3xbq379415s0i0y6rz02hay20zbvgra1jmg4mgrl9vbdr8zmw"))
(patches (search-patches "onionshare-fix-install-paths.patch"))))
"02iv7dg15da57gy3zvfchnwwpr21n1gva7mqwpwr958ni2034smk"))))
(build-system python-build-system)
(arguments
`(#:phases
@ -157,25 +156,17 @@ networks.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(onionshare (string-append out "/share/onionshare")))
(substitute*
"install/pyinstaller.spec"
;; inform onionshare where the 'resources' files are installed
(("../resources") onionshare))
(substitute*
"onionshare/strings.py"
(substitute* "onionshare/strings.py"
;; correct the locale directory
(("helpers.get_resource_path\\('locale'\\)")
(string-append "'" onionshare "/locale'")))
(substitute*
"onionshare/helpers.py"
(substitute* "onionshare/helpers.py"
;; correct the location of version.txt
(("/usr") out)
(("get_resource_path\\('version.txt'\\)")
(string-append "'" onionshare "/version.txt'"))
(("get_resource_path\\('wordlist.txt'\\)")
(string-append "'" onionshare "/wordlist.txt'")))
(substitute*
"onionshare/web.py"
(substitute* "onionshare/web.py"
;; fix the location of the html files
(("helpers.get_resource_path\\('html/denied.html'\\)")
(string-append "'" onionshare "/html/denied.html'"))
@ -183,25 +174,26 @@ networks.")
(string-append "'" onionshare "/html/404.html'"))
(("helpers.get_resource_path\\('html/index.html'\\)")
(string-append "'" onionshare "/html/index.html'")))
(substitute*
"onionshare_gui/file_selection.py"
(substitute* "onionshare_gui/file_selection.py"
;; fancy box image in the GUI
(("helpers.get_resource_path\\('images/drop_files.png'\\)")
(string-append "'" onionshare "/images/drop_files.png'")))
(substitute*
"onionshare_gui/server_status.py"
(substitute* "onionshare_gui/server_status.py"
(("helpers.get_resource_path\\('images/server_stopped.png'\\)")
(string-append "'" onionshare "/images/server_stopped.png'"))
(("helpers.get_resource_path\\('images/server_working.png'\\)")
(string-append "'" onionshare "/images/server_working.png'"))
(("helpers.get_resource_path\\('images/server_started.png'\\)")
(string-append "'" onionshare "/images/server_started.png'")))
(substitute*
"onionshare_gui/onionshare_gui.py"
(substitute* "onionshare_gui/onionshare_gui.py"
;; for the icon on the GUI
(("helpers.get_resource_path\\('images/logo.png'\\)")
(string-append "'" onionshare "/images/logo.png'")))
(substitute*
"install/onionshare.desktop"
(("/usr") out))
(substitute* '("setup.py" "onionshare/helpers.py")
(("sys.prefix,") (string-append "'" out "',")))
(substitute* "setup.py"
;; for the nautilus plugin
(("/usr/share/nautilus") "share/nautilus"))
#t)))
(delete 'check)
(add-before 'strip 'tests