gnu: perl-tk: Update to 804.033.
* gnu/packages/tcl.scm (perl-tk): Update to 804.033. [source]: Remove patch. * gnu/packages/patches/perl-tk-x11-discover.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove patch.
This commit is contained in:
parent
39eefcee97
commit
e5a2edeba0
|
@ -654,7 +654,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/perl-no-sys-dirs.patch \
|
||||
gnu/packages/patches/perl-module-pluggable-search.patch \
|
||||
gnu/packages/patches/perl-source-date-epoch.patch \
|
||||
gnu/packages/patches/perl-tk-x11-discover.patch \
|
||||
gnu/packages/patches/pidgin-add-search-path.patch \
|
||||
gnu/packages/patches/pingus-sdl-libs-config.patch \
|
||||
gnu/packages/patches/plink-1.07-unclobber-i.patch \
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
On non-x86_64 systems, this conditional can cause a specified X11 build value
|
||||
to be overwritten to null, causing x11 discovery to fail.
|
||||
|
||||
--- a/myConfig 2014-05-12 11:16:48.152719722 -0500
|
||||
+++ b/myConfig 2014-05-12 11:16:24.704719113 -0500
|
||||
@@ -350,7 +350,7 @@
|
||||
#
|
||||
# Prefer 64bit libraries on certain architectures
|
||||
#
|
||||
- unless (defined $xlib and $Config{'archname'} =~ m/x86_64/)
|
||||
+ unless (defined $xlib or not $Config{'archname'} =~ m/x86_64/)
|
||||
{
|
||||
$xlib64 = &lX11(0, chooseX11(</usr/X11*/lib64>));
|
||||
}
|
|
@ -2,6 +2,7 @@
|
|||
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -187,7 +188,7 @@ interfaces (GUIs) in the Tcl language.")
|
|||
(define-public perl-tk
|
||||
(package
|
||||
(name "perl-tk")
|
||||
(version "804.032")
|
||||
(version "804.033")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -195,8 +196,7 @@ interfaces (GUIs) in the Tcl language.")
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0jarvplhfvnm0shhdm2a5zczlnk9mkf8jvfjiwyhjrr3cy1gl0w0"))
|
||||
(patches (list (search-patch "perl-tk-x11-discover.patch")))))
|
||||
"1bc8bacsf95598yimrxijymb3advrgan73pqxj75qmd20ydnwxc4"))))
|
||||
(build-system perl-build-system)
|
||||
(native-inputs `(("pkg-config" ,pkg-config)))
|
||||
(inputs `(("libx11" ,libx11)
|
||||
|
|
Loading…
Reference in New Issue