Merge branch 'media-updates'

master
Mark H Weaver 2016-02-25 13:50:19 -05:00
commit e62b5c6903
20 changed files with 403 additions and 528 deletions

View File

@ -4648,6 +4648,8 @@ list of updaters). Currently, @var{updater} may be one of:
the updater for GNU packages;
@item gnome
the updater for GNOME packages;
@item xorg
the updater for X.org packages;
@item elpa
the updater for @uref{http://elpa.gnu.org/, ELPA} packages;
@item cran

View File

@ -771,17 +771,9 @@ dist_patch_DATA = \
gnu/packages/patches/xf86-video-intel-compat-api.patch \
gnu/packages/patches/xf86-video-intel-glibc-2.20.patch \
gnu/packages/patches/xf86-video-mach64-glibc-2.20.patch \
gnu/packages/patches/xf86-video-mga-glibc-2.20.patch \
gnu/packages/patches/xf86-video-nv-remove-mibstore.patch \
gnu/packages/patches/xf86-video-openchrome-glibc-2.20.patch \
gnu/packages/patches/xf86-video-r128-glibc-2.20.patch \
gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch \
gnu/packages/patches/xf86-video-sis-fix-exa-crash.patch \
gnu/packages/patches/xf86-video-sis-update-api.patch \
gnu/packages/patches/xf86-video-tdfx-remove-mibstore.patch \
gnu/packages/patches/xf86-video-tga-remove-mibstore.patch \
gnu/packages/patches/xf86-video-trident-remove-mibstore.patch \
gnu/packages/patches/xf86-video-vmware-glibc-2.20.patch \
gnu/packages/patches/xfce4-panel-plugins.patch \
gnu/packages/patches/xfce4-session-fix-xflock4.patch \
gnu/packages/patches/xfce4-settings-defaults.patch \

View File

@ -82,14 +82,14 @@ freedesktop.org project.")
(define-public libinput
(package
(name "libinput")
(version "0.21.0")
(version "1.1.902")
(source (origin
(method url-fetch)
(uri (string-append "http://freedesktop.org/software/libinput/"
(uri (string-append "https://freedesktop.org/software/libinput/"
name "-" version ".tar.xz"))
(sha256
(base32
"0l7mhdr50g11hxg2pz8ihsgzbm0810syj05d3555rzhda6g7mkkw"))))
"19wa5yizc3nfq3gibyqb3ygdvcs7v7bz1m5ifv0f4va3igxc3nk3"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@ -97,7 +97,8 @@ freedesktop.org project.")
`(("libudev" ,eudev))) ; required by libinput.pc
(inputs
`(("libevdev" ,libevdev)
("mtdev" ,mtdev)))
("mtdev" ,mtdev)
("libwacom" ,libwacom)))
(home-page "http://www.freedesktop.org/wiki/Software/libinput/")
(synopsis "Input devices handling library")
(description

View File

@ -192,7 +192,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
(version "11.0.3")
(version "11.0.9")
(source
(origin
(method url-fetch)
@ -200,7 +200,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz"))
(sha256
(base32
"1mikw0biw0wxq0fn3cp18bm6kjrkd66fy84774yc5b91rvp94adb"))))
"009b3nq8ly5nzy9cxi9cxf4qasrhggjz0v0q87rwq5kaqvqjy9m1"))))
(build-system gnu-build-system)
(propagated-inputs
`(("glproto" ,glproto)

View File

@ -28,21 +28,33 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages bison)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages curl)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages mp3)
#:use-module (gnu packages perl)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages qt)
#:use-module (gnu packages rdf)
#:use-module (gnu packages video)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xiph)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages ssh)
#:use-module (gnu packages telephony)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages yasm)
#:use-module (gnu packages xml))
@ -83,7 +95,7 @@ arrays of data.")
(define-public gstreamer
(package
(name "gstreamer")
(version "1.6.1")
(version "1.6.3")
(source
(origin
(method url-fetch)
@ -92,7 +104,7 @@ arrays of data.")
version ".tar.xz"))
(sha256
(base32
"172w1bpnkn6mm1wi37n03apdbb6cdkykhzjf1vfxchcd7hhkyflp"))))
"093zldafh7xh3lrlwzm7j0vvjz6k9ca83wqil40gfz5qcy6mdy92"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
@ -131,15 +143,15 @@ This package provides the core library and elements.")
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
(version "1.6.1")
(version "1.6.3")
(source
(origin
(method url-fetch)
(uri (string-append "http://gstreamer.freedesktop.org/src/" name "/"
(uri (string-append "https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256
(base32
"18sbyjcp281zb3bsqji3pglsdsxi0s6ai7rx90sx8cpflkxdqcwm"))))
"0xbskifk95rw7jd85sqjrmqh2kys1bpi0inrxyapx1x4vf7ly5dn"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
@ -168,12 +180,11 @@ This package provides the core library and elements.")
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))
#:phases
(alist-cons-before
'configure 'patch
(lambda _
(substitute* "tests/check/libs/pbutils.c"
(("/bin/sh") (which "sh"))))
%standard-phases)))
(modify-phases %standard-phases
(add-before 'configure 'patch
(lambda _
(substitute* "tests/check/libs/pbutils.c"
(("/bin/sh") (which "sh"))))))))
(home-page "http://gstreamer.freedesktop.org/")
(synopsis
"Plugins for the GStreamer multimedia library")
@ -185,16 +196,16 @@ for the GStreamer multimedia library.")
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
(version "1.6.1")
(version "1.6.3")
(source
(origin
(method url-fetch)
(uri (string-append
"https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-"
version ".tar.xz"))
"https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256
(base32
"0darc3058kbnql3mnlpizl0sq0hhli7vkm0rpqb7nywz14abim46"))))
"0xx16h0q63gs3pxlzdflnpyssba3vcrh1qnzplg4d0ra1fvrvc94"))))
(build-system gnu-build-system)
(inputs
`(("aalib" ,aalib)
@ -228,7 +239,7 @@ for the GStreamer multimedia library.")
'unpack 'disable-failing-rtprtx-tests
(lambda _
;; Disable rtprtx tests that frequently fail.
;; XXX FIXME: Try removing this for version > 1.6.1.
;; XXX FIXME: Try removing this for version > 1.6.3.
(substitute* "tests/check/elements/rtprtx.c"
(("tcase_add_test \\(tc_chain,\
(test_rtxsender_max_size_packets|test_rtxreceive_data_reconstruction)\\);" all)
@ -242,10 +253,83 @@ GStreamer multimedia library. This set contains those plug-ins which the
developers consider to have good quality code and correct functionality.")
(license lgpl2.0+)))
(define-public gst-plugins-bad
(package
(name "gst-plugins-bad")
(version "1.6.3")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/src/"
name "/" name "-" version ".tar.xz"))
(sha256
(base32
"0q9s5da54819gwncmdi95l5qzx97l9vxk6adx4zmx73a3l82j6wp"))))
(outputs '("out" "doc"))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; XXX: 11 of 54 tests fail
#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))))
(propagated-inputs
`(("gst-plugins-base" ,gst-plugins-base)))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("python" ,python)))
(inputs
;; XXX: The following dependencies are missing:
;; vo-amrwbenc, vo-aacenc, bs2b, chromaprint, directfb, daala, libdts,
;; faac, flite, libgsm, libde265, libmms, libmimic, mjpegtools,
;; mpeg2enc, libofa, opencv, openh264, openni2, libtimemmgr, wildmidi,
;; openspc, gme, sbc, schroedinger, zbar, librtmp, spandsp, x265
`(("bluez" ,bluez)
("curl" ,curl)
("faad2" ,faad2)
("fluidsynth" ,fluidsynth)
("gtk+" ,gtk+)
("ladspa" ,ladspa)
("libass" ,libass)
("libdvdnav" ,libdvdnav)
("libdvdread" ,libdvdread)
("libgcrypt" ,libgcrypt)
("libgudev" ,libgudev)
("libkate" ,libkate)
("libmodplug" ,libmodplug)
("librsvg" ,librsvg)
("libsndfile" ,libsndfile)
("libsrtp" ,libsrtp)
("libssh2" ,libssh2)
("libusb" ,libusb)
("libvdpau" ,libvdpau)
("libwebp" ,libwebp)
("libxml2" ,libxml2)
("lrdf" ,lrdf)
("mesa" ,mesa)
("mpg123" ,mpg123)
("neon" ,neon)
("openal" ,openal)
("openexr" ,openexr)
("openjpeg" ,openjpeg)
("openssl" ,openssl)
("opus" ,opus)
("orc" ,orc)
("qt" ,qt)
("soundtouch" ,soundtouch)
("wayland" ,wayland)))
(home-page "http://gstreamer.freedesktop.org/")
(synopsis "Plugins for the GStreamer multimedia library")
(description
"GStreamer Bad Plug-ins is a set of plug-ins whose quality aren't up to
par compared to the rest.")
(license lgpl2.0+)))
(define-public gst-plugins-ugly
(package
(name "gst-plugins-ugly")
(version "1.6.1")
(version "1.6.3")
(source
(origin
(method url-fetch)
@ -253,7 +337,7 @@ developers consider to have good quality code and correct functionality.")
name "/" name "-" version ".tar.xz"))
(sha256
(base32
"0mvasl1pwq70w2kmrkcrg77kggl5q7jqybi7fkvy3vr28c7gkhqc"))))
"0r6h3ys5n90jv3c06crxzcac561z07s4h04hy5i8ybw8qyvzgv1g"))))
(build-system gnu-build-system)
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
@ -283,7 +367,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
(define-public gst-libav
(package
(name "gst-libav")
(version "1.6.1")
(version "1.6.3")
(source (origin
(method url-fetch)
(uri (string-append
@ -291,7 +375,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
name "-" version ".tar.xz"))
(sha256
(base32
"1a9pc7zp5rg0cvpx8gqkr21w73i6p9xa505a34day9f8p3lfim94"))))
"1aylbg1xnm68c3wc49mzx813qhsjfg23hqnjqqwdwdq31839qyw5"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-system-libav")

View File

@ -1,17 +0,0 @@
Fix test compilation with exa.h in configure when using glibc 2.20.
Inspired by a patch by Peter Hutterer <peter.hutterer@who-t.net>.
See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
--- xf86-video-mga-1.6.3/configure.~1~ 2013-12-04 21:10:25.000000000 -0500
+++ xf86-video-mga-1.6.3/configure 2014-12-19 01:06:23.005774736 -0500
@@ -18464,7 +18464,9 @@
SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
- ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default"
+ ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default
+#include <xorg-server.h>
+"
if test "x$ac_cv_header_exa_h" = xyes; then :
have_exa_h="yes"
else

View File

@ -1,17 +0,0 @@
Fix test compilation with exa.h in configure when using glibc 2.20.
Inspired by a patch by Peter Hutterer <peter.hutterer@who-t.net>.
See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
--- xf86-video-r128-6.9.2/configure.~1~ 2013-10-02 14:38:15.000000000 -0400
+++ xf86-video-r128-6.9.2/configure 2014-12-19 01:23:03.346735159 -0500
@@ -18400,7 +18400,9 @@
SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
- ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default"
+ ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default
+#include <xorg-server.h>
+"
if test "x$ac_cv_header_exa_h" = xyes; then :
have_exa_h="yes"
else

View File

@ -1,16 +0,0 @@
Removes references to mibstore.h and miInitializeBackingStore, which
have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
wrote: "It was a noop for at least 5 years and it has been removed."
See: http://patches.openembedded.org/patch/46133/
--- xf86-video-siliconmotion-1.7.7/src/smi_driver.c.~1~ 2012-07-17 00:53:21.000000000 -0400
+++ xf86-video-siliconmotion-1.7.7/src/smi_driver.c 2014-12-19 01:30:16.708884086 -0500
@@ -1750,8 +1750,6 @@
"Done writing mode. Register dump:\n");
SMI_PrintRegs(pScrn);
- miInitializeBackingStore(pScreen);
-
#ifdef HAVE_XMODES
xf86DiDGAInit(pScreen, (unsigned long)(pSmi->FBBase + pScrn->fbOffset));
#endif

View File

@ -1,45 +0,0 @@
Fix X server crash when sis driver is used with EXA acceleration.
Source: http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/trusty/xserver-xorg-video-sis/trusty/revision/24/debian/patches/fix-exa-crash.diff
The patch was originally proposed by nihui:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-sis/+bug/1066464/comments/13
--- a/src/sis310_accel.c
+++ b/src/sis310_accel.c
@@ -1874,7 +1874,7 @@
{
ScrnInfoPtr pScrn = xf86ScreenToScrn(pDst->drawable.pScreen);
SISPtr pSiS = SISPTR(pScrn);
- unsigned char *dst = pDst->devPrivate.ptr;
+ unsigned char *dst = ((unsigned char *) pSiS->FbBase) + exaGetPixmapOffset(pDst);
int dst_pitch = exaGetPixmapPitch(pDst);
(pSiS->SyncAccel)(pScrn);
@@ -1882,7 +1882,7 @@
if(pDst->drawable.bitsPerPixel < 8)
return FALSE;
- dst += (x * pDst->drawable.bitsPerPixel / 8) + (y * src_pitch);
+ dst += (x * pDst->drawable.bitsPerPixel / 8) + (y * dst_pitch);
while(h--) {
SiSMemCopyToVideoRam(pSiS, dst, (unsigned char *)src,
(w * pDst->drawable.bitsPerPixel / 8));
@@ -1953,7 +1953,7 @@
{
ScrnInfoPtr pScrn = xf86ScreenToScrn(pSrc->drawable.pScreen);
SISPtr pSiS = SISPTR(pScrn);
- unsigned char *src = pSrc->devPrivate.ptr;
+ unsigned char *src = ((unsigned char *) pSiS->FbBase) + exaGetPixmapOffset(pSrc);
int src_pitch = exaGetPixmapPitch(pSrc);
int size = src_pitch < dst_pitch ? src_pitch : dst_pitch;
@@ -1964,7 +1964,7 @@
src += (x * pSrc->drawable.bitsPerPixel / 8) + (y * src_pitch);
while(h--) {
- SiSMemCopyFromVideoRam(pSiS, (unsigned char *)dst, src, size);
+ SiSMemCopyFromVideoRam(pSiS, (unsigned char *)dst, src, (w * pSrc->drawable.bitsPerPixel / 8));
src += src_pitch;
dst += dst_pitch;
}

View File

@ -1,128 +0,0 @@
Update xf86-video-sis to the current xorg-server API.
Copied from: http://pkgs.fedoraproject.org/cgit/xorg-x11-drv-sis.git/tree/sis-0.10.7-git.patch?id=2705859f0ddc7ee7a3b07f21b442ebeab5df1276
Commit log: http://pkgs.fedoraproject.org/cgit/xorg-x11-drv-sis.git/log/sis-0.10.7-git.patch
Patch by Adam Jackson <ajax@redhat.com>
diff --git a/src/sis.h b/src/sis.h
index 46fca2a..20e6134 100644
--- a/src/sis.h
+++ b/src/sis.h
@@ -75,7 +75,6 @@
#include "compiler.h"
#include "xf86Pci.h"
-#include "xf86Priv.h"
#include "xf86_OSproc.h"
#if GET_ABI_MAJOR(ABI_VIDEODRV_VERSION) < 6
#include "xf86Resources.h"
diff --git a/src/sis_driver.c b/src/sis_driver.c
index 61e8075..0fd83d7 100644
--- a/src/sis_driver.c
+++ b/src/sis_driver.c
@@ -57,7 +57,6 @@
#include "fb.h"
#include "micmap.h"
#include "mipointer.h"
-#include "mibstore.h"
#include "edid.h"
#define SIS_NEED_inSISREG
@@ -94,6 +93,10 @@
#include "dri.h"
#endif
+#ifndef DEFAULT_DPI
+#define DEFAULT_DPI 96
+#endif
+
/*
* LookupWindow was removed with video abi 11.
*/
@@ -7344,7 +7347,11 @@ SISUnmapMem(ScrnInfoPtr pScrn)
if(pSiSEnt->MapCountIOBase) {
pSiSEnt->MapCountIOBase--;
if((pSiSEnt->MapCountIOBase == 0) || (pSiSEnt->forceUnmapIOBase)) {
+#ifndef XSERVER_LIBPCIACCESS
xf86UnMapVidMem(pScrn->scrnIndex, (pointer)pSiSEnt->IOBase, (pSiS->mmioSize * 1024));
+#else
+ pci_device_unmap_range(pSiS->PciInfo, pSiSEnt->IOBase, (pSiS->mmioSize * 1024));
+#endif
pSiSEnt->IOBase = NULL;
pSiSEnt->MapCountIOBase = 0;
pSiSEnt->forceUnmapIOBase = FALSE;
@@ -7355,7 +7362,11 @@ SISUnmapMem(ScrnInfoPtr pScrn)
if(pSiSEnt->MapCountIOBaseDense) {
pSiSEnt->MapCountIOBaseDense--;
if((pSiSEnt->MapCountIOBaseDense == 0) || (pSiSEnt->forceUnmapIOBaseDense)) {
+#ifndef XSERVER_LIBPCIACCESS
xf86UnMapVidMem(pScrn->scrnIndex, (pointer)pSiSEnt->IOBaseDense, (pSiS->mmioSize * 1024));
+#else
+ pci_device_unmap_range(pSiS->PciInfo, (pointer)pSiSEnt->IOBaseDense, (pSiS->mmioSize * 1024));
+#endif
pSiSEnt->IOBaseDense = NULL;
pSiSEnt->MapCountIOBaseDense = 0;
pSiSEnt->forceUnmapIOBaseDense = FALSE;
@@ -7366,7 +7377,11 @@ SISUnmapMem(ScrnInfoPtr pScrn)
if(pSiSEnt->MapCountFbBase) {
pSiSEnt->MapCountFbBase--;
if((pSiSEnt->MapCountFbBase == 0) || (pSiSEnt->forceUnmapFbBase)) {
+#ifndef XSERVER_LIBPCIACCESS
xf86UnMapVidMem(pScrn->scrnIndex, (pointer)pSiSEnt->RealFbBase, pSiS->FbMapSize);
+#else
+ pci_device_unmap_range(pSiS->PciInfo, (pointer)pSiSEnt->RealFbBase, pSiS->FbMapSize);
+#endif
pSiSEnt->FbBase = pSiSEnt->RealFbBase = NULL;
pSiSEnt->MapCountFbBase = 0;
pSiSEnt->forceUnmapFbBase = FALSE;
@@ -7376,13 +7391,25 @@ SISUnmapMem(ScrnInfoPtr pScrn)
}
} else {
#endif
+#ifndef XSERVER_LIBPCIACCESS
xf86UnMapVidMem(pScrn->scrnIndex, (pointer)pSiS->IOBase, (pSiS->mmioSize * 1024));
+#else
+ pci_device_unmap_range(pSiS->PciInfo, (pointer)pSiS->IOBase, (pSiS->mmioSize * 1024));
+#endif
pSiS->IOBase = NULL;
#ifdef __alpha__
+#ifndef XSERVER_LIBPCIACCESS
xf86UnMapVidMem(pScrn->scrnIndex, (pointer)pSiS->IOBaseDense, (pSiS->mmioSize * 1024));
+#else
+ pci_device_unmap_range(pSiS->PciInfo, (pointer)pSiS->IOBaseDense, (pSiS->mmioSize * 1024));
+#endif
pSiS->IOBaseDense = NULL;
#endif
+#ifndef XSERVER_LIBPCIACCESS
xf86UnMapVidMem(pScrn->scrnIndex, (pointer)pSiS->RealFbBase, pSiS->FbMapSize);
+#else
+ pci_device_unmap_range(pSiS->PciInfo, (pointer)pSiS->RealFbBase, pSiS->FbMapSize);
+#endif
pSiS->FbBase = pSiS->RealFbBase = NULL;
#ifdef SISDUALHEAD
}
@@ -8859,7 +8886,6 @@ SISScreenInit(SCREEN_INIT_ARGS_DECL)
}
pSiS->SiSFastVidCopyDone = TRUE;
- miInitializeBackingStore(pScreen);
xf86SetBackingStore(pScreen);
xf86SetSilkenMouse(pScreen);
@@ -9352,7 +9378,14 @@ SISMergedPointerMoved(SCRN_ARG_TYPE arg, int x, int y)
}
if(doit) {
sigstate = xf86BlockSIGIO();
-#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 15
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 18
+ {
+ double dx = x, dy = y;
+ miPointerSetPosition(inputInfo.pointer, Absolute, &dx, &dy, NULL, NULL);
+ x = (int)dx;
+ y = (int)dy;
+ }
+#elif GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 15
{
double dx = x, dy = y;
miPointerSetPosition(inputInfo.pointer, Absolute, &dx, &dy);

View File

@ -1,26 +0,0 @@
Removes references to mibstore.h and miInitializeBackingStore, which
have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
wrote: "It was a noop for at least 5 years and it has been removed."
See: http://patches.openembedded.org/patch/46133/
--- xf86-video-tdfx-1.4.5/src/tdfx_driver.c.~1~ 2012-07-17 01:21:16.000000000 -0400
+++ xf86-video-tdfx-1.4.5/src/tdfx_driver.c 2014-12-19 01:36:42.762798424 -0500
@@ -62,10 +62,6 @@
#include "compiler.h"
-/* Drivers using the mi implementation of backing store need: */
-
-#include "mibstore.h"
-
/* All drivers using the vgahw module need this */
/* This driver needs to be modified to not use vgaHW for multihead operation */
#include "vgaHW.h"
@@ -2373,7 +2369,6 @@
}
}
- miInitializeBackingStore(pScreen);
xf86SetBackingStore(pScreen);
xf86SetSilkenMouse(pScreen);

View File

@ -1,23 +0,0 @@
Removes references to mibstore.h and miInitializeBackingStore, which
have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
wrote: "It was a noop for at least 5 years and it has been removed."
See: http://patches.openembedded.org/patch/46133/
--- xf86-video-trident-1.3.6/src/trident_driver.c.~1~ 2012-07-15 22:16:00.000000000 -0400
+++ xf86-video-trident-1.3.6/src/trident_driver.c 2014-12-19 01:45:29.529410518 -0500
@@ -56,7 +56,6 @@
#include "mipointer.h"
-#include "mibstore.h"
#include "shadow.h"
#include "trident.h"
#include "trident_regs.h"
@@ -3037,7 +3036,6 @@
TridentAccelInit(pScreen);
}
- miInitializeBackingStore(pScreen);
xf86SetBackingStore(pScreen);
/* Initialise cursor functions */

View File

@ -1,15 +0,0 @@
Allow builds with glibc 2.20.
Based on a patch by Peter Hutterer <peter.hutterer@who-t.net>.
See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
--- xf86-video-vmware-13.0.2/vmwgfx/vmwgfx_overlay.c.~1~ 2014-03-20 09:15:03.000000000 -0400
+++ xf86-video-vmware-13.0.2/vmwgfx/vmwgfx_overlay.c 2014-12-19 02:31:34.759122552 -0500
@@ -35,6 +35,8 @@
*/
+#include <xorg-server.h>
+
#include "xf86xv.h"
#include "fourcc.h"
#define debug_printf(...)

View File

@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@ -114,15 +115,15 @@ rates.")
(define pulseaudio
(package
(name "pulseaudio")
(version "6.0")
(version "8.0")
(source (origin
(method url-fetch)
(uri (string-append
"https://freedesktop.org/software/pulseaudio/releases/pulseaudio-"
version ".tar.xz"))
"https://freedesktop.org/software/pulseaudio/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
"1xpnfxa0d8pgf6b4qdgnkcvrvdxbbbjd5ync19h0f5hbp3h401mm"))
"128rrlvrgb4ia3pbzipf5mi6nvrpm6zmxn5r3bynqiikhvify3k9"))
(modules '((guix build utils)))
(snippet
;; Disable console-kit support by default since it's deprecated

View File

@ -774,7 +774,7 @@ projects while introducing many more.")
(define-public libvpx
(package
(name "libvpx")
(version "1.4.0")
(version "1.5.0")
(source (origin
(method url-fetch)
(uri (string-append "http://storage.googleapis.com/"
@ -782,23 +782,23 @@ projects while introducing many more.")
name "-" version ".tar.bz2"))
(sha256
(base32
"1r0ql5kgy0c8mh5w7iiqvsd7w5njl9f9cclc7m52ln8assrdk0pm"))))
"15v7qw0ydyxn08ksb6lxn1l51pxgpwgshdwd3275yrr5hs86fv9h"))))
(build-system gnu-build-system)
(arguments
`(#:phases (alist-replace
'configure
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CONFIG_SHELL" (which "bash"))
(let ((out (assoc-ref outputs "out")))
(setenv "LDFLAGS"
(string-append "-Wl,-rpath=" out "/lib"))
(zero? (system* "./configure"
"--enable-shared"
"--as=yasm"
;; Limit size to avoid CVE-2015-1258
"--size-limit=16384x16384"
(string-append "--prefix=" out)))))
%standard-phases)
`(#:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CONFIG_SHELL" (which "bash"))
(let ((out (assoc-ref outputs "out")))
(setenv "LDFLAGS"
(string-append "-Wl,-rpath=" out "/lib"))
(zero? (system* "./configure"
"--enable-shared"
"--as=yasm"
;; Limit size to avoid CVE-2015-1258
"--size-limit=16384x16384"
(string-append "--prefix=" out)))))))
#:tests? #f)) ; no check target
(native-inputs
`(("perl" ,perl)

View File

@ -626,19 +626,21 @@ Escape key when Left Control is pressed and released on its own.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("glib" ,glib)
("gtk+" ,gtk+)
`(("gtk+" ,gtk+)
("libgudev" ,libgudev)
("eudev" ,eudev)
("libxml2" ,libxml2)))
(propagated-inputs
;; libwacom includes header files that include GLib, and libinput uses
;; those header files.
`(("glib" ,glib)))
(home-page "http://linuxwacom.sourceforge.net/")
(synopsis "Helper library for Wacom tablet settings")
(description
"Libwacom is a library to help implement Wacom tablet settings. It
is intended to be used by client-programs that need model identification. It
is already being used by the gnome-settings-daemon and the GNOME 3.4 Control
Center Wacom tablet applet. In the future, the xf86-input-wacom driver may
use it as well.")
"Libwacom is a library to help implement Wacom tablet settings. It is
intended to be used by client-programs that need model identification. It is
already being used by the gnome-settings-daemon and the GNOME Control Center
Wacom tablet applet.")
(license license:x11)))
(define-public xf86-input-wacom

File diff suppressed because it is too large Load Diff

View File

@ -40,6 +40,7 @@
#:use-module (srfi srfi-26)
#:use-module (ice-9 match)
#:export (xorg-configuration-file
%default-xorg-modules
xorg-start-command
%default-slim-theme
%default-slim-theme-name
@ -137,9 +138,52 @@ EndSection
"\n"
extra-config))
(define %default-xorg-modules
(list xf86-video-vesa
xf86-video-fbdev
xf86-video-modesetting
xf86-video-cirrus
xf86-video-intel
xf86-video-mach64
xf86-video-nouveau
xf86-video-nv
xf86-video-sis
xf86-input-libinput
xf86-input-evdev
xf86-input-keyboard
xf86-input-mouse
xf86-input-synaptics))
(define (xorg-configuration-directory modules)
"Return a directory that contains the @code{.conf} files for X.org that
includes the @code{share/X11/xorg.conf.d} directories of each package listed
in @var{modules}."
(computed-file "xorg.conf.d"
#~(begin
(use-modules (guix build utils)
(srfi srfi-1))
(define files
(append-map (lambda (module)
(find-files (string-append
module
"/share/X11/xorg.conf.d")
"\\.conf$"))
(list #$@modules)))
(mkdir #$output)
(for-each (lambda (file)
(symlink file
(string-append #$output "/"
(basename file))))
files)
#t)
#:modules '((guix build utils))))
(define* (xorg-start-command #:key
(guile (canonical-package guile-2.0))
(configuration-file (xorg-configuration-file))
(modules %default-xorg-modules)
(xorg-server xorg-server))
"Return a derivation that builds a @var{guile} script to start the X server
from @var{xorg-server}. @var{configuration-file} is the server configuration
@ -158,6 +202,7 @@ Usually the X server is started by a login manager."
"-logverbose" "-verbose"
"-xkbdir" (string-append #$xkeyboard-config "/share/X11/xkb")
"-config" #$configuration-file
"-configdir" #$(xorg-configuration-directory modules)
"-nolisten" "tcp" "-terminate"
;; Note: SLiM and other display managers add the

View File

@ -33,6 +33,7 @@
#:use-module (guix records)
#:use-module (guix upstream)
#:use-module (guix packages)
#:use-module (gnu packages)
#:export (gnu-package-name
gnu-package-mundane-name
gnu-package-copyright-holder
@ -57,7 +58,8 @@
gnu-package-name->name+version
%gnu-updater
%gnome-updater))
%gnome-updater
%xorg-updater))
;;; Commentary:
;;;
@ -508,6 +510,32 @@ elpa.gnu.org, and all the GNOME packages."
;; checksums.
#:file->signature (const #f))))
(define (xorg-package? package)
"Return true if PACKAGE is an X.org package, developed by X.org."
(define xorg-uri?
(match-lambda
((? string? uri)
(string-prefix? "mirror://xorg/" uri))
(_
#f)))
(match (package-source package)
((? origin? origin)
(match (origin-uri origin)
((? xorg-uri?) #t)
(_ #f)))
(_ #f)))
(define (latest-xorg-release package)
"Return the latest release of PACKAGE, the name of an X.org package."
(let ((uri (string->uri (origin-uri (package-source (specification->package package))))))
(false-if-ftp-error
(latest-ftp-release
package
#:server "ftp.freedesktop.org"
#:directory
(string-append "/pub/xorg/" (dirname (uri-path uri)))))))
(define %gnu-updater
(upstream-updater
(name 'gnu)
@ -522,4 +550,11 @@ elpa.gnu.org, and all the GNOME packages."
(pred gnome-package?)
(latest latest-gnome-release)))
(define %xorg-updater
(upstream-updater
(name 'xorg)
(description "Updater for X.org packages")
(pred xorg-package?)
(latest latest-xorg-release)))
;;; gnu-maintenance.scm ends here

View File

@ -32,7 +32,7 @@
#:use-module (guix scripts graph)
#:use-module (guix monads)
#:use-module ((guix gnu-maintenance)
#:select (%gnu-updater %gnome-updater))
#:select (%gnu-updater %gnome-updater %xorg-updater))
#:use-module (guix import elpa)
#:use-module (guix import cran)
#:use-module (guix gnupg)
@ -194,6 +194,7 @@ unavailable optional dependencies such as Guile-JSON."
;; List of "updaters" used by default. They are consulted in this order.
(list-updaters %gnu-updater
%gnome-updater
%xorg-updater
%elpa-updater
%cran-updater
%bioconductor-updater