gnu: w3m: Update patch to use '-p1'.

* gnu/packages/patches/w3m-fix-compile.patch: Rename this file...
* gnu/packages/patches/w3m-libgc.patch: ...to this, and adjust patch
prefix level to '-p1'.
* gnu-system.am (dist_patch_DATA): Update patch name.
* gnu/packages/w3m.scm (w3m)[source]: Update patch name.
[source]: Drop patch flag -p0.
master
Leo Famulari 2016-01-06 10:43:18 -05:00
parent d4aaf95401
commit e6352001c4
4 changed files with 31 additions and 18 deletions

View File

@ -698,7 +698,7 @@ dist_patch_DATA = \
gnu/packages/patches/valgrind-enable-arm.patch \
gnu/packages/patches/vpnc-script.patch \
gnu/packages/patches/vtk-mesa-10.patch \
gnu/packages/patches/w3m-fix-compile.patch \
gnu/packages/patches/w3m-libgc.patch \
gnu/packages/patches/webkitgtk-2.4-sql-init-string.patch \
gnu/packages/patches/weechat-python.patch \
gnu/packages/patches/weex-vacopy.patch \

View File

@ -1,15 +0,0 @@
https://bugs.archlinux.org/task/33397
diff -aur old/main.c new/main.c
--- main.c 2013-01-14 18:16:14.216210053 -0600
+++ main.c 2013-01-14 18:17:28.816220559 -0600
@@ -833,7 +833,8 @@
mySignal(SIGPIPE, SigPipe);
#endif
- orig_GC_warn_proc = GC_set_warn_proc(wrap_GC_warn_proc);
+ orig_GC_warn_proc = GC_get_warn_proc();
+ GC_set_warn_proc(wrap_GC_warn_proc);
err_msg = Strnew();
if (load_argc == 0) {
/* no URL specified */

View File

@ -0,0 +1,28 @@
This patch fixes w3m compilation with libgc > 7.2.
Reported:
https://bugs.archlinux.org/task/33397
Patch with explanation:
http://anonscm.debian.org/cgit/collab-maint/w3m.git/commit/?id=770eec8304bdbe458
---
main.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/main.c b/main.c
index b421943..249eb1a 100644
--- a/main.c
+++ b/main.c
@@ -833,7 +833,8 @@ main(int argc, char **argv, char **envp)
mySignal(SIGPIPE, SigPipe);
#endif
- orig_GC_warn_proc = GC_set_warn_proc(wrap_GC_warn_proc);
+ orig_GC_warn_proc = GC_get_warn_proc();
+ GC_set_warn_proc(wrap_GC_warn_proc);
err_msg = Strnew();
if (load_argc == 0) {
/* no URL specified */
--
2.6.4

View File

@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@ -43,8 +44,7 @@
"1qx9f0kprf92r1wxl3sacykla0g04qsi0idypzz24b7xy9ix5579"))
;; cf. https://bugs.archlinux.org/task/33397
(patches (list (search-patch "w3m-fix-compile.patch")))
(patch-flags '("-p0"))))
(patches (list (search-patch "w3m-libgc.patch")))))
(build-system gnu-build-system)
(arguments `(#:tests? #f ; no check target
#:phases (alist-cons-before