gnu: Add cpufrequtils.

* gnu/packages/linux.scm (cpufrequtils): New variable.
* gnu/packages/patches/cpufrequtils-fix-aclocal.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
master
Taylan Ulrich Bayırlı/Kammer 2015-02-18 21:20:57 +01:00
parent a9a1a40b50
commit e6caa52d85
3 changed files with 75 additions and 0 deletions

View File

@ -374,6 +374,7 @@ dist_patch_DATA = \
gnu/packages/patches/cpio-CVE-2014-9112-pt4.patch \
gnu/packages/patches/cpio-CVE-2014-9112-pt5.patch \
gnu/packages/patches/cpio-gets-undeclared.patch \
gnu/packages/patches/cpufrequtils-fix-aclocal.patch \
gnu/packages/patches/cssc-gets-undeclared.patch \
gnu/packages/patches/cssc-missing-include.patch \
gnu/packages/patches/clucene-contribs-lib.patch \

View File

@ -1961,3 +1961,31 @@ also contains the libsysfs library.")
(("includedir='(\\$\\{prefix\\}/include)'" all orig)
(string-append "includedir='" orig "/sysfs'")))))))
(synopsis "System utilities based on Linux sysfs (version 1.x)")))
(define-public cpufrequtils
(package
(name "cpufrequtils")
(version "0.3")
(source
(origin
(method url-fetch)
(uri
(string-append
"https://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils-"
version ".tar.gz"))
(sha256
(base32 "0qfqv7nqmjfr3p0bwrdlxkiqwqr7vmx053cadaa548ybqbghxmvm"))
(patches (list (search-patch "cpufrequtils-fix-aclocal.patch")))))
(build-system gnu-build-system)
(native-inputs
`(("sysfsutils" ,sysfsutils-1)))
(arguments
'(#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))))
(home-page "https://www.kernel.org/pub/linux/utils/kernel/cpufreq/")
(synopsis "Utilities to get and set CPU frequency on Linux")
(description
"The cpufrequtils suite contains utilities to retreive CPU frequency
information, and set the CPU frequency if supported, using the cpufreq
capabilities of the Linux kernel.")
(license gpl2)))

View File

@ -0,0 +1,46 @@
Add an extra layer of quoting to ltmain.sh sanity check.
--- a/configure 2005-05-07 14:19:31.000000000 +0200
+++ b/configure 2015-02-10 11:16:32.456146934 +0100
@@ -6266,7 +6266,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
--- a/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
+++ b/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
@@ -246,7 +246,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
AC_MSG_RESULT(no)
echo
--- a/libcpufreq/configure 2005-05-07 14:19:31.000000000 +0200
+++ b/libcpufreq/configure 2015-02-10 11:16:32.456146934 +0100
@@ -6266,7 +6266,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
--- a/libcpufreq/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
+++ b/libcpufreq/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
@@ -246,7 +246,7 @@
exit 1
fi
gentoo_lt_version="1.5.16"
-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
AC_MSG_RESULT(no)
echo