gnu: pspp: Upgrade to 0.8.2

* gnu/packages/maths.scm (pspp): Update to 0.8.2.
* gnu/packages/patches/pspp-tests.patch: Deleted.
* gnu-system.am: Removed pspp-tests.patch from the manifest.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
John Darrington 2014-01-15 18:50:10 +01:00 committed by Ludovic Courtès
parent 2a5e15c6e1
commit e7d6f7bfa0
3 changed files with 2 additions and 17 deletions

View File

@ -276,7 +276,6 @@ dist_patch_DATA = \
gnu/packages/patches/perl-no-sys-dirs.patch \
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
gnu/packages/patches/procps-make-3.82.patch \
gnu/packages/patches/pspp-tests.patch \
gnu/packages/patches/pulseaudio-test-timeouts.patch \
gnu/packages/patches/pulseaudio-volume-test.patch \
gnu/packages/patches/python-fix-dbm.patch \

View File

@ -125,7 +125,7 @@ LP/MIP solver is included in the package.")
(define-public pspp
(package
(name "pspp")
(version "0.8.1")
(version "0.8.2")
(source
(origin
(method url-fetch)
@ -133,8 +133,7 @@ LP/MIP solver is included in the package.")
version ".tar.gz"))
(sha256
(base32
"0qhxsdbwxd3cn1shc13wxvx2lg32lp4z6sz24kv3jz7p5xfi8j7x"))
(patches (list (search-patch "pspp-tests.patch")))))
"1w7h3dglgx0jlq1wb605b8pgfsk2vr1q2q2rj7bsajh9ihbcsixr"))))
(build-system gnu-build-system)
(inputs
`(("cairo" ,cairo)

View File

@ -1,13 +0,0 @@
diff --git a/tests/output/render-test.c b/tests/output/render-test.c
index 5f4c1da..e9df96c 100644
--- a/tests/output/render-test.c
+++ b/tests/output/render-test.c
@@ -142,7 +142,7 @@ configure_drivers (int width, int length)
string_map_insert (&options, "left-margin", "0");
string_map_insert (&options, "right-margin", "0");
string_map_insert_nocopy (&options, xstrdup ("paper-size"),
- xasprintf ("%dx%dpt", width * 5, length * 8));
+ xasprintf ("%dx%dpt", width * 5, length * 16));
driver = output_driver_create (&options);
if (driver == NULL)
exit (EXIT_FAILURE);