gnu: findutils: Update to 4.6.0.
* gnu/packages/patches/findutils-absolute-paths.patch: Remove. * gnu/packages/patches/findutils-test-xargs.patch: New file. * gnu-system.am (dist_patch_DATA): Adjust accordingly. * gnu/packages/base.scm (findutils): Update to 4.6.0. Remove 'findutils-absolute-paths.patch' and add 'findutils-test-xargs.patch'.
This commit is contained in:
parent
7165a91c7d
commit
e80d2555f5
|
@ -461,8 +461,8 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/fasthenry-spUtils.patch \
|
gnu/packages/patches/fasthenry-spUtils.patch \
|
||||||
gnu/packages/patches/fasthenry-spSolve.patch \
|
gnu/packages/patches/fasthenry-spSolve.patch \
|
||||||
gnu/packages/patches/fasthenry-spFactor.patch \
|
gnu/packages/patches/fasthenry-spFactor.patch \
|
||||||
gnu/packages/patches/findutils-absolute-paths.patch \
|
|
||||||
gnu/packages/patches/findutils-localstatedir.patch \
|
gnu/packages/patches/findutils-localstatedir.patch \
|
||||||
|
gnu/packages/patches/findutils-test-xargs.patch \
|
||||||
gnu/packages/patches/flashrom-use-libftdi1.patch \
|
gnu/packages/patches/flashrom-use-libftdi1.patch \
|
||||||
gnu/packages/patches/flex-bison-tests.patch \
|
gnu/packages/patches/flex-bison-tests.patch \
|
||||||
gnu/packages/patches/flint-ldconfig.patch \
|
gnu/packages/patches/flint-ldconfig.patch \
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
|
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
|
||||||
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
||||||
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
|
||||||
|
@ -206,17 +206,17 @@ interactive means to merge two files.")
|
||||||
(define-public findutils
|
(define-public findutils
|
||||||
(package
|
(package
|
||||||
(name "findutils")
|
(name "findutils")
|
||||||
(version "4.4.2")
|
(version "4.6.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/findutils/findutils-"
|
(uri (string-append "mirror://gnu/findutils/findutils-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0amn0bbwqvsvvsh6drfwz20ydc2czk374lzw5kksbh6bf78k4ks3"))
|
"178nn4dl7wbcw499czikirnkniwnx36argdnqgz4ik9i6zvwkm6y"))
|
||||||
(patches (map search-patch
|
(patches (map search-patch
|
||||||
'("findutils-absolute-paths.patch"
|
'("findutils-localstatedir.patch"
|
||||||
"findutils-localstatedir.patch")))))
|
"findutils-test-xargs.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags (list
|
`(#:configure-flags (list
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
Fix use of LFS-style absolute paths.
|
|
||||||
|
|
||||||
Patches from Nixpkgs by Armijn Hemel <armijn@gpl-violations.org>
|
|
||||||
and Wouter den Breejen <uu@denbreejen.net>.
|
|
||||||
|
|
||||||
diff -ruN findutils-4.2.20/locate/updatedb.sh findutils-4.2.20.new/locate/updatedb.sh
|
|
||||||
--- findutils-4.2.20/locate/updatedb.sh 2005-01-24 17:12:35.000000000 +0100
|
|
||||||
+++ findutils-4.2.20.new/locate/updatedb.sh 2005-08-23 14:37:10.000000000 +0200
|
|
||||||
@@ -141,7 +141,7 @@
|
|
||||||
: ${code:=${LIBEXECDIR}/@code@}
|
|
||||||
|
|
||||||
|
|
||||||
-PATH=/bin:/usr/bin:${BINDIR}; export PATH
|
|
||||||
+PATH=/bin:/usr/bin:${BINDIR}:${PATH}; export PATH
|
|
||||||
|
|
||||||
: ${PRUNEFS="nfs NFS proc afs proc smbfs autofs iso9660 ncpfs coda devpts ftpfs devfs mfs sysfs shfs"}
|
|
||||||
|
|
||||||
diff -Naur findutils-4.2.30/xargs/xargs.c findutils-4.2.30_new/xargs/xargs.c
|
|
||||||
--- findutils-4.2.30/xargs/xargs.c 2007-02-27 11:21:08.000000000 +0100
|
|
||||||
+++ findutils-4.2.30_new/xargs/xargs.c 2007-07-17 19:02:05.000000000 +0200
|
|
||||||
@@ -402,7 +402,7 @@
|
|
||||||
int show_limits = 0; /* --show-limits */
|
|
||||||
int always_run_command = 1;
|
|
||||||
char *input_file = "-"; /* "-" is stdin */
|
|
||||||
- char *default_cmd = "/bin/echo";
|
|
||||||
+ char *default_cmd = "echo";
|
|
||||||
int (*read_args) PARAMS ((void)) = read_line;
|
|
||||||
void (*act_on_init_result)(void) = noop;
|
|
||||||
int env_too_big = 0;
|
|
|
@ -0,0 +1,22 @@
|
||||||
|
This test relies on 'xargs' being available in $PATH, which is not
|
||||||
|
the case when we build the initial Findutils doing bootstrapping.
|
||||||
|
Reported at <https://savannah.gnu.org/bugs/index.php?46786>.
|
||||||
|
|
||||||
|
--- findutils-4.6.0/find/testsuite/sv-34976-execdir-fd-leak.sh 2015-12-31 19:37:59.401526288 +0100
|
||||||
|
+++ findutils-4.6.0/find/testsuite/sv-34976-execdir-fd-leak.sh 2015-12-31 19:38:36.061770693 +0100
|
||||||
|
@@ -50,13 +50,14 @@ die() {
|
||||||
|
# Create test files, each 98 in the directories ".", "one" and "two".
|
||||||
|
make_test_data() {
|
||||||
|
d="$1"
|
||||||
|
+ xargs="`cd ../../xargs; pwd -P`/xargs"
|
||||||
|
(
|
||||||
|
cd "$1" || exit 1
|
||||||
|
mkdir one two || exit 1
|
||||||
|
for i in ${three_to_hundred} ; do
|
||||||
|
printf "./%03d one/%03d two/%03d " $i $i $i
|
||||||
|
done \
|
||||||
|
- | xargs touch || exit 1
|
||||||
|
+ | "$xargs" touch || exit 1
|
||||||
|
) \
|
||||||
|
|| die "failed to set up the test in ${outdir}"
|
||||||
|
}
|
Loading…
Reference in New Issue