gnu: wpa-supplicant: Update to 2.5.
* gnu/packages/patches/wpa-supplicant-2015-2-fix.patch, gnu/packages/patches/wpa-supplicant-2015-3-fix.patch, gnu/packages/patches/wpa-supplicant-2015-4-fix-pt1.patch, gnu/packages/patches/wpa-supplicant-2015-4-fix-pt2.patch, gnu/packages/patches/wpa-supplicant-2015-4-fix-pt3.patch, gnu/packages/patches/wpa-supplicant-2015-4-fix-pt4.patch, gnu/packages/patches/wpa-supplicant-2015-4-fix-pt5.patch, gnu/packages/patches/wpa-supplicant-2015-5-fix.patch, gnu/packages/patches/wpa-supplicant-CVE-2015-1863.patch: Delete files. * gnu-system.am (dist_patch_DATA): Remove them. * gnu/packages/admin.scm (wpa-supplicant-minimal): Update to 2.5. Remove patches.
This commit is contained in:
parent
797e1401fe
commit
e91e28d60c
|
@ -657,15 +657,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/wicd-template-instantiation.patch \
|
||||
gnu/packages/patches/wicd-urwid-1.3.patch \
|
||||
gnu/packages/patches/wmctrl-64-fix.patch \
|
||||
gnu/packages/patches/wpa-supplicant-CVE-2015-1863.patch \
|
||||
gnu/packages/patches/wpa-supplicant-2015-2-fix.patch \
|
||||
gnu/packages/patches/wpa-supplicant-2015-3-fix.patch \
|
||||
gnu/packages/patches/wpa-supplicant-2015-4-fix-pt1.patch \
|
||||
gnu/packages/patches/wpa-supplicant-2015-4-fix-pt2.patch \
|
||||
gnu/packages/patches/wpa-supplicant-2015-4-fix-pt3.patch \
|
||||
gnu/packages/patches/wpa-supplicant-2015-4-fix-pt4.patch \
|
||||
gnu/packages/patches/wpa-supplicant-2015-4-fix-pt5.patch \
|
||||
gnu/packages/patches/wpa-supplicant-2015-5-fix.patch \
|
||||
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-geode-glibc-2.20.patch \
|
||||
|
|
|
@ -707,7 +707,7 @@ commands and their arguments.")
|
|||
(define-public wpa-supplicant-minimal
|
||||
(package
|
||||
(name "wpa-supplicant-minimal")
|
||||
(version "2.4")
|
||||
(version "2.5")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -716,17 +716,7 @@ commands and their arguments.")
|
|||
".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"08li21q1wjn5chrv289w666il9ah1w419y3dkq2rl4wnq0rci385"))
|
||||
(patches
|
||||
(map search-patch '("wpa-supplicant-CVE-2015-1863.patch"
|
||||
"wpa-supplicant-2015-2-fix.patch"
|
||||
"wpa-supplicant-2015-3-fix.patch"
|
||||
"wpa-supplicant-2015-4-fix-pt1.patch"
|
||||
"wpa-supplicant-2015-4-fix-pt2.patch"
|
||||
"wpa-supplicant-2015-4-fix-pt3.patch"
|
||||
"wpa-supplicant-2015-4-fix-pt4.patch"
|
||||
"wpa-supplicant-2015-4-fix-pt5.patch"
|
||||
"wpa-supplicant-2015-5-fix.patch")))))
|
||||
"05mkp5bx1c3z7h5biddsv0p49gkrq9ksany3anp4wdiv92p5prfc"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:phases (alist-replace
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
Patch copied from http://w1.fi/security/2015-2/
|
||||
|
||||
From 5acd23f4581da58683f3cf5e36cb71bbe4070bd7 Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <j@w1.fi>
|
||||
Date: Tue, 28 Apr 2015 17:08:33 +0300
|
||||
Subject: [PATCH] WPS: Fix HTTP chunked transfer encoding parser
|
||||
|
||||
strtoul() return value may end up overflowing the int h->chunk_size and
|
||||
resulting in a negative value to be stored as the chunk_size. This could
|
||||
result in the following memcpy operation using a very large length
|
||||
argument which would result in a buffer overflow and segmentation fault.
|
||||
|
||||
This could have been used to cause a denial service by any device that
|
||||
has been authorized for network access (either wireless or wired). This
|
||||
would affect both the WPS UPnP functionality in a WPS AP (hostapd with
|
||||
upnp_iface parameter set in the configuration) and WPS ER
|
||||
(wpa_supplicant with WPS_ER_START control interface command used).
|
||||
|
||||
Validate the parsed chunk length value to avoid this. In addition to
|
||||
rejecting negative values, we can also reject chunk size that would be
|
||||
larger than the maximum configured body length.
|
||||
|
||||
Thanks to Kostya Kortchinsky of Google security team for discovering and
|
||||
reporting this issue.
|
||||
|
||||
Signed-off-by: Jouni Malinen <j@w1.fi>
|
||||
---
|
||||
src/wps/httpread.c | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/src/wps/httpread.c b/src/wps/httpread.c
|
||||
index 2f08f37..d2855e3 100644
|
||||
--- a/src/wps/httpread.c
|
||||
+++ b/src/wps/httpread.c
|
||||
@@ -533,6 +533,13 @@ static void httpread_read_handler(int sd, void *eloop_ctx, void *sock_ctx)
|
||||
if (!isxdigit(*cbp))
|
||||
goto bad;
|
||||
h->chunk_size = strtoul(cbp, NULL, 16);
|
||||
+ if (h->chunk_size < 0 ||
|
||||
+ h->chunk_size > h->max_bytes) {
|
||||
+ wpa_printf(MSG_DEBUG,
|
||||
+ "httpread: Invalid chunk size %d",
|
||||
+ h->chunk_size);
|
||||
+ goto bad;
|
||||
+ }
|
||||
/* throw away chunk header
|
||||
* so we have only real data
|
||||
*/
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,43 +0,0 @@
|
|||
Patch copied from http://w1.fi/security/2015-3/
|
||||
|
||||
From ef566a4d4f74022e1fdb0a2addfe81e6de9f4aae Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <j@w1.fi>
|
||||
Date: Wed, 29 Apr 2015 02:21:53 +0300
|
||||
Subject: [PATCH] AP WMM: Fix integer underflow in WMM Action frame parser
|
||||
|
||||
The length of the WMM Action frame was not properly validated and the
|
||||
length of the information elements (int left) could end up being
|
||||
negative. This would result in reading significantly past the stack
|
||||
buffer while parsing the IEs in ieee802_11_parse_elems() and while doing
|
||||
so, resulting in segmentation fault.
|
||||
|
||||
This can result in an invalid frame being used for a denial of service
|
||||
attack (hostapd process killed) against an AP with a driver that uses
|
||||
hostapd for management frame processing (e.g., all mac80211-based
|
||||
drivers).
|
||||
|
||||
Thanks to Kostya Kortchinsky of Google security team for discovering and
|
||||
reporting this issue.
|
||||
|
||||
Signed-off-by: Jouni Malinen <j@w1.fi>
|
||||
---
|
||||
src/ap/wmm.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/ap/wmm.c b/src/ap/wmm.c
|
||||
index 6d4177c..314e244 100644
|
||||
--- a/src/ap/wmm.c
|
||||
+++ b/src/ap/wmm.c
|
||||
@@ -274,6 +274,9 @@ void hostapd_wmm_action(struct hostapd_data *hapd,
|
||||
return;
|
||||
}
|
||||
|
||||
+ if (left < 0)
|
||||
+ return; /* not a valid WMM Action frame */
|
||||
+
|
||||
/* extract the tspec info element */
|
||||
if (ieee802_11_parse_elems(pos, left, &elems, 1) == ParseFailed) {
|
||||
hostapd_logger(hapd, mgmt->sa, HOSTAPD_MODULE_IEEE80211,
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,75 +0,0 @@
|
|||
Patch copied from http://w1.fi/security/2015-4/
|
||||
|
||||
From dd2f043c9c43d156494e33d7ce22db96e6ef42c7 Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <j@w1.fi>
|
||||
Date: Fri, 1 May 2015 16:37:45 +0300
|
||||
Subject: [PATCH 1/5] EAP-pwd peer: Fix payload length validation for Commit
|
||||
and Confirm
|
||||
|
||||
The length of the received Commit and Confirm message payloads was not
|
||||
checked before reading them. This could result in a buffer read
|
||||
overflow when processing an invalid message.
|
||||
|
||||
Fix this by verifying that the payload is of expected length before
|
||||
processing it. In addition, enforce correct state transition sequence to
|
||||
make sure there is no unexpected behavior if receiving a Commit/Confirm
|
||||
message before the previous exchanges have been completed.
|
||||
|
||||
Thanks to Kostya Kortchinsky of Google security team for discovering and
|
||||
reporting this issue.
|
||||
|
||||
Signed-off-by: Jouni Malinen <j@w1.fi>
|
||||
---
|
||||
src/eap_peer/eap_pwd.c | 29 +++++++++++++++++++++++++++++
|
||||
1 file changed, 29 insertions(+)
|
||||
|
||||
diff --git a/src/eap_peer/eap_pwd.c b/src/eap_peer/eap_pwd.c
|
||||
index f2b0926..a629437 100644
|
||||
--- a/src/eap_peer/eap_pwd.c
|
||||
+++ b/src/eap_peer/eap_pwd.c
|
||||
@@ -355,6 +355,23 @@ eap_pwd_perform_commit_exchange(struct eap_sm *sm, struct eap_pwd_data *data,
|
||||
BIGNUM *mask = NULL, *x = NULL, *y = NULL, *cofactor = NULL;
|
||||
u16 offset;
|
||||
u8 *ptr, *scalar = NULL, *element = NULL;
|
||||
+ size_t prime_len, order_len;
|
||||
+
|
||||
+ if (data->state != PWD_Commit_Req) {
|
||||
+ ret->ignore = TRUE;
|
||||
+ goto fin;
|
||||
+ }
|
||||
+
|
||||
+ prime_len = BN_num_bytes(data->grp->prime);
|
||||
+ order_len = BN_num_bytes(data->grp->order);
|
||||
+
|
||||
+ if (payload_len != 2 * prime_len + order_len) {
|
||||
+ wpa_printf(MSG_INFO,
|
||||
+ "EAP-pwd: Unexpected Commit payload length %u (expected %u)",
|
||||
+ (unsigned int) payload_len,
|
||||
+ (unsigned int) (2 * prime_len + order_len));
|
||||
+ goto fin;
|
||||
+ }
|
||||
|
||||
if (((data->private_value = BN_new()) == NULL) ||
|
||||
((data->my_element = EC_POINT_new(data->grp->group)) == NULL) ||
|
||||
@@ -554,6 +571,18 @@ eap_pwd_perform_confirm_exchange(struct eap_sm *sm, struct eap_pwd_data *data,
|
||||
u8 conf[SHA256_MAC_LEN], *cruft = NULL, *ptr;
|
||||
int offset;
|
||||
|
||||
+ if (data->state != PWD_Confirm_Req) {
|
||||
+ ret->ignore = TRUE;
|
||||
+ goto fin;
|
||||
+ }
|
||||
+
|
||||
+ if (payload_len != SHA256_MAC_LEN) {
|
||||
+ wpa_printf(MSG_INFO,
|
||||
+ "EAP-pwd: Unexpected Confirm payload length %u (expected %u)",
|
||||
+ (unsigned int) payload_len, SHA256_MAC_LEN);
|
||||
+ goto fin;
|
||||
+ }
|
||||
+
|
||||
/*
|
||||
* first build up the ciphersuite which is group | random_function |
|
||||
* prf
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,68 +0,0 @@
|
|||
Patch copied from http://w1.fi/security/2015-4/
|
||||
|
||||
From e28a58be26184c2a23f80b410e0997ef1bd5d578 Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <j@w1.fi>
|
||||
Date: Fri, 1 May 2015 16:40:44 +0300
|
||||
Subject: [PATCH 2/5] EAP-pwd server: Fix payload length validation for Commit
|
||||
and Confirm
|
||||
|
||||
The length of the received Commit and Confirm message payloads was not
|
||||
checked before reading them. This could result in a buffer read
|
||||
overflow when processing an invalid message.
|
||||
|
||||
Fix this by verifying that the payload is of expected length before
|
||||
processing it. In addition, enforce correct state transition sequence to
|
||||
make sure there is no unexpected behavior if receiving a Commit/Confirm
|
||||
message before the previous exchanges have been completed.
|
||||
|
||||
Thanks to Kostya Kortchinsky of Google security team for discovering and
|
||||
reporting this issue.
|
||||
|
||||
Signed-off-by: Jouni Malinen <j@w1.fi>
|
||||
---
|
||||
src/eap_server/eap_server_pwd.c | 19 +++++++++++++++++++
|
||||
1 file changed, 19 insertions(+)
|
||||
|
||||
diff --git a/src/eap_server/eap_server_pwd.c b/src/eap_server/eap_server_pwd.c
|
||||
index 66bd5d2..3189105 100644
|
||||
--- a/src/eap_server/eap_server_pwd.c
|
||||
+++ b/src/eap_server/eap_server_pwd.c
|
||||
@@ -656,9 +656,21 @@ eap_pwd_process_commit_resp(struct eap_sm *sm, struct eap_pwd_data *data,
|
||||
BIGNUM *x = NULL, *y = NULL, *cofactor = NULL;
|
||||
EC_POINT *K = NULL, *point = NULL;
|
||||
int res = 0;
|
||||
+ size_t prime_len, order_len;
|
||||
|
||||
wpa_printf(MSG_DEBUG, "EAP-pwd: Received commit response");
|
||||
|
||||
+ prime_len = BN_num_bytes(data->grp->prime);
|
||||
+ order_len = BN_num_bytes(data->grp->order);
|
||||
+
|
||||
+ if (payload_len != 2 * prime_len + order_len) {
|
||||
+ wpa_printf(MSG_INFO,
|
||||
+ "EAP-pwd: Unexpected Commit payload length %u (expected %u)",
|
||||
+ (unsigned int) payload_len,
|
||||
+ (unsigned int) (2 * prime_len + order_len));
|
||||
+ goto fin;
|
||||
+ }
|
||||
+
|
||||
if (((data->peer_scalar = BN_new()) == NULL) ||
|
||||
((data->k = BN_new()) == NULL) ||
|
||||
((cofactor = BN_new()) == NULL) ||
|
||||
@@ -774,6 +786,13 @@ eap_pwd_process_confirm_resp(struct eap_sm *sm, struct eap_pwd_data *data,
|
||||
u8 conf[SHA256_MAC_LEN], *cruft = NULL, *ptr;
|
||||
int offset;
|
||||
|
||||
+ if (payload_len != SHA256_MAC_LEN) {
|
||||
+ wpa_printf(MSG_INFO,
|
||||
+ "EAP-pwd: Unexpected Confirm payload length %u (expected %u)",
|
||||
+ (unsigned int) payload_len, SHA256_MAC_LEN);
|
||||
+ goto fin;
|
||||
+ }
|
||||
+
|
||||
/* build up the ciphersuite: group | random_function | prf */
|
||||
grp = htons(data->group_num);
|
||||
ptr = (u8 *) &cs;
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,54 +0,0 @@
|
|||
Patch copied from http://w1.fi/security/2015-4/
|
||||
|
||||
From 477c74395acd0123340457ba6f15ab345d42016e Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <j@w1.fi>
|
||||
Date: Sat, 2 May 2015 19:23:04 +0300
|
||||
Subject: [PATCH 3/5] EAP-pwd peer: Fix Total-Length parsing for fragment
|
||||
reassembly
|
||||
|
||||
The remaining number of bytes in the message could be smaller than the
|
||||
Total-Length field size, so the length needs to be explicitly checked
|
||||
prior to reading the field and decrementing the len variable. This could
|
||||
have resulted in the remaining length becoming negative and interpreted
|
||||
as a huge positive integer.
|
||||
|
||||
In addition, check that there is no already started fragment in progress
|
||||
before allocating a new buffer for reassembling fragments. This avoid a
|
||||
potential memory leak when processing invalid message.
|
||||
|
||||
Signed-off-by: Jouni Malinen <j@w1.fi>
|
||||
---
|
||||
src/eap_peer/eap_pwd.c | 12 ++++++++++++
|
||||
1 file changed, 12 insertions(+)
|
||||
|
||||
diff --git a/src/eap_peer/eap_pwd.c b/src/eap_peer/eap_pwd.c
|
||||
index a629437..1d2079b 100644
|
||||
--- a/src/eap_peer/eap_pwd.c
|
||||
+++ b/src/eap_peer/eap_pwd.c
|
||||
@@ -866,11 +866,23 @@ eap_pwd_process(struct eap_sm *sm, void *priv, struct eap_method_ret *ret,
|
||||
* if it's the first fragment there'll be a length field
|
||||
*/
|
||||
if (EAP_PWD_GET_LENGTH_BIT(lm_exch)) {
|
||||
+ if (len < 2) {
|
||||
+ wpa_printf(MSG_DEBUG,
|
||||
+ "EAP-pwd: Frame too short to contain Total-Length field");
|
||||
+ ret->ignore = TRUE;
|
||||
+ return NULL;
|
||||
+ }
|
||||
tot_len = WPA_GET_BE16(pos);
|
||||
wpa_printf(MSG_DEBUG, "EAP-pwd: Incoming fragments whose "
|
||||
"total length = %d", tot_len);
|
||||
if (tot_len > 15000)
|
||||
return NULL;
|
||||
+ if (data->inbuf) {
|
||||
+ wpa_printf(MSG_DEBUG,
|
||||
+ "EAP-pwd: Unexpected new fragment start when previous fragment is still in use");
|
||||
+ ret->ignore = TRUE;
|
||||
+ return NULL;
|
||||
+ }
|
||||
data->inbuf = wpabuf_alloc(tot_len);
|
||||
if (data->inbuf == NULL) {
|
||||
wpa_printf(MSG_INFO, "Out of memory to buffer "
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,52 +0,0 @@
|
|||
Patch copied from http://w1.fi/security/2015-4/
|
||||
|
||||
From 3035cc2894e08319b905bd6561e8bddc8c2db9fa Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <j@w1.fi>
|
||||
Date: Sat, 2 May 2015 19:26:06 +0300
|
||||
Subject: [PATCH 4/5] EAP-pwd server: Fix Total-Length parsing for fragment
|
||||
reassembly
|
||||
|
||||
The remaining number of bytes in the message could be smaller than the
|
||||
Total-Length field size, so the length needs to be explicitly checked
|
||||
prior to reading the field and decrementing the len variable. This could
|
||||
have resulted in the remaining length becoming negative and interpreted
|
||||
as a huge positive integer.
|
||||
|
||||
In addition, check that there is no already started fragment in progress
|
||||
before allocating a new buffer for reassembling fragments. This avoid a
|
||||
potential memory leak when processing invalid message.
|
||||
|
||||
Signed-off-by: Jouni Malinen <j@w1.fi>
|
||||
---
|
||||
src/eap_server/eap_server_pwd.c | 10 ++++++++++
|
||||
1 file changed, 10 insertions(+)
|
||||
|
||||
diff --git a/src/eap_server/eap_server_pwd.c b/src/eap_server/eap_server_pwd.c
|
||||
index 3189105..2bfc3c2 100644
|
||||
--- a/src/eap_server/eap_server_pwd.c
|
||||
+++ b/src/eap_server/eap_server_pwd.c
|
||||
@@ -942,11 +942,21 @@ static void eap_pwd_process(struct eap_sm *sm, void *priv,
|
||||
* the first fragment has a total length
|
||||
*/
|
||||
if (EAP_PWD_GET_LENGTH_BIT(lm_exch)) {
|
||||
+ if (len < 2) {
|
||||
+ wpa_printf(MSG_DEBUG,
|
||||
+ "EAP-pwd: Frame too short to contain Total-Length field");
|
||||
+ return;
|
||||
+ }
|
||||
tot_len = WPA_GET_BE16(pos);
|
||||
wpa_printf(MSG_DEBUG, "EAP-pwd: Incoming fragments, total "
|
||||
"length = %d", tot_len);
|
||||
if (tot_len > 15000)
|
||||
return;
|
||||
+ if (data->inbuf) {
|
||||
+ wpa_printf(MSG_DEBUG,
|
||||
+ "EAP-pwd: Unexpected new fragment start when previous fragment is still in use");
|
||||
+ return;
|
||||
+ }
|
||||
data->inbuf = wpabuf_alloc(tot_len);
|
||||
if (data->inbuf == NULL) {
|
||||
wpa_printf(MSG_INFO, "EAP-pwd: Out of memory to "
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,34 +0,0 @@
|
|||
Patch copied from http://w1.fi/security/2015-4/
|
||||
|
||||
From 28a069a545b06b99eb55ad53f63f2c99e65a98f6 Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <j@w1.fi>
|
||||
Date: Sat, 2 May 2015 19:26:28 +0300
|
||||
Subject: [PATCH 5/5] EAP-pwd peer: Fix asymmetric fragmentation behavior
|
||||
|
||||
The L (Length) and M (More) flags needs to be cleared before deciding
|
||||
whether the locally generated response requires fragmentation. This
|
||||
fixes an issue where these flags from the server could have been invalid
|
||||
for the following message. In some cases, this could have resulted in
|
||||
triggering the wpabuf security check that would terminate the process
|
||||
due to invalid buffer allocation.
|
||||
|
||||
Signed-off-by: Jouni Malinen <j@w1.fi>
|
||||
---
|
||||
src/eap_peer/eap_pwd.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/eap_peer/eap_pwd.c b/src/eap_peer/eap_pwd.c
|
||||
index 1d2079b..e58b13a 100644
|
||||
--- a/src/eap_peer/eap_pwd.c
|
||||
+++ b/src/eap_peer/eap_pwd.c
|
||||
@@ -968,6 +968,7 @@ eap_pwd_process(struct eap_sm *sm, void *priv, struct eap_method_ret *ret,
|
||||
/*
|
||||
* we have output! Do we need to fragment it?
|
||||
*/
|
||||
+ lm_exch = EAP_PWD_GET_EXCHANGE(lm_exch);
|
||||
len = wpabuf_len(data->outbuf);
|
||||
if ((len + EAP_PWD_HDR_SIZE) > data->mtu) {
|
||||
resp = eap_msg_alloc(EAP_VENDOR_IETF, EAP_TYPE_PWD, data->mtu,
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,64 +0,0 @@
|
|||
Original patch copied from http://w1.fi/security/2015-5/
|
||||
and then backported to wpa-supplicant-2.4.
|
||||
|
||||
From df9079e72760ceb7ebe7fb11538200c516bdd886 Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <j@w1.fi>
|
||||
Date: Tue, 7 Jul 2015 21:57:28 +0300
|
||||
Subject: [PATCH] NFC: Fix payload length validation in NDEF record parser
|
||||
|
||||
It was possible for the 32-bit record->total_length value to end up
|
||||
wrapping around due to integer overflow if the longer form of payload
|
||||
length field is used and record->payload_length gets a value close to
|
||||
2^32. This could result in ndef_parse_record() accepting a too large
|
||||
payload length value and the record type filter reading up to about 20
|
||||
bytes beyond the end of the buffer and potentially killing the process.
|
||||
This could also result in an attempt to allocate close to 2^32 bytes of
|
||||
heap memory and if that were to succeed, a buffer read overflow of the
|
||||
same length which would most likely result in the process termination.
|
||||
In case of record->total_length ending up getting the value 0, there
|
||||
would be no buffer read overflow, but record parsing would result in an
|
||||
infinite loop in ndef_parse_records().
|
||||
|
||||
Any of these error cases could potentially be used for denial of service
|
||||
attacks over NFC by using a malformed NDEF record on an NFC Tag or
|
||||
sending them during NFC connection handover if the application providing
|
||||
the NDEF message to hostapd/wpa_supplicant did no validation of the
|
||||
received records. While such validation is likely done in the NFC stack
|
||||
that needs to parse the NFC messages before further processing,
|
||||
hostapd/wpa_supplicant better be prepared for any data being included
|
||||
here.
|
||||
|
||||
Fix this by validating record->payload_length value in a way that
|
||||
detects integer overflow. (CID 122668)
|
||||
|
||||
Signed-off-by: Jouni Malinen <j@w1.fi>
|
||||
---
|
||||
src/wps/ndef.c | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/wps/ndef.c b/src/wps/ndef.c
|
||||
index 5604b0a..50d018f 100644
|
||||
--- a/src/wps/ndef.c
|
||||
+++ b/src/wps/ndef.c
|
||||
@@ -48,6 +48,8 @@ static int ndef_parse_record(const u8 *data, u32 size,
|
||||
if (size < 6)
|
||||
return -1;
|
||||
record->payload_length = ntohl(*(u32 *)pos);
|
||||
+ if (record->payload_length > size - 6)
|
||||
+ return -1;
|
||||
pos += sizeof(u32);
|
||||
}
|
||||
|
||||
@@ -68,7 +70,8 @@ static int ndef_parse_record(const u8 *data, u32 size,
|
||||
pos += record->payload_length;
|
||||
|
||||
record->total_length = pos - data;
|
||||
- if (record->total_length > size)
|
||||
+ if (record->total_length > size ||
|
||||
+ record->total_length < record->payload_length)
|
||||
return -1;
|
||||
return 0;
|
||||
}
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,42 +0,0 @@
|
|||
From 9ed4eee345f85e3025c33c6e20aa25696e341ccd Mon Sep 17 00:00:00 2001
|
||||
From: Jouni Malinen <jouni@qca.qualcomm.com>
|
||||
Date: Tue, 7 Apr 2015 11:32:11 +0300
|
||||
Subject: [PATCH] P2P: Validate SSID element length before copying it
|
||||
(CVE-2015-1863)
|
||||
|
||||
This fixes a possible memcpy overflow for P2P dev->oper_ssid in
|
||||
p2p_add_device(). The length provided by the peer device (0..255 bytes)
|
||||
was used without proper bounds checking and that could have resulted in
|
||||
arbitrary data of up to 223 bytes being written beyond the end of the
|
||||
dev->oper_ssid[] array (of which about 150 bytes would be beyond the
|
||||
heap allocation) when processing a corrupted management frame for P2P
|
||||
peer discovery purposes.
|
||||
|
||||
This could result in corrupted state in heap, unexpected program
|
||||
behavior due to corrupted P2P peer device information, denial of service
|
||||
due to process crash, exposure of memory contents during GO Negotiation,
|
||||
and potentially arbitrary code execution.
|
||||
|
||||
Thanks to Google security team for reporting this issue and smart
|
||||
hardware research group of Alibaba security team for discovering it.
|
||||
|
||||
Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
|
||||
---
|
||||
src/p2p/p2p.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/p2p/p2p.c b/src/p2p/p2p.c
|
||||
index f584fae..a45fe73 100644
|
||||
--- a/src/p2p/p2p.c
|
||||
+++ b/src/p2p/p2p.c
|
||||
@@ -778,6 +778,7 @@ int p2p_add_device(struct p2p_data *p2p, const u8 *addr, int freq,
|
||||
if (os_memcmp(addr, p2p_dev_addr, ETH_ALEN) != 0)
|
||||
os_memcpy(dev->interface_addr, addr, ETH_ALEN);
|
||||
if (msg.ssid &&
|
||||
+ msg.ssid[1] <= sizeof(dev->oper_ssid) &&
|
||||
(msg.ssid[1] != P2P_WILDCARD_SSID_LEN ||
|
||||
os_memcmp(msg.ssid + 2, P2P_WILDCARD_SSID, P2P_WILDCARD_SSID_LEN)
|
||||
!= 0)) {
|
||||
--
|
||||
1.9.1
|
||||
|
Loading…
Reference in New Issue