gnu: make: Fix compatibility with glibc 2.27.
* gnu/packages/patches/make-glibc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/base.scm (gnu-make)[source](patches): Use it.
This commit is contained in:
parent
5e8cb5e698
commit
e9b9ea1ec0
|
@ -895,6 +895,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/lvm2-static-link.patch \
|
%D%/packages/patches/lvm2-static-link.patch \
|
||||||
%D%/packages/patches/lxsession-use-gapplication.patch \
|
%D%/packages/patches/lxsession-use-gapplication.patch \
|
||||||
%D%/packages/patches/mailutils-uninitialized-memory.patch \
|
%D%/packages/patches/mailutils-uninitialized-memory.patch \
|
||||||
|
%D%/packages/patches/make-glibc-compat.patch \
|
||||||
%D%/packages/patches/make-impure-dirs.patch \
|
%D%/packages/patches/make-impure-dirs.patch \
|
||||||
%D%/packages/patches/mars-install.patch \
|
%D%/packages/patches/mars-install.patch \
|
||||||
%D%/packages/patches/mars-sfml-2.3.patch \
|
%D%/packages/patches/mars-sfml-2.3.patch \
|
||||||
|
|
|
@ -386,13 +386,17 @@ functionality beyond that which is outlined in the POSIX standard.")
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"12f5zzyq2w56g95nni65hc0g5p7154033y2f3qmjvd016szn5qnn"))
|
"12f5zzyq2w56g95nni65hc0g5p7154033y2f3qmjvd016szn5qnn"))
|
||||||
(patches (search-patches "make-impure-dirs.patch"))))
|
(patches (search-patches "make-impure-dirs.patch"
|
||||||
|
"make-glibc-compat.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs `(("pkg-config" ,pkg-config))) ; to detect Guile
|
(native-inputs `(("pkg-config" ,pkg-config))) ; to detect Guile
|
||||||
(inputs `(("guile" ,guile-2.0)))
|
(inputs `(("guile" ,guile-2.0)))
|
||||||
(outputs '("out" "debug"))
|
(outputs '("out" "debug"))
|
||||||
(arguments
|
(arguments
|
||||||
'(#:phases
|
'(;; Work around faulty glob detection with glibc 2.27. See
|
||||||
|
;; <https://lists.nongnu.org/archive/html/bug-make/2017-11/msg00027.html>.
|
||||||
|
#:configure-flags '("make_cv_sys_gnu_glob=yes")
|
||||||
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
(add-before 'build 'set-default-shell
|
(add-before 'build 'set-default-shell
|
||||||
(lambda* (#:key inputs #:allow-other-keys)
|
(lambda* (#:key inputs #:allow-other-keys)
|
||||||
|
|
|
@ -0,0 +1,52 @@
|
||||||
|
Work with the new glob interface in glibc 2.27.
|
||||||
|
|
||||||
|
Taken from this upstream commit:
|
||||||
|
https://git.savannah.gnu.org/cgit/make.git/commit/?id=193f1e81edd6b1b56b0eb0ff8aa4b41c7b4257b4
|
||||||
|
|
||||||
|
diff --git a/dir.c b/dir.c
|
||||||
|
index adbb8a9..c343e4c 100644
|
||||||
|
--- a/dir.c
|
||||||
|
+++ b/dir.c
|
||||||
|
@@ -1299,15 +1299,40 @@ local_stat (const char *path, struct stat *buf)
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+/* Similarly for lstat. */
|
||||||
|
+#if !defined(lstat) && !defined(WINDOWS32) || defined(VMS)
|
||||||
|
+# ifndef VMS
|
||||||
|
+# ifndef HAVE_SYS_STAT_H
|
||||||
|
+int lstat (const char *path, struct stat *sbuf);
|
||||||
|
+# endif
|
||||||
|
+# else
|
||||||
|
+ /* We are done with the fake lstat. Go back to the real lstat */
|
||||||
|
+# ifdef lstat
|
||||||
|
+# undef lstat
|
||||||
|
+# endif
|
||||||
|
+# endif
|
||||||
|
+# define local_lstat lstat
|
||||||
|
+#elif defined(WINDOWS32)
|
||||||
|
+/* Windows doesn't support lstat(). */
|
||||||
|
+# define local_lstat local_stat
|
||||||
|
+#else
|
||||||
|
+static int
|
||||||
|
+local_lstat (const char *path, struct stat *buf)
|
||||||
|
+{
|
||||||
|
+ int e;
|
||||||
|
+ EINTRLOOP (e, lstat (path, buf));
|
||||||
|
+ return e;
|
||||||
|
+}
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
void
|
||||||
|
dir_setup_glob (glob_t *gl)
|
||||||
|
{
|
||||||
|
gl->gl_opendir = open_dirstream;
|
||||||
|
gl->gl_readdir = read_dirstream;
|
||||||
|
gl->gl_closedir = free;
|
||||||
|
+ gl->gl_lstat = local_lstat;
|
||||||
|
gl->gl_stat = local_stat;
|
||||||
|
- /* We don't bother setting gl_lstat, since glob never calls it.
|
||||||
|
- The slot is only there for compatibility with 4.4 BSD. */
|
||||||
|
}
|
||||||
|
|
||||||
|
void
|
Loading…
Reference in New Issue