gnu: libtirpc: Update to 1.0.3.

* gnu/packages/onc-rpc.scm (libtirpc): Update to 1.0.3.
[source]: Remove patch.
* gnu/packages/patches/libtirpc-missing-headers.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Tobias Geerinckx-Rice 2018-03-17 19:40:48 +01:00
parent 86ce44c503
commit eaa69a7996
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 2 additions and 44 deletions

View File

@ -865,7 +865,6 @@ dist_patch_DATA = \
%D%/packages/patches/libtasn1-CVE-2017-10790.patch \
%D%/packages/patches/libtasn1-CVE-2018-6003.patch \
%D%/packages/patches/libtheora-config-guess.patch \
%D%/packages/patches/libtirpc-missing-headers.patch \
%D%/packages/patches/libtiff-CVE-2017-9935.patch \
%D%/packages/patches/libtiff-CVE-2017-18013.patch \
%D%/packages/patches/libtool-skip-tests2.patch \

View File

@ -33,16 +33,15 @@
(define-public libtirpc
(package
(name "libtirpc")
(version "1.0.2")
(version "1.0.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
version "/libtirpc-"
version ".tar.bz2"))
(patches (search-patches "libtirpc-missing-headers.patch"))
(sha256
(base32
"1xchbxy0xql7yl7z4n1icj8r7dmly46i22fvm00vdjq64zlmqg3j"))))
"0ppxl3k3nsz0qdakq844i2kj4fvh9h937lhx26bgmpmxq67sghw6"))))
(build-system gnu-build-system)
(arguments
`(#:phases

View File

@ -1,40 +0,0 @@
Fix compilation failure with glibc 2.26 caused by missing type
declarations:
------
xdr_sizeof.c: In function x_inline:
xdr_sizeof.c:93:13: error: uintptr_t undeclared (first use in this function)
if (len < (uintptr_t)xdrs->x_base) {
------
Patch copied from upstream source repository:
http://git.linux-nfs.org/?p=steved/libtirpc.git;a=commit;h=acb9a37977cf0a9630eac74af9adebf35e38e719
From acb9a37977cf0a9630eac74af9adebf35e38e719 Mon Sep 17 00:00:00 2001
From: Thorsten Kukuk <kukuk@thkukuk.de>
Date: Tue, 14 Nov 2017 10:39:08 -0500
Subject: [PATCH] Include stdint.h from xdr_sizeof.c to avoid missing
declaration errors.
Signed-off-by: Thorsten Kukuk <kukuk@suse.de>
Signed-off-by: Steve Dickson <steved@redhat.com>
---
src/xdr_sizeof.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/xdr_sizeof.c b/src/xdr_sizeof.c
index d23fbd1..79d6707 100644
--- a/src/xdr_sizeof.c
+++ b/src/xdr_sizeof.c
@@ -39,6 +39,7 @@
#include <rpc/xdr.h>
#include <sys/types.h>
#include <stdlib.h>
+#include <stdint.h>
#include "un-namespace.h"
/* ARGSUSED */
--
1.8.3.1