gnu: eudev: Fix build failure caused by conflicting function type declaration.

* gnu/packages/patches/eudev-conflicting-declaration.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/linux.scm (eudev)[source]: Use it.
master
Leo Famulari 2017-02-25 21:59:09 -05:00
parent 378618640d
commit f0a01af5c6
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 34 additions and 1 deletions

View File

@ -541,6 +541,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
%D%/packages/patches/eudev-rules-directory.patch \
%D%/packages/patches/eudev-conflicting-declaration.patch \
%D%/packages/patches/evilwm-lost-focus-bug.patch \
%D%/packages/patches/expat-CVE-2016-0718-fix-regression.patch \
%D%/packages/patches/fastcap-mulGlobal.patch \

View File

@ -1741,7 +1741,8 @@ from the module-init-tools project.")
(sha256
(base32
"06gyyl90n85x8i7lfhns514y1kg1ians13l467admyzy3kjxkqsp"))
(patches (search-patches "eudev-rules-directory.patch"))))
(patches (search-patches "eudev-rules-directory.patch"
"eudev-conflicting-declaration.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)

View File

@ -0,0 +1,31 @@
Fix build failure due to conflicting declaration of
keyboard_lookup_key() in gperf-3.1:
https://bugs.gentoo.org/show_bug.cgi?id=604864
Patch copied from upstream source repository:
https://github.com/gentoo/eudev/commit/5bab4d8de0dcbb8e2e7d4d5125b4aea1652a0d60
From 5bab4d8de0dcbb8e2e7d4d5125b4aea1652a0d60 Mon Sep 17 00:00:00 2001
From: "Anthony G. Basile" <blueness@gentoo.org>
Date: Thu, 5 Jan 2017 16:21:17 -0500
Subject: [PATCH] src/udev/udev-builtin-keyboard.c: fix build with gperf 3.1
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
---
src/udev/udev-builtin-keyboard.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/udev/udev-builtin-keyboard.c b/src/udev/udev-builtin-keyboard.c
index 73171c3..fad3520 100644
--- a/src/udev/udev-builtin-keyboard.c
+++ b/src/udev/udev-builtin-keyboard.c
@@ -28,7 +28,6 @@
#include "udev.h"
-static const struct key *keyboard_lookup_key(const char *str, unsigned len);
#include "keyboard-keys-from-name.h"
#include "keyboard-keys-to-name.h"