gnu: binutils: Update to 2.28.
* gnu/packages/base.scm (binutils): Update to 2.28. [source]<patches>: Remove upstreamed patch. [arguments]<#:configure-flags>: Remove "--disable-werror" * gnu/packages/patches/binutils-mips-bash-bug.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
2dca204eb0
commit
f0c6dda640
|
@ -516,7 +516,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/bigloo-gc-shebangs.patch \
|
||||
%D%/packages/patches/binutils-ld-new-dtags.patch \
|
||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||
%D%/packages/patches/binutils-mips-bash-bug.patch \
|
||||
%D%/packages/patches/byobu-writable-status.patch \
|
||||
%D%/packages/patches/cairo-CVE-2016-9082.patch \
|
||||
%D%/packages/patches/calibre-drop-unrar.patch \
|
||||
|
|
|
@ -418,17 +418,16 @@ change. GNU make offers many powerful extensions over the standard utility.")
|
|||
(define-public binutils
|
||||
(package
|
||||
(name "binutils")
|
||||
(version "2.27")
|
||||
(version "2.28")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/binutils/binutils-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"125clslv17xh1sab74343fg6v31msavpmaa1c1394zsqa773g5rn"))
|
||||
"0wiasgns7i8km8nrxas265sh2dfpsw93b3qw195ipc90w4z475v2"))
|
||||
(patches (search-patches "binutils-ld-new-dtags.patch"
|
||||
"binutils-loongson-workaround.patch"
|
||||
"binutils-mips-bash-bug.patch"))))
|
||||
"binutils-loongson-workaround.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
|
||||
;; TODO: Add dependency on zlib + those for Gold.
|
||||
|
@ -440,10 +439,6 @@ change. GNU make offers many powerful extensions over the standard utility.")
|
|||
;; Don't search under /usr/lib & co.
|
||||
"--with-lib-path=/no-ld-lib-path"
|
||||
|
||||
;; Glibc 2.17 has a "comparison of unsigned
|
||||
;; expression >= 0 is always true" in wchar.h.
|
||||
"--disable-werror"
|
||||
|
||||
;; Install BFD. It ends up in a hidden directory,
|
||||
;; but it's here.
|
||||
"--enable-install-libbfd"
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
Bash 4.2.0(1)-release, which we use during bootstrap, does not yield the
|
||||
"x" case in:
|
||||
|
||||
case x"$EMULATION_NAME" in x) ;; *) ;; esac
|
||||
|
||||
when 'EMULATION_NAME' is undefined. Bash 4.3.30(1)-release doesn't have this
|
||||
problem. Work around it.
|
||||
|
||||
This Bash bug was fixed
|
||||
in <http://ftp.gnu.org/gnu/bash/bash-4.2-patches/bash42-007>.
|
||||
|
||||
--- a/ld/emulparams/elf32bmipn32-defs.sh
|
||||
+++ b/ld/emulparams/elf32bmipn32-defs.sh
|
||||
@@ -13,7 +13,7 @@ LITTLE_OUTPUT_FORMAT="elf32-littlemips"
|
||||
TEMPLATE_NAME=elf32
|
||||
EXTRA_EM_FILE=mipself
|
||||
|
||||
-case x"$EMULATION_NAME" in
|
||||
+case "x$EMULATION_NAME" in
|
||||
xelf32*n32*) ELFSIZE=32 ;;
|
||||
xelf64*) ELFSIZE=64 ;;
|
||||
x) ;;
|
Loading…
Reference in New Issue