gnu: emacs-zones: silence byte-compiler.
* gnu/packages/patches/emacs-zones-called-interactively.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
7a352f76cf
commit
f125c5a5ea
|
@ -745,6 +745,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||
%D%/packages/patches/emacs-realgud-fix-configure-ac.patch \
|
||||
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
|
||||
%D%/packages/patches/emacs-zones-called-interactively.patch \
|
||||
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
|
||||
%D%/packages/patches/erlang-man-path.patch \
|
||||
%D%/packages/patches/eudev-rules-directory.patch \
|
||||
|
|
|
@ -6037,7 +6037,10 @@ customizable by the user.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0gwnw2giii2a14nlh62xp45f47cw6ikqphhzpmcw6c7mn9x5z2ar"))))
|
||||
"0gwnw2giii2a14nlh62xp45f47cw6ikqphhzpmcw6c7mn9x5z2ar"))
|
||||
(patches
|
||||
(search-patches
|
||||
"emacs-zones-called-interactively.patch"))))
|
||||
(build-system emacs-build-system)
|
||||
(home-page "https://www.emacswiki.org/emacs/Zones")
|
||||
(synopsis "Define and act on multiple zones of buffer text")
|
||||
|
|
|
@ -0,0 +1,43 @@
|
|||
From fb56fbb706804215ef9af0cc575db97c373046c6 Mon Sep 17 00:00:00 2001
|
||||
From: Brian Leung <bkleung89@gmail.com>
|
||||
Date: Sun, 17 Mar 2019 01:32:04 +0100
|
||||
Subject: [PATCH] This patch silences the byte-compiler.
|
||||
|
||||
---
|
||||
zones.el | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/zones.el b/zones.el
|
||||
index 1bf94f0..94fa9a6 100644
|
||||
--- a/zones.el
|
||||
+++ b/zones.el
|
||||
@@ -1031,7 +1031,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
|
||||
|
||||
This is a destructive operation. The list structure of the variable
|
||||
value can be modified."
|
||||
- (zz-narrow-advice (interactive-p)))
|
||||
+ (zz-narrow-advice (called-interactively-p)))
|
||||
|
||||
(defadvice narrow-to-defun (after zz-add-zone--defun activate)
|
||||
"Push the defun limits to the current `zz-izones-var'.
|
||||
@@ -1039,7 +1039,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
|
||||
|
||||
This is a destructive operation. The list structure of the variable
|
||||
value can be modified."
|
||||
- (zz-narrow-advice (interactive-p)))
|
||||
+ (zz-narrow-advice (called-interactively-p)))
|
||||
|
||||
;; Call `zz-add-zone' if interactive or `zz-add-zone-anyway-p'.
|
||||
;;
|
||||
@@ -1049,7 +1049,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
|
||||
|
||||
This is a destructive operation. The list structure of the variable
|
||||
value can be modified."
|
||||
- (zz-narrow-advice (interactive-p)))
|
||||
+ (zz-narrow-advice (called-interactively-p)))
|
||||
|
||||
;;(@* "General Commands")
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
Loading…
Reference in New Issue