gnu: twinkle: update to 1.10.2.
* gnu/packages/telephony.scm (twinkle): update to 1.10.2 * gnu/packages/patches/twinkle-include-qregexpvalidator.patch: Delete it. * gnu/local.mk (dist_patch_DATA): Remove patch. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
191668bc97
commit
f1371daa97
|
@ -1362,7 +1362,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/totem-meson-compat.patch \
|
%D%/packages/patches/totem-meson-compat.patch \
|
||||||
%D%/packages/patches/totem-meson-easy-codec.patch \
|
%D%/packages/patches/totem-meson-easy-codec.patch \
|
||||||
%D%/packages/patches/tuxpaint-stamps-path.patch \
|
%D%/packages/patches/tuxpaint-stamps-path.patch \
|
||||||
%D%/packages/patches/twinkle-include-qregexpvalidator.patch \
|
|
||||||
%D%/packages/patches/txr-shell.patch \
|
%D%/packages/patches/txr-shell.patch \
|
||||||
%D%/packages/patches/u-boot-fix-mkimage-header-verification.patch \
|
%D%/packages/patches/u-boot-fix-mkimage-header-verification.patch \
|
||||||
%D%/packages/patches/unzip-CVE-2014-8139.patch \
|
%D%/packages/patches/unzip-CVE-2014-8139.patch \
|
||||||
|
|
|
@ -1,123 +0,0 @@
|
||||||
Copied from upstream:
|
|
||||||
|
|
||||||
https://github.com/LubosD/twinkle/commit/4b42755619011c117a76bdf98e417ebedc47e319
|
|
||||||
|
|
||||||
From 4b42755619011c117a76bdf98e417ebedc47e319 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michal Kubecek <mkubecek@suse.cz>
|
|
||||||
Date: Wed, 6 Jun 2018 10:07:21 +0200
|
|
||||||
Subject: [PATCH] Include <QRegExpValidator> explicitly
|
|
||||||
|
|
||||||
Since Qt 5.11, generated ui_getprofilename.h no longer includes QHeaderView
|
|
||||||
which breaks the chain that included qvalidator.h in getprofilename.cpp.
|
|
||||||
As it feels rather fragile to rely on such indirect includes, let's include
|
|
||||||
<QRegExpValidator> explicitly in each file using QRegExpValidator class.
|
|
||||||
---
|
|
||||||
src/gui/diamondcardprofileform.cpp | 1 +
|
|
||||||
src/gui/getprofilenameform.cpp | 2 +-
|
|
||||||
src/gui/inviteform.cpp | 1 +
|
|
||||||
src/gui/mphoneform.cpp | 1 +
|
|
||||||
src/gui/numberconversionform.cpp | 1 +
|
|
||||||
src/gui/syssettingsform.cpp | 1 +
|
|
||||||
src/gui/userprofileform.cpp | 1 +
|
|
||||||
src/gui/wizardform.cpp | 1 +
|
|
||||||
8 files changed, 8 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/gui/diamondcardprofileform.cpp b/src/gui/diamondcardprofileform.cpp
|
|
||||||
index 6656909..517180b 100644
|
|
||||||
--- a/src/gui/diamondcardprofileform.cpp
|
|
||||||
+++ b/src/gui/diamondcardprofileform.cpp
|
|
||||||
@@ -21,6 +21,7 @@
|
|
||||||
|
|
||||||
#include <QRegExp>
|
|
||||||
#include <QValidator>
|
|
||||||
+#include <QRegExpValidator>
|
|
||||||
#include "gui.h"
|
|
||||||
#include "diamondcard.h"
|
|
||||||
#include "getprofilenameform.h"
|
|
||||||
diff --git a/src/gui/getprofilenameform.cpp b/src/gui/getprofilenameform.cpp
|
|
||||||
index 1319e1d..89c715e 100644
|
|
||||||
--- a/src/gui/getprofilenameform.cpp
|
|
||||||
+++ b/src/gui/getprofilenameform.cpp
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
#include "getprofilenameform.h"
|
|
||||||
-
|
|
||||||
#include <QDir>
|
|
||||||
#include <QMessageBox>
|
|
||||||
+#include <QRegExpValidator>
|
|
||||||
#include "user.h"
|
|
||||||
#include "protocol.h"
|
|
||||||
|
|
||||||
diff --git a/src/gui/inviteform.cpp b/src/gui/inviteform.cpp
|
|
||||||
index 433fb22..2a5b68d 100644
|
|
||||||
--- a/src/gui/inviteform.cpp
|
|
||||||
+++ b/src/gui/inviteform.cpp
|
|
||||||
@@ -7,6 +7,7 @@
|
|
||||||
#include "sys_settings.h"
|
|
||||||
#include <QRegExp>
|
|
||||||
#include <QValidator>
|
|
||||||
+#include <QRegExpValidator>
|
|
||||||
|
|
||||||
/*
|
|
||||||
Copyright (C) 2005-2009 Michel de Boer <michel@twinklephone.com>
|
|
||||||
diff --git a/src/gui/mphoneform.cpp b/src/gui/mphoneform.cpp
|
|
||||||
index 260fda7..c4e3c1d 100644
|
|
||||||
--- a/src/gui/mphoneform.cpp
|
|
||||||
+++ b/src/gui/mphoneform.cpp
|
|
||||||
@@ -54,6 +54,7 @@
|
|
||||||
#include <QRegExp>
|
|
||||||
#include <QValidator>
|
|
||||||
#include <QSettings>
|
|
||||||
+#include <QRegExpValidator>
|
|
||||||
#include "buddyform.h"
|
|
||||||
#include "diamondcardprofileform.h"
|
|
||||||
#include "osd.h"
|
|
||||||
diff --git a/src/gui/numberconversionform.cpp b/src/gui/numberconversionform.cpp
|
|
||||||
index f8ae64c..8481a9b 100644
|
|
||||||
--- a/src/gui/numberconversionform.cpp
|
|
||||||
+++ b/src/gui/numberconversionform.cpp
|
|
||||||
@@ -1,5 +1,6 @@
|
|
||||||
#include "numberconversionform.h"
|
|
||||||
|
|
||||||
+#include <QRegExpValidator>
|
|
||||||
#include "gui.h"
|
|
||||||
|
|
||||||
/*
|
|
||||||
diff --git a/src/gui/syssettingsform.cpp b/src/gui/syssettingsform.cpp
|
|
||||||
index 216af54..355df59 100644
|
|
||||||
--- a/src/gui/syssettingsform.cpp
|
|
||||||
+++ b/src/gui/syssettingsform.cpp
|
|
||||||
@@ -28,6 +28,7 @@
|
|
||||||
#include "twinkle_config.h"
|
|
||||||
#include <QRegExp>
|
|
||||||
#include <QValidator>
|
|
||||||
+#include <QRegExpValidator>
|
|
||||||
#include "syssettingsform.h"
|
|
||||||
/*
|
|
||||||
* Constructs a SysSettingsForm as a child of 'parent', with the
|
|
||||||
diff --git a/src/gui/userprofileform.cpp b/src/gui/userprofileform.cpp
|
|
||||||
index 28700a6..9ed9209 100644
|
|
||||||
--- a/src/gui/userprofileform.cpp
|
|
||||||
+++ b/src/gui/userprofileform.cpp
|
|
||||||
@@ -31,6 +31,7 @@
|
|
||||||
#include <QStringList>
|
|
||||||
#include "twinkle_config.h"
|
|
||||||
#include <QListWidget>
|
|
||||||
+#include <QRegExpValidator>
|
|
||||||
#include "numberconversionform.h"
|
|
||||||
#include "util.h"
|
|
||||||
#include "userprofileform.h"
|
|
||||||
diff --git a/src/gui/wizardform.cpp b/src/gui/wizardform.cpp
|
|
||||||
index 777aa12..f925875 100644
|
|
||||||
--- a/src/gui/wizardform.cpp
|
|
||||||
+++ b/src/gui/wizardform.cpp
|
|
||||||
@@ -23,6 +23,7 @@
|
|
||||||
#include <QTextStream>
|
|
||||||
#include "gui.h"
|
|
||||||
#include <QFile>
|
|
||||||
+#include <QRegExpValidator>
|
|
||||||
#include "wizardform.h"
|
|
||||||
|
|
||||||
#define PROV_NONE QT_TRANSLATE_NOOP("WizardForm", "None (direct IP to IP calls)")
|
|
||||||
--
|
|
||||||
2.17.0
|
|
||||||
|
|
|
@ -491,22 +491,18 @@ Mumble consists of two applications for separate usage:
|
||||||
license:bsd-2))))
|
license:bsd-2))))
|
||||||
|
|
||||||
(define-public twinkle
|
(define-public twinkle
|
||||||
(let ((commit "02e1d1538af3337134bd7381dcd95f8d7775b30f")
|
|
||||||
(revision "1"))
|
|
||||||
(package
|
(package
|
||||||
(name "twinkle")
|
(name "twinkle")
|
||||||
(version (git-version "1.10.1" revision commit))
|
(version "1.10.2")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
(uri (git-reference
|
(uri (git-reference
|
||||||
(url "https://github.com/LubosD/twinkle")
|
(url "https://github.com/LubosD/twinkle")
|
||||||
(commit commit)))
|
(commit (string-append "v" version))))
|
||||||
(patches
|
|
||||||
(search-patches "twinkle-include-qregexpvalidator.patch"))
|
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0ds4rp4vr1wagn4m4m7ldqbsx5vgmgbfcqqgyhn1wf6s1dm0020z"))))
|
"0s0gi03xwvzp02ah4q6j33r9jx9nbayr6dxlg2ck9pwbay1nq1hx"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:tests? #f ; no test target
|
`(#:tests? #f ; no test target
|
||||||
|
@ -551,7 +547,7 @@ Mumble consists of two applications for separate usage:
|
||||||
messaging communcations using the SIP protocol. You can use it for direct IP
|
messaging communcations using the SIP protocol. You can use it for direct IP
|
||||||
phone to IP phone communication or in a network using a SIP proxy to route your
|
phone to IP phone communication or in a network using a SIP proxy to route your
|
||||||
calls and messages")
|
calls and messages")
|
||||||
(license license:gpl2+))))
|
(license license:gpl2+)))
|
||||||
|
|
||||||
(define-public pjproject
|
(define-public pjproject
|
||||||
(package
|
(package
|
||||||
|
|
Loading…
Reference in New Issue