gnu: emacs-exwm: Update to 0.20.

* gnu/packages/emacs.scm (emacs-exwm): Update to 0.20.
[source]: Remove emacs-exwm-fix-fullscreen-issue.patch.
* gnu/local.mk (dist_patch_DATA): Remove patch.
* gnu/packages/patches/emacs-exwm-fix-fullscreen-issue.patch: Remove patch.
master
Clément Lassieur 2018-10-16 10:58:06 +02:00
parent 503fe87098
commit f1376bfabe
No known key found for this signature in database
GPG Key ID: 89F96D4808F359C7
3 changed files with 2 additions and 31 deletions

View File

@ -659,7 +659,6 @@ dist_patch_DATA = \
%D%/packages/patches/elogind-glibc-2.27.patch \
%D%/packages/patches/einstein-build.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-exwm-fix-fullscreen-issue.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \

View File

@ -6615,7 +6615,7 @@ It should enable you to implement low-level X11 applications.")
(define-public emacs-exwm
(package
(name "emacs-exwm")
(version "0.19")
(version "0.20")
(synopsis "Emacs X window manager")
(source (origin
(method url-fetch)
@ -6623,8 +6623,7 @@ It should enable you to implement low-level X11 applications.")
version ".tar"))
(sha256
(base32
"11xd2w4h3zdwkdxypvmcz8s7q72cn76lfr9js77jbizyj6b04lr0"))
(patches (search-patches "emacs-exwm-fix-fullscreen-issue.patch"))))
"0nhhzbkm0mkj7sd1dy2c19cmn56gyaj9nl8kgy86h4fp63hjaz04"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-xelb" ,emacs-xelb)))

View File

@ -1,27 +0,0 @@
From 13a14579cc1bb772735f895dd5b4b90c6812f3ee Mon Sep 17 00:00:00 2001
From: Chris Feng <chris.w.feng@gmail.com>
Date: Sun, 29 Jul 2018 00:00:00 +0000
Subject: [PATCH] Fix issues with destroying full screen X windows
* exwm-manage.el (exwm-manage--unmanage-window): Set the Emacs window
of an full screen X window as non-dedicated before killing its buffer
so as not to cause other side effects.
---
exwm-manage.el | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/exwm-manage.el b/exwm-manage.el
index a0a9e05..349157f 100644
--- a/exwm-manage.el
+++ b/exwm-manage.el
@@ -392,6 +392,10 @@ manager is shutting down."
:window window :parent exwm--root :x 0 :y 0))
(xcb:+request exwm--connection
(make-instance 'xcb:DestroyWindow :window container))))
+ (when (exwm-layout--fullscreen-p)
+ (let ((window (get-buffer-window)))
+ (when window
+ (set-window-dedicated-p window nil))))
(exwm-manage--set-client-list)
(xcb:flush exwm--connection))
(let ((kill-buffer-func