gnu: grub: Add patch to fix new version of freetype
* gnu/packages/patches/grub-freetype.patch: New file. * gnu-system.am (dist_patch_DATA): Add the patch. * gnu/packages/grub.scm (grub): Apply new patch.
This commit is contained in:
parent
81f36365f1
commit
f195b36602
|
@ -412,6 +412,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/gobject-introspection-girepository.patch \
|
||||
gnu/packages/patches/grep-CVE-2015-1345.patch \
|
||||
gnu/packages/patches/grub-gets-undeclared.patch \
|
||||
gnu/packages/patches/grub-freetype.patch \
|
||||
gnu/packages/patches/gstreamer-0.10-bison3.patch \
|
||||
gnu/packages/patches/gstreamer-0.10-silly-test.patch \
|
||||
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||
|
|
|
@ -79,7 +79,8 @@
|
|||
(sha256
|
||||
(base32
|
||||
"0n64hpmsccvicagvr0c6v0kgp2yw0kgnd3jvsyd26cnwgs7c6kkq"))
|
||||
(patches (list (search-patch "grub-gets-undeclared.patch")))))
|
||||
(patches (list (search-patch "grub-gets-undeclared.patch")
|
||||
(search-patch "grub-freetype.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags '("--disable-werror")
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
commit fd0df6d098b1e6a4f60275c48a3ec88d15ba1fbb
|
||||
Author: Colin Watson <cjwatson@ubuntu.com>
|
||||
Date: Fri Nov 29 12:19:36 2013 +0000
|
||||
|
||||
Fix build with FreeType 2.5.1
|
||||
|
||||
* util/grub-gen-asciih.c: Include FT_SYNTHESIS_H rather than
|
||||
<freetype/ftsynth.h>, fixing build with FreeType 2.5.1.
|
||||
* util/grub-gen-widthspec.c: Likewise.
|
||||
* util/grub-mkfont.c: Likewise.
|
||||
|
||||
diff --git a/util/grub-mkfont.c b/util/grub-mkfont.c
|
||||
index 0d8eb78..242dd01 100644
|
||||
--- a/util/grub-mkfont.c
|
||||
+++ b/util/grub-mkfont.c
|
||||
@@ -43,7 +43,7 @@
|
||||
#include FT_FREETYPE_H
|
||||
#include FT_TRUETYPE_TAGS_H
|
||||
#include FT_TRUETYPE_TABLES_H
|
||||
-#include <freetype/ftsynth.h>
|
||||
+#include FT_SYNTHESIS_H
|
||||
|
||||
#undef __FTERRORS_H__
|
||||
#define FT_ERROR_START_LIST const char *ft_errmsgs[] = {
|
Loading…
Reference in New Issue