gnu: e2fsprogs: Update to 1.43.5.
* gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/linux.scm (e2fsprogs): Update to 1.43.5. [source]: Use patch.
This commit is contained in:
parent
15428168ea
commit
f28fea1ca7
|
@ -580,6 +580,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/doc++-segfault-fix.patch \
|
||||
%D%/packages/patches/doxygen-test.patch \
|
||||
%D%/packages/patches/dvd+rw-tools-add-include.patch \
|
||||
%D%/packages/patches/e2fsprogs-32bit-quota-warnings.patch \
|
||||
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
||||
%D%/packages/patches/elixir-disable-failing-tests.patch \
|
||||
%D%/packages/patches/einstein-build.patch \
|
||||
|
|
|
@ -680,16 +680,17 @@ slabtop, and skill.")
|
|||
(define-public e2fsprogs
|
||||
(package
|
||||
(name "e2fsprogs")
|
||||
(version "1.43.4")
|
||||
(version "1.43.5")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"mirror://kernel.org/linux/kernel/people/tytso/"
|
||||
name "/v" version "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(patches (search-patches "e2fsprogs-32bit-quota-warnings.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"092absr4vrlqrkdf9nwh4ykj40ab6hhwrkdr6sjsccd54c8z5csl"))))
|
||||
"05ssjpmy0fpv2ik6ibm1f47wr6794nf0q50r581vygrqvsd3s7r6"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("util-linux" ,util-linux)))
|
||||
(native-inputs `(("pkg-config" ,pkg-config)
|
||||
|
|
|
@ -0,0 +1,46 @@
|
|||
Fix a test failure on 32-bit platforms.
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://git.kernel.org/pub/scm/fs/ext2/e2fsprogs.git/commit/?id=9e31a5696c4b699bf000a07b86601c1fb91c0493
|
||||
|
||||
diff --git a/lib/support/mkquota.c b/lib/support/mkquota.c
|
||||
index 00f3a40..931a839 100644
|
||||
--- a/lib/support/mkquota.c
|
||||
+++ b/lib/support/mkquota.c
|
||||
@@ -50,11 +50,13 @@ static void print_dquot(const char *desc, struct dquot *dq)
|
||||
{
|
||||
if (desc)
|
||||
fprintf(stderr, "%s: ", desc);
|
||||
- fprintf(stderr, "%u %ld:%ld:%ld %ld:%ld:%ld\n",
|
||||
- dq->dq_id, dq->dq_dqb.dqb_curspace,
|
||||
- dq->dq_dqb.dqb_bsoftlimit, dq->dq_dqb.dqb_bhardlimit,
|
||||
- dq->dq_dqb.dqb_curinodes,
|
||||
- dq->dq_dqb.dqb_isoftlimit, dq->dq_dqb.dqb_ihardlimit);
|
||||
+ fprintf(stderr, "%u %lld:%lld:%lld %lld:%lld:%lld\n",
|
||||
+ dq->dq_id, (long long) dq->dq_dqb.dqb_curspace,
|
||||
+ (long long) dq->dq_dqb.dqb_bsoftlimit,
|
||||
+ (long long) dq->dq_dqb.dqb_bhardlimit,
|
||||
+ (long long) dq->dq_dqb.dqb_curinodes,
|
||||
+ (long long) dq->dq_dqb.dqb_isoftlimit,
|
||||
+ (long long) dq->dq_dqb.dqb_ihardlimit);
|
||||
}
|
||||
#else
|
||||
static void print_dquot(const char *desc EXT2FS_ATTR((unused)),
|
||||
@@ -524,11 +526,11 @@ static int scan_dquots_callback(struct dquot *dquot, void *cb_data)
|
||||
dq->dq_dqb.dqb_curinodes != dquot->dq_dqb.dqb_curinodes) {
|
||||
scan_data->usage_is_inconsistent = 1;
|
||||
fprintf(stderr, "[QUOTA WARNING] Usage inconsistent for ID %u:"
|
||||
- "actual (%ld, %ld) != expected (%ld, %ld)\n",
|
||||
- dq->dq_id, dq->dq_dqb.dqb_curspace,
|
||||
- dq->dq_dqb.dqb_curinodes,
|
||||
- dquot->dq_dqb.dqb_curspace,
|
||||
- dquot->dq_dqb.dqb_curinodes);
|
||||
+ "actual (%lld, %lld) != expected (%lld, %lld)\n",
|
||||
+ dq->dq_id, (long long) dq->dq_dqb.dqb_curspace,
|
||||
+ (long long) dq->dq_dqb.dqb_curinodes,
|
||||
+ (long long) dquot->dq_dqb.dqb_curspace,
|
||||
+ (long long) dquot->dq_dqb.dqb_curinodes);
|
||||
}
|
||||
|
||||
if (scan_data->update_limits) {
|
Loading…
Reference in New Issue