gnu: pspp: Add input cairo.
* gnu/packages/maths.scm (pspp): Add cairo and further necessary inputs. * gnu/packages/patches/pspp-tests.patch: New file, thanks to John Darrington <john@darrington.wattle.id.au>. * gnu-system.am (dist_patch_DATA): Register patch.
This commit is contained in:
parent
c42a4b76c4
commit
f392980041
|
@ -255,6 +255,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/perl-no-sys-dirs.patch \
|
gnu/packages/patches/perl-no-sys-dirs.patch \
|
||||||
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
|
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
|
||||||
gnu/packages/patches/procps-make-3.82.patch \
|
gnu/packages/patches/procps-make-3.82.patch \
|
||||||
|
gnu/packages/patches/pspp-tests.patch \
|
||||||
gnu/packages/patches/pulseaudio-test-timeouts.patch \
|
gnu/packages/patches/pulseaudio-test-timeouts.patch \
|
||||||
gnu/packages/patches/python-fix-dbm.patch \
|
gnu/packages/patches/python-fix-dbm.patch \
|
||||||
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
||||||
|
|
|
@ -26,9 +26,11 @@
|
||||||
#:use-module (guix build-system cmake)
|
#:use-module (guix build-system cmake)
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
#:use-module (gnu packages compression)
|
#:use-module (gnu packages compression)
|
||||||
|
#:use-module (gnu packages fontutils)
|
||||||
#:use-module ((gnu packages gettext)
|
#:use-module ((gnu packages gettext)
|
||||||
#:renamer (symbol-prefix-proc 'gnu:))
|
#:renamer (symbol-prefix-proc 'gnu:))
|
||||||
#:use-module (gnu packages gcc)
|
#:use-module (gnu packages gcc)
|
||||||
|
#:use-module (gnu packages gtk)
|
||||||
#:use-module (gnu packages multiprecision)
|
#:use-module (gnu packages multiprecision)
|
||||||
#:use-module (gnu packages perl)
|
#:use-module (gnu packages perl)
|
||||||
#:use-module (gnu packages pkg-config)
|
#:use-module (gnu packages pkg-config)
|
||||||
|
@ -132,12 +134,16 @@ LP/MIP solver is included in the package.")
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0qhxsdbwxd3cn1shc13wxvx2lg32lp4z6sz24kv3jz7p5xfi8j7x"))))
|
"0qhxsdbwxd3cn1shc13wxvx2lg32lp4z6sz24kv3jz7p5xfi8j7x"))
|
||||||
|
(patches (list (search-patch "pspp-tests.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
`(("gettext" ,gnu:gettext)
|
`(("cairo" ,cairo)
|
||||||
|
("fontconfig" ,fontconfig)
|
||||||
|
("gettext" ,gnu:gettext)
|
||||||
("gsl" ,gsl)
|
("gsl" ,gsl)
|
||||||
("libxml2" ,libxml2)
|
("libxml2" ,libxml2)
|
||||||
|
("pango" ,pango)
|
||||||
("readline" ,readline)
|
("readline" ,readline)
|
||||||
("zlib" ,zlib)))
|
("zlib" ,zlib)))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
|
@ -145,8 +151,7 @@ LP/MIP solver is included in the package.")
|
||||||
("pkg-config" ,pkg-config)))
|
("pkg-config" ,pkg-config)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags
|
`(#:configure-flags
|
||||||
`("--without-cairo" ; FIXME: tests currently fail for lack of font
|
`("--without-gui"))) ; FIXME: package missing dependencies
|
||||||
"--without-gui"))) ; FIXME: package missing dependencies
|
|
||||||
(home-page "http://www.gnu.org/software/pspp/")
|
(home-page "http://www.gnu.org/software/pspp/")
|
||||||
(synopsis "Statistical analysis")
|
(synopsis "Statistical analysis")
|
||||||
(description
|
(description
|
||||||
|
|
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/tests/output/render-test.c b/tests/output/render-test.c
|
||||||
|
index 5f4c1da..e9df96c 100644
|
||||||
|
--- a/tests/output/render-test.c
|
||||||
|
+++ b/tests/output/render-test.c
|
||||||
|
@@ -142,7 +142,7 @@ configure_drivers (int width, int length)
|
||||||
|
string_map_insert (&options, "left-margin", "0");
|
||||||
|
string_map_insert (&options, "right-margin", "0");
|
||||||
|
string_map_insert_nocopy (&options, xstrdup ("paper-size"),
|
||||||
|
- xasprintf ("%dx%dpt", width * 5, length * 8));
|
||||||
|
+ xasprintf ("%dx%dpt", width * 5, length * 16));
|
||||||
|
driver = output_driver_create (&options);
|
||||||
|
if (driver == NULL)
|
||||||
|
exit (EXIT_FAILURE);
|
Loading…
Reference in New Issue