gnu: xpdf: Update to 3.04.
* gnu/packages/patches/xpdf-constchar.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/pdf.scm (xpdf): Update to 3.04. Remove patch. Add libpng as an input.
This commit is contained in:
parent
553521d27c
commit
f410c11076
|
@ -414,8 +414,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/vpnc-script.patch \
|
gnu/packages/patches/vpnc-script.patch \
|
||||||
gnu/packages/patches/w3m-fix-compile.patch \
|
gnu/packages/patches/w3m-fix-compile.patch \
|
||||||
gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch \
|
gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch \
|
||||||
gnu/packages/patches/xmodmap-asprintf.patch \
|
gnu/packages/patches/xmodmap-asprintf.patch
|
||||||
gnu/packages/patches/xpdf-constchar.patch
|
|
||||||
|
|
||||||
bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap
|
bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap
|
||||||
bootstrap_x86_64_linuxdir = $(bootstrapdir)/x86_64-linux
|
bootstrap_x86_64_linuxdir = $(bootstrapdir)/x86_64-linux
|
||||||
|
|
|
@ -1,15 +0,0 @@
|
||||||
This patch circumvents an error with 'const char *' to 'char *' conversion,
|
|
||||||
see http://gnats.netbsd.org/45562 .
|
|
||||||
|
|
||||||
diff -u a/xpdf/XPDFViewer.cc b/xpdf/XPDFViewer.cc
|
|
||||||
--- a/xpdf/XPDFViewer.cc 2011-08-15 23:08:53.000000000 +0200
|
|
||||||
+++ b/xpdf/XPDFViewer.cc 2013-03-31 15:13:21.000000000 +0200
|
|
||||||
@@ -1803,7 +1803,7 @@
|
|
||||||
menuPane = XmCreatePulldownMenu(toolBar, "zoomMenuPane", args, n);
|
|
||||||
for (i = 0; i < nZoomMenuItems; ++i) {
|
|
||||||
n = 0;
|
|
||||||
- s = XmStringCreateLocalized(zoomMenuInfo[i].label);
|
|
||||||
+ s = XmStringCreateLocalized((char *) zoomMenuInfo[i].label);
|
|
||||||
XtSetArg(args[n], XmNlabelString, s); ++n;
|
|
||||||
XtSetArg(args[n], XmNuserData, (XtPointer)i); ++n;
|
|
||||||
sprintf(buf, "zoom%d", i);
|
|
|
@ -85,14 +85,13 @@
|
||||||
(define-public xpdf
|
(define-public xpdf
|
||||||
(package
|
(package
|
||||||
(name "xpdf")
|
(name "xpdf")
|
||||||
(version "3.03")
|
(version "3.04")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "ftp://ftp.foolabs.com/pub/xpdf/xpdf-"
|
(uri (string-append "ftp://ftp.foolabs.com/pub/xpdf/xpdf-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256 (base32
|
(sha256 (base32
|
||||||
"1jnfzdqc54wa73lw28kjv0m7120mksb0zkcn81jdlvijyvc67kq2"))
|
"1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
|
||||||
(patches (list (search-patch "xpdf-constchar.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("freetype" ,freetype)
|
(inputs `(("freetype" ,freetype)
|
||||||
("gs-fonts" ,gs-fonts)
|
("gs-fonts" ,gs-fonts)
|
||||||
|
@ -103,6 +102,7 @@
|
||||||
("libxp" ,libxp)
|
("libxp" ,libxp)
|
||||||
("libxpm" ,libxpm)
|
("libxpm" ,libxpm)
|
||||||
("libxt" ,libxt)
|
("libxt" ,libxt)
|
||||||
|
("libpng" ,libpng)
|
||||||
("zlib" ,zlib)))
|
("zlib" ,zlib)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:tests? #f ; there is no check target
|
`(#:tests? #f ; there is no check target
|
||||||
|
|
Loading…
Reference in New Issue