gnu: wicd: Update to 1.7.4.
* gnu/packages/wicd.scm (wicd): Update to 1.7.4. [source]: Remove 'wicd-template-instantiation.patch'. * gnu/packages/patches/wicd-template-instantiation.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove it.
This commit is contained in:
parent
dbeaf8f203
commit
f5480572d0
|
@ -780,7 +780,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/weex-vacopy.patch \
|
gnu/packages/patches/weex-vacopy.patch \
|
||||||
gnu/packages/patches/wicd-bitrate-none-fix.patch \
|
gnu/packages/patches/wicd-bitrate-none-fix.patch \
|
||||||
gnu/packages/patches/wicd-get-selected-profile-fix.patch \
|
gnu/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||||
gnu/packages/patches/wicd-template-instantiation.patch \
|
|
||||||
gnu/packages/patches/wicd-urwid-1.3.patch \
|
gnu/packages/patches/wicd-urwid-1.3.patch \
|
||||||
gnu/packages/patches/wmctrl-64-fix.patch \
|
gnu/packages/patches/wmctrl-64-fix.patch \
|
||||||
gnu/packages/patches/wpa-supplicant-CVE-2015-5310.patch \
|
gnu/packages/patches/wpa-supplicant-CVE-2015-5310.patch \
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
Wicd 1.7.3 fails to instantiate template lines that have several
|
|
||||||
variable references. For instance, the line:
|
|
||||||
|
|
||||||
wep_key$_KEY_INDEX=$_KEY
|
|
||||||
|
|
||||||
which is found in in the 'wep-hex' template, expands to these two
|
|
||||||
lines:
|
|
||||||
|
|
||||||
wep_key0=$_KEY
|
|
||||||
wep_key0=123456789ab
|
|
||||||
|
|
||||||
This patch fixes that by only emitting the fully substituted line.
|
|
||||||
|
|
||||||
Patch by Ludovic Courtès <ludo@gnu.org>.
|
|
||||||
|
|
||||||
--- a/wicd/misc.py 2012-11-17 00:07:08 +0000
|
|
||||||
+++ b/wicd/misc.py 2015-05-09 11:22:37 +0000
|
|
||||||
@@ -321,11 +321,11 @@ def ParseEncryption(network):
|
|
||||||
rep_val = '0'
|
|
||||||
if rep_val:
|
|
||||||
line = line.replace("$_%s" % cur_val, str(rep_val))
|
|
||||||
- config_file = ''.join([config_file, line])
|
|
||||||
else:
|
|
||||||
print "Ignoring template line: '%s'" % line
|
|
||||||
else:
|
|
||||||
print "Weird parsing error occurred"
|
|
||||||
+ config_file = ''.join([config_file, line])
|
|
||||||
else: # Just a regular entry.
|
|
||||||
config_file = ''.join([config_file, line])
|
|
|
@ -36,7 +36,7 @@
|
||||||
(define-public wicd
|
(define-public wicd
|
||||||
(package
|
(package
|
||||||
(name "wicd")
|
(name "wicd")
|
||||||
(version "1.7.3")
|
(version "1.7.4")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -44,12 +44,11 @@
|
||||||
(version-major+minor version) "/" version
|
(version-major+minor version) "/" version
|
||||||
"/+download/wicd-" version ".tar.gz"))
|
"/+download/wicd-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "00c4rq753bhg64rv1v9yl834ssq7igyy7cz3swp287b5n5bqiqwi"))
|
(base32 "0qpbwwsrqdp40mm3a8djpn2d055rxxspdhwijwsdnws700a9d637"))
|
||||||
(patches (map search-patch
|
(patches (map search-patch
|
||||||
'("wicd-bitrate-none-fix.patch"
|
'("wicd-bitrate-none-fix.patch"
|
||||||
"wicd-get-selected-profile-fix.patch"
|
"wicd-get-selected-profile-fix.patch"
|
||||||
"wicd-urwid-1.3.patch"
|
"wicd-urwid-1.3.patch")))))
|
||||||
"wicd-template-instantiation.patch")))))
|
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(native-inputs `(("gettext" ,gnu-gettext)))
|
(native-inputs `(("gettext" ,gnu-gettext)))
|
||||||
(inputs `(("dbus-glib" ,dbus-glib)
|
(inputs `(("dbus-glib" ,dbus-glib)
|
||||||
|
|
Loading…
Reference in New Issue