gnu: gspell: Update to 1.4.1.

* gnu/packages/gnome.scm (gspell): Update to 1.4.1.
* gnu/packages/patches/gspell-dash-test.patch: Adjust accordingly.
master
Kei Kebreau 2017-06-15 21:52:57 -04:00
parent a147fadd3b
commit f54efbdc46
No known key found for this signature in database
GPG Key ID: E6A5EE3C19467A0D
2 changed files with 15 additions and 9 deletions

View File

@ -6221,7 +6221,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
(define-public gspell
(package
(name "gspell")
(version "1.3.2")
(version "1.4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -6229,7 +6229,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
name "-" version ".tar.xz"))
(sha256
(base32
"1n4kd5i11l79h8bpvx3cz79ww0b4z89y99h4czvyg80qlarn585w"))
"1ghh1xdzf04mfgb13zqpj88krpa44xv2vbyhm6k017kzrpz8hbs4"))
(patches (search-patches "gspell-dash-test.patch"))))
(build-system glib-or-gtk-build-system)
(arguments

View File

@ -1,16 +1,22 @@
Somehow, Aspell 0.60.6.1 and aspell-dict-en-2016.11.20-0 don't consider
this a valid spelling. Skip it.
--- gspell-1.3.2/testsuite/test-checker.c 2017-05-17 16:02:40.832415940 +0200
+++ gspell-1.3.2/testsuite/test-checker.c 2017-05-17 16:02:50.768351895 +0200
@@ -101,9 +101,6 @@ test_dashes (void)
checker = gspell_checker_new (lang);
TODO: Migrate to using hunspell. According to upstream, this bug won't be fixed.
See https://bugzilla.gnome.org/show_bug.cgi?id=772406.
--- a/testsuite/test-checker.c 2017-03-24 09:50:50.000000000 -0400
+++ b/testsuite/test-checker.c 2017-06-15 21:47:07.116173895 -0400
@@ -105,10 +105,11 @@
* be considered deprecated, it is better to use hunspell, so WONTFIX.
* For more details, see:
* https://bugzilla.gnome.org/show_bug.cgi?id=772406
+ *
+ * correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
+ * g_assert_no_error (error);
+ * g_assert (correctly_spelled);
*/
- correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
- g_assert_no_error (error);
- g_assert (correctly_spelled);
correctly_spelled = gspell_checker_check_word (checker, "nrst-auie", -1, &error);
g_assert_no_error (error);