gnu: fabric: Update to 1.13.2.

* gnu/packages/admin.scm (fabric): Update to 1.13.2.  Remove outdated comments.
[source]: Remove ‘patches’.
* gnu/packages/patches/fabric-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Tobias Geerinckx-Rice 2017-08-04 03:46:49 +02:00
parent 19dd5097d9
commit f58be41761
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 6 additions and 28 deletions

View File

@ -586,7 +586,6 @@ dist_patch_DATA = \
%D%/packages/patches/evilwm-lost-focus-bug.patch \
%D%/packages/patches/expat-CVE-2016-0718-fix-regression.patch \
%D%/packages/patches/exim-CVE-2017-1000369.patch \
%D%/packages/patches/fabric-tests.patch \
%D%/packages/patches/fastcap-mulGlobal.patch \
%D%/packages/patches/fastcap-mulSetup.patch \
%D%/packages/patches/fasthenry-spAllocate.patch \

View File

@ -2105,28 +2105,22 @@ Intel DRM Driver.")
(define-public fabric
(package
(name "fabric")
(version "1.13.1")
(version "1.13.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Fabric" version))
(sha256
(base32
"1z17hw0yiqp1blq217zxkg2jzkv8qd79saqhscgsw14mwlcqpwd0"))
(patches (search-patches "fabric-tests.patch"))))
"0k944dxr41whw7ib6380q9x15wyskx7fqni656icdn8rzshn9bwq"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2)) ;Python 2 only
`(#:python ,python-2)) ; Python 2 only
(native-inputs
`(("python2-fudge" ,python2-fudge) ; Requires < 1.0
("python2-jinja2" ,python2-jinja2) ; Requires < 3.0
("python2-nose" ,python2-nose))) ; Requires < 2.0
`(("python2-fudge" ,python2-fudge)
("python2-jinja2" ,python2-jinja2)
("python2-nose" ,python2-nose)))
(propagated-inputs
;; Required upgrading python-paramiko 1.17.4 to fix an incompatibility
;; between python-paramiko and newer python-pycrypto. Without this, the
;; `fab` command fails with "ValueError: CTR mode needs counter
;; parameter, not IV". See:
;; https://github.com/paramiko/paramiko/pull/714#issuecomment-281191548.
`(("python2-paramiko" ,python2-paramiko)))
(home-page "http://fabfile.org")
(synopsis "Simple Pythonic remote execution and deployment tool")

View File

@ -1,15 +0,0 @@
The `fab` excecutable doesn't exist during the test phase as it is created
dynamically during installation. Refer to the equivalent Python module
directly.
--- a/tests/test_utils.py
+++ b/tests/test_utils.py
@@ -93,7 +93,7 @@
# perform when they are allowed to bubble all the way to the top. So, we
# invoke a subprocess and look at its stderr instead.
with quiet():
- result = local("fab -f tests/support/aborts.py kaboom", capture=True)
+ result = local("python -m fabric -f tests/support/aborts.py kaboom", capture=True)
# When error in #1318 is present, this has an extra "It burns!" at end of
# stderr string.
eq_(result.stderr, "Fatal error: It burns!\n\nAborting.")