gnu: dtc: Add missing symbols patch from debian.
* gnu/packages/u-boot.scm (dtc)[source]: Add patch. * gnu/packages/patches/dtc-add-missing-symbols-to-lds.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: David Craven <david@craven.ch>
This commit is contained in:
parent
4e49163f76
commit
f63e5eaaeb
|
@ -483,6 +483,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/doc++-include-directives.patch \
|
%D%/packages/patches/doc++-include-directives.patch \
|
||||||
%D%/packages/patches/doc++-segfault-fix.patch \
|
%D%/packages/patches/doc++-segfault-fix.patch \
|
||||||
%D%/packages/patches/doxygen-test.patch \
|
%D%/packages/patches/doxygen-test.patch \
|
||||||
|
%D%/packages/patches/dtc-add-missing-symbols-to-lds.patch \
|
||||||
%D%/packages/patches/duplicity-piped-password.patch \
|
%D%/packages/patches/duplicity-piped-password.patch \
|
||||||
%D%/packages/patches/duplicity-test_selection-tmp.patch \
|
%D%/packages/patches/duplicity-test_selection-tmp.patch \
|
||||||
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
||||||
|
|
|
@ -0,0 +1,59 @@
|
||||||
|
From a4b093f7366fdb429ca1781144d3985fa50d0fbb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Julien Grall <julien.grall@linaro.org>
|
||||||
|
Date: Tue, 17 Mar 2015 16:00:34 +0000
|
||||||
|
Subject: [PATCH] libfdt: Add missing functions to shared library
|
||||||
|
|
||||||
|
The commit 4e76ec7 "libfdt: Add fdt_next_subnode() to permit easy
|
||||||
|
subnode iteration" adds new functions (fdt_{first,next}_subnode) but
|
||||||
|
forgot to mark them as 'global' in the shared library.
|
||||||
|
|
||||||
|
Signed-off-by: Julien Grall <julien.grall@linaro.org>
|
||||||
|
---
|
||||||
|
libfdt/version.lds | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/libfdt/version.lds b/libfdt/version.lds
|
||||||
|
index 80b322b..941208e 100644
|
||||||
|
--- a/libfdt/version.lds
|
||||||
|
+++ b/libfdt/version.lds
|
||||||
|
@@ -54,6 +54,8 @@ LIBFDT_1.2 {
|
||||||
|
fdt_get_property_by_offset;
|
||||||
|
fdt_getprop_by_offset;
|
||||||
|
fdt_next_property_offset;
|
||||||
|
+ fdt_first_subnode;
|
||||||
|
+ fdt_next_subnode;
|
||||||
|
|
||||||
|
local:
|
||||||
|
*;
|
||||||
|
From f58799be130e27cc729cb2d45566daa0bb3b8605 Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Gibson <david@gibson.dropbear.id.au>
|
||||||
|
Date: Tue, 1 Dec 2015 12:55:21 +1100
|
||||||
|
Subject: [PATCH] libfdt: Add some missing symbols to version.lds
|
||||||
|
|
||||||
|
Several functions in the header file were missing from the version.lds
|
||||||
|
script, meaning that they couldn't be used from a libfdt shared library.
|
||||||
|
|
||||||
|
Reported by Ken Aaker, via github issue tracker.
|
||||||
|
|
||||||
|
Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
|
||||||
|
---
|
||||||
|
libfdt/version.lds | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/libfdt/version.lds b/libfdt/version.lds
|
||||||
|
index f19f157..1f4e1ea 100644
|
||||||
|
--- a/libfdt/version.lds
|
||||||
|
+++ b/libfdt/version.lds
|
||||||
|
@@ -57,6 +57,10 @@ LIBFDT_1.2 {
|
||||||
|
fdt_next_property_offset;
|
||||||
|
fdt_first_subnode;
|
||||||
|
fdt_next_subnode;
|
||||||
|
+ fdt_address_cells;
|
||||||
|
+ fdt_size_cells;
|
||||||
|
+ fdt_stringlist_contains;
|
||||||
|
+ fdt_resize;
|
||||||
|
|
||||||
|
local:
|
||||||
|
*;
|
||||||
|
--
|
||||||
|
2.8.1
|
|
@ -40,7 +40,9 @@
|
||||||
"dtc-" version ".tar.xz"))
|
"dtc-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"155v52palf5fwfcnq696s41whjk0a5dqx98b7maqzdn7xbc2m6bp"))))
|
"155v52palf5fwfcnq696s41whjk0a5dqx98b7maqzdn7xbc2m6bp"))
|
||||||
|
(patches
|
||||||
|
(search-patches "dtc-add-missing-symbols-to-lds.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("bison" ,bison)
|
`(("bison" ,bison)
|
||||||
|
|
Loading…
Reference in New Issue