gnu: pulseaudio: Increase timeout on cpu-mix-test.

* gnu/packages/patches/pulseaudio-longer-test-timeout.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/pulseaudio.scm (pulseaudio)[source]: Add patch.
master
Mark H Weaver 2015-03-31 14:13:29 -04:00
parent 15aa2c3842
commit f6e7e20b03
3 changed files with 18 additions and 2 deletions

View File

@ -504,6 +504,7 @@ dist_patch_DATA = \
gnu/packages/patches/portaudio-audacity-compat.patch \
gnu/packages/patches/procps-make-3.82.patch \
gnu/packages/patches/pulseaudio-fix-mult-test.patch \
gnu/packages/patches/pulseaudio-longer-test-timeout.patch \
gnu/packages/patches/pybugz-encode-error.patch \
gnu/packages/patches/pybugz-stty.patch \
gnu/packages/patches/pyqt-configure.patch \

View File

@ -0,0 +1,13 @@
Increase the timeout on 'cpu-mix-test' to accommodate slower machines.
--- pulseaudio-6.0/src/tests/cpu-mix-test.c.ORIG 2015-02-12 09:10:35.000000000 -0500
+++ pulseaudio-6.0/src/tests/cpu-mix-test.c 2015-03-31 13:45:05.316878322 -0400
@@ -212,7 +212,7 @@
#if defined (__arm__) && defined (__linux__) && defined (HAVE_NEON)
tcase_add_test(tc, mix_neon_test);
#endif
- tcase_set_timeout(tc, 120);
+ tcase_set_timeout(tc, 240);
suite_add_tcase(s, tc);
sr = srunner_create(s);

View File

@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -128,7 +128,9 @@ rates. ")
'(substitute* "src/daemon/default.pa.in"
(("load-module module-console-kit" all)
(string-append "#" all "\n"))))
(patches (list (search-patch "pulseaudio-fix-mult-test.patch")))))
(patches
(list (search-patch "pulseaudio-fix-mult-test.patch")
(search-patch "pulseaudio-longer-test-timeout.patch")))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--localstatedir=/var" ;"--sysconfdir=/etc"