gnu: irrlicht: Update to 1.8.4.
* gnu/packages/games.scm (irrlicht): Update to 1.8.4. [arguments]: Delete phase "apply-patch/mesa-10-fix". [native-inputs]: Remove "patch/mesa-10-fix". * gnu/packages/patches/irrlicht-mesa-10.patch: Delete file. * gnu/local.mk (dist_path_DATA): Remove irrlicht patch.
This commit is contained in:
parent
b8a35ccea6
commit
f90b2dbdb7
|
@ -604,7 +604,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/id3lib-CVE-2007-4460.patch \
|
%D%/packages/patches/id3lib-CVE-2007-4460.patch \
|
||||||
%D%/packages/patches/ilmbase-fix-tests.patch \
|
%D%/packages/patches/ilmbase-fix-tests.patch \
|
||||||
%D%/packages/patches/inkscape-drop-wait-for-targets.patch \
|
%D%/packages/patches/inkscape-drop-wait-for-targets.patch \
|
||||||
%D%/packages/patches/irrlicht-mesa-10.patch \
|
|
||||||
%D%/packages/patches/jansson-CVE-2016-4425.patch \
|
%D%/packages/patches/jansson-CVE-2016-4425.patch \
|
||||||
%D%/packages/patches/jasper-CVE-2007-2721.patch \
|
%D%/packages/patches/jasper-CVE-2007-2721.patch \
|
||||||
%D%/packages/patches/jasper-CVE-2008-3520.patch \
|
%D%/packages/patches/jasper-CVE-2008-3520.patch \
|
||||||
|
|
|
@ -545,7 +545,7 @@ are primarily in English, however some in other languages are provided.")
|
||||||
(define-public irrlicht
|
(define-public irrlicht
|
||||||
(package
|
(package
|
||||||
(name "irrlicht")
|
(name "irrlicht")
|
||||||
(version "1.8.1")
|
(version "1.8.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
|
@ -554,10 +554,10 @@ are primarily in English, however some in other languages are provided.")
|
||||||
"/" version "/irrlicht-" version ".zip"))
|
"/" version "/irrlicht-" version ".zip"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0yz9lvsc8aqk8wj4rnpanxrw90gqpwn9w5hxp94r8hnm2q0vjjw1"))))
|
"0cz4z4dwrv5ypl19ll67wl6jjpy5k6ly4vr042w4br88qq5jhazl"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:phases (alist-cons-after
|
`(#:phases (alist-cons-after
|
||||||
'unpack 'fix-build-env
|
'unpack 'fix-build-env
|
||||||
(lambda* (#:key outputs #:allow-other-keys)
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
(let ((out (assoc-ref outputs "out")))
|
(let ((out (assoc-ref outputs "out")))
|
||||||
|
@ -572,19 +572,13 @@ are primarily in English, however some in other languages are provided.")
|
||||||
(lambda* (#:key source #:allow-other-keys)
|
(lambda* (#:key source #:allow-other-keys)
|
||||||
(and (zero? (system* "unzip" source))
|
(and (zero? (system* "unzip" source))
|
||||||
;; The actual source is buried a few directories deep.
|
;; The actual source is buried a few directories deep.
|
||||||
(chdir "irrlicht-1.8.1/source/Irrlicht/")))
|
(chdir (string-append "irrlicht-" ,version "/source/Irrlicht/"))))
|
||||||
(alist-cons-after
|
|
||||||
'unpack 'apply-patch/mesa-10-fix
|
|
||||||
(lambda* (#:key inputs #:allow-other-keys)
|
|
||||||
(zero? (system* "patch" "--force" "-p3" "-i"
|
|
||||||
(assoc-ref inputs "patch/mesa-10-fix"))))
|
|
||||||
;; No configure script
|
;; No configure script
|
||||||
(alist-delete 'configure %standard-phases))))
|
(alist-delete 'configure %standard-phases)))
|
||||||
#:tests? #f ; no check target
|
#:tests? #f ; no check target
|
||||||
#:make-flags '("CC=gcc" "sharedlib")))
|
#:make-flags '("CC=gcc" "sharedlib")))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("patch/mesa-10-fix" ,(search-patch "irrlicht-mesa-10.patch"))
|
`(("unzip" ,unzip)))
|
||||||
("unzip" ,unzip)))
|
|
||||||
(inputs
|
(inputs
|
||||||
`(("mesa" ,mesa)
|
`(("mesa" ,mesa)
|
||||||
("glu" ,glu)))
|
("glu" ,glu)))
|
||||||
|
|
|
@ -1,46 +0,0 @@
|
||||||
Patch to work around incompatibility between irrlicht-1.8.1 and mesa-10.x.
|
|
||||||
Upstream bug (fixed in trunk): http://sourceforge.net/p/irrlicht/bugs/429/
|
|
||||||
Upstream fix: http://sourceforge.net/p/irrlicht/code/4810
|
|
||||||
This patch copied from:
|
|
||||||
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-games/irrlicht/files/irrlicht-1.8.1-mesa-10.x.patch?view=markup
|
|
||||||
|
|
||||||
From 244d00280c1b082ca164f92337773e9e4e1a3898 Mon Sep 17 00:00:00 2001
|
|
||||||
From: hiker <henrichsjoerg@mgail.com>
|
|
||||||
Date: Wed, 26 Feb 2014 11:13:03 +1100
|
|
||||||
Subject: [PATCH] Applied patch from jpirie for fixing mesa 10 compilation
|
|
||||||
problems.
|
|
||||||
|
|
||||||
--- irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
|
|
||||||
+++ irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
|
|
||||||
@@ -21,6 +21,7 @@
|
|
||||||
#endif
|
|
||||||
#include <GL/gl.h>
|
|
||||||
#if defined(_IRR_OPENGL_USE_EXTPOINTER_)
|
|
||||||
+ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
|
|
||||||
#include "glext.h"
|
|
||||||
#endif
|
|
||||||
#include "wglext.h"
|
|
||||||
@@ -35,6 +36,7 @@
|
|
||||||
#endif
|
|
||||||
#include <OpenGL/gl.h>
|
|
||||||
#if defined(_IRR_OPENGL_USE_EXTPOINTER_)
|
|
||||||
+ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
|
|
||||||
#include "glext.h"
|
|
||||||
#endif
|
|
||||||
#elif defined(_IRR_COMPILE_WITH_SDL_DEVICE_) && !defined(_IRR_COMPILE_WITH_X11_DEVICE_)
|
|
||||||
@@ -48,6 +50,7 @@
|
|
||||||
#define NO_SDL_GLEXT
|
|
||||||
#include <SDL/SDL_video.h>
|
|
||||||
#include <SDL/SDL_opengl.h>
|
|
||||||
+ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
|
|
||||||
#include "glext.h"
|
|
||||||
#else
|
|
||||||
#if defined(_IRR_OPENGL_USE_EXTPOINTER_)
|
|
||||||
@@ -60,6 +63,7 @@
|
|
||||||
#include <GL/gl.h>
|
|
||||||
#include <GL/glx.h>
|
|
||||||
#if defined(_IRR_OPENGL_USE_EXTPOINTER_)
|
|
||||||
+ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
|
|
||||||
#include "glext.h"
|
|
||||||
#undef GLX_ARB_get_proc_address // avoid problems with local glxext.h
|
|
||||||
#include "glxext.h"
|
|
Loading…
Reference in New Issue