gnu: glib: Update to 2.60.6.
* gnu/packages/patches/glib-keyfile-arguments.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/glib.scm (glib): Update to 2.60.6. [source](patches): Remove obsolete patch.
This commit is contained in:
parent
014d4c1495
commit
f9f72d3536
|
@ -856,7 +856,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ghostscript-no-header-uuid.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
|
||||
%D%/packages/patches/giflib-make-reallocarray-private.patch \
|
||||
%D%/packages/patches/glib-keyfile-arguments.patch \
|
||||
%D%/packages/patches/glib-tests-timer.patch \
|
||||
%D%/packages/patches/glibc-CVE-2015-5180.patch \
|
||||
%D%/packages/patches/glibc-CVE-2015-7547.patch \
|
||||
|
|
|
@ -159,7 +159,7 @@ shared NFS home directories.")
|
|||
(define glib
|
||||
(package
|
||||
(name "glib")
|
||||
(version "2.60.5")
|
||||
(version "2.60.6")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/"
|
||||
|
@ -167,9 +167,8 @@ shared NFS home directories.")
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0bk2l9mhvc44c0gfg442wrifwj2fci1w71dsp3nb50pffvsivpry"))
|
||||
(patches (search-patches "glib-tests-timer.patch"
|
||||
"glib-keyfile-arguments.patch"))
|
||||
"0v7vpx2md1gn0wwiirn7g4bhf2csfvcr03y96q2zv97ain6sp3zz"))
|
||||
(patches (search-patches "glib-tests-timer.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
Fix a problem with the keyfile backend whereby instantiating it with
|
||||
the default NULL value would cause an assertion error:
|
||||
|
||||
https://gitlab.gnome.org/GNOME/glib/issues/1825
|
||||
|
||||
This issue showed up when running the test suites of uhttpmock and spice.
|
||||
|
||||
diff --git a/gio/gkeyfilesettingsbackend.c b/gio/gkeyfilesettingsbackend.c
|
||||
--- a/gio/gkeyfilesettingsbackend.c
|
||||
+++ b/gio/gkeyfilesettingsbackend.c
|
||||
@@ -740,7 +740,8 @@ g_keyfile_settings_backend_set_property (GObject *object,
|
||||
case PROP_FILENAME:
|
||||
/* Construct only. */
|
||||
g_assert (kfsb->file == NULL);
|
||||
- kfsb->file = g_file_new_for_path (g_value_get_string (value));
|
||||
+ if (g_value_get_string (value))
|
||||
+ kfsb->file = g_file_new_for_path (g_value_get_string (value));
|
||||
break;
|
||||
|
||||
case PROP_ROOT_PATH:
|
Loading…
Reference in New Issue