gnu: bitlbee: Upgrade to 3.2.2.
* gnu/packages/messaging.scm (bitlbee): Upgrade to 3.2.2. Remove patches. Use 'libotr' instead of 'libotr-3'. * gnu/packages/patches/bitlbee-fix-tests.patch: Remove file. * gnu/packages/patches/bitlbee-memset-fix.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove patches.
This commit is contained in:
parent
59c51be290
commit
fa40e4d4ec
|
@ -275,8 +275,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/bigloo-gc-shebangs.patch \
|
gnu/packages/patches/bigloo-gc-shebangs.patch \
|
||||||
gnu/packages/patches/binutils-ld-new-dtags.patch \
|
gnu/packages/patches/binutils-ld-new-dtags.patch \
|
||||||
gnu/packages/patches/binutils-loongson-workaround.patch \
|
gnu/packages/patches/binutils-loongson-workaround.patch \
|
||||||
gnu/packages/patches/bitlbee-fix-tests.patch \
|
|
||||||
gnu/packages/patches/bitlbee-memset-fix.patch \
|
|
||||||
gnu/packages/patches/ccache-stdc-predef-test.patch \
|
gnu/packages/patches/ccache-stdc-predef-test.patch \
|
||||||
gnu/packages/patches/cdparanoia-fpic.patch \
|
gnu/packages/patches/cdparanoia-fpic.patch \
|
||||||
gnu/packages/patches/clucene-pkgconfig.patch \
|
gnu/packages/patches/clucene-pkgconfig.patch \
|
||||||
|
|
|
@ -77,20 +77,18 @@ providing:
|
||||||
(define-public bitlbee
|
(define-public bitlbee
|
||||||
(package
|
(package
|
||||||
(name "bitlbee")
|
(name "bitlbee")
|
||||||
(version "3.2.1")
|
(version "3.2.2")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://get.bitlbee.org/src/bitlbee-"
|
(uri (string-append "http://get.bitlbee.org/src/bitlbee-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0n8g5452i5qap43zxb83gxp01d48psf6rr3k1q7z6a3dgpfi3x00"))
|
(base32 "13jmcxxgli82wb2n4hs091159xk8rgh7nb02f478lgpjh6996f5s"))))
|
||||||
(patches (list (search-patch "bitlbee-memset-fix.patch")
|
|
||||||
(search-patch "bitlbee-fix-tests.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs `(("pkg-config" ,pkg-config)
|
(native-inputs `(("pkg-config" ,pkg-config)
|
||||||
("check" ,check)))
|
("check" ,check)))
|
||||||
(inputs `(("glib" ,glib)
|
(inputs `(("glib" ,glib)
|
||||||
("libotr" ,libotr-3)
|
("libotr" ,libotr)
|
||||||
("gnutls" ,gnutls)
|
("gnutls" ,gnutls)
|
||||||
("zlib" ,zlib) ; Needed to satisfy "pkg-config --exists gnutls"
|
("zlib" ,zlib) ; Needed to satisfy "pkg-config --exists gnutls"
|
||||||
("python" ,python-2)
|
("python" ,python-2)
|
||||||
|
|
|
@ -1,33 +0,0 @@
|
||||||
Pass the correct number of arguments to 'nick_strip' and 'nick_ok' in tests.
|
|
||||||
|
|
||||||
Patch by Mark H Weaver <mhw@netris.org>.
|
|
||||||
|
|
||||||
--- bitlbee/tests/check_nick.c.orig 2013-11-27 17:54:54.000000000 -0500
|
|
||||||
+++ bitlbee/tests/check_nick.c 2014-03-05 23:41:45.761230468 -0500
|
|
||||||
@@ -30,7 +30,7 @@ START_TEST(test_nick_strip)
|
|
||||||
for (i = 0; get[i]; i++) {
|
|
||||||
char copy[60];
|
|
||||||
strcpy(copy, get[i]);
|
|
||||||
- nick_strip(copy);
|
|
||||||
+ nick_strip(NULL, copy);
|
|
||||||
fail_unless (strcmp(copy, expected[i]) == 0,
|
|
||||||
"(%d) nick_strip broken: %s -> %s (expected: %s)",
|
|
||||||
i, get[i], copy, expected[i]);
|
|
||||||
@@ -45,7 +45,7 @@ START_TEST(test_nick_ok_ok)
|
|
||||||
int i;
|
|
||||||
|
|
||||||
for (i = 0; nicks[i]; i++) {
|
|
||||||
- fail_unless (nick_ok(nicks[i]) == 1,
|
|
||||||
+ fail_unless (nick_ok(NULL, nicks[i]) == 1,
|
|
||||||
"nick_ok() failed: %s", nicks[i]);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
@@ -58,7 +58,7 @@ START_TEST(test_nick_ok_notok)
|
|
||||||
int i;
|
|
||||||
|
|
||||||
for (i = 0; nicks[i]; i++) {
|
|
||||||
- fail_unless (nick_ok(nicks[i]) == 0,
|
|
||||||
+ fail_unless (nick_ok(NULL, nicks[i]) == 0,
|
|
||||||
"nick_ok() succeeded for invalid: %s", nicks[i]);
|
|
||||||
}
|
|
||||||
}
|
|
|
@ -1,15 +0,0 @@
|
||||||
Fix the size argument to 'memset'.
|
|
||||||
|
|
||||||
Patch by Mark H Weaver <mhw@netris.org>.
|
|
||||||
|
|
||||||
--- bitlbee/lib/md5.c.orig 2013-11-27 17:54:54.000000000 -0500
|
|
||||||
+++ bitlbee/lib/md5.c 2014-03-05 21:39:04.739746093 -0500
|
|
||||||
@@ -159,7 +159,7 @@ void md5_finish(struct MD5Context *ctx,
|
|
||||||
ctx->buf[2] = cvt32(ctx->buf[2]);
|
|
||||||
ctx->buf[3] = cvt32(ctx->buf[3]);
|
|
||||||
memcpy(digest, ctx->buf, 16);
|
|
||||||
- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
|
|
||||||
+ memset(ctx, 0, sizeof(*ctx)); /* In case it's sensitive */
|
|
||||||
}
|
|
||||||
|
|
||||||
void md5_finish_ascii(struct MD5Context *context, char *ascii)
|
|
Loading…
Reference in New Issue