gnu: mumble: Fix build with Boost 1.66.

Fixes <https://bugs.gnu.org/31775>.

* gnu/packages/patches/mumble-1.2.19-abs.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/telephony.scm (mumble)[source]: Add it.
master
Danny Milosavljevic 2018-06-10 15:49:10 +02:00
parent e6c8199b66
commit fc51c11b9d
No known key found for this signature in database
GPG Key ID: E71A35542C30BAA5
3 changed files with 33 additions and 0 deletions

View File

@ -938,6 +938,7 @@ dist_patch_DATA = \
%D%/packages/patches/mozjs38-shell-version.patch \
%D%/packages/patches/mozjs38-tracelogger.patch \
%D%/packages/patches/mozjs38-version-detection.patch \
%D%/packages/patches/mumble-1.2.19-abs.patch \
%D%/packages/patches/mumps-build-parallelism.patch \
%D%/packages/patches/mupen64plus-ui-console-notice.patch \
%D%/packages/patches/mupen64plus-video-z64-glew-correct-path.patch \

View File

@ -0,0 +1,31 @@
From ea861fe86743c8402bbad77d8d1dd9de8dce447e Mon Sep 17 00:00:00 2001
From: Mikkel Krautz <mikkel@krautz.dk>
Date: Fri, 29 Dec 2017 14:47:25 +0100
Subject: [PATCH] AudioOutput: do not use non-existant template version of
std::abs.
This change fixes AudioOutput to use the float overload of std::abs:
float std::abs(float);
instead of a non-existant template version (for newer Boost 1.66).
Fixes mumble-voip/mumble#3281
---
src/mumble/AudioOutput.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/mumble/AudioOutput.cpp b/src/mumble/AudioOutput.cpp
index cbe0c0e2b..7a0a5e2ab 100644
--- a/src/mumble/AudioOutput.cpp
+++ b/src/mumble/AudioOutput.cpp
@@ -437,7 +437,7 @@ bool AudioOutput::mix(void *outbuff, unsigned int nsamp) {
top[2] = 0.0f;
}
- if (std::abs<float>(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
+ if (std::abs(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
// Not perpendicular. Assume Y up and rotate 90 degrees.
float azimuth = 0.0f;

View File

@ -387,6 +387,7 @@ address of one of the participants.")
(sha256
(base32
"1s60vaici3v034jzzi20x23hsj6mkjlc0glipjq4hffrg9qgnizh"))
(patches (search-patches "mumble-1.2.19-abs.patch"))
(modules '((guix build utils)))
(snippet
`(begin