gnu: xf86-video-nv: Update to 2.1.20.
* gnu/packages/patches/xf86-video-nv-remove-mibstore.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-video-nv): Update to 2.1.20. Add patch.
This commit is contained in:
parent
caabecf056
commit
fc7a0cf678
|
@ -467,6 +467,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/xf86-video-intel-glibc-2.20.patch \
|
||||
gnu/packages/patches/xf86-video-mach64-glibc-2.20.patch \
|
||||
gnu/packages/patches/xf86-video-mga-glibc-2.20.patch \
|
||||
gnu/packages/patches/xf86-video-nv-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-openchrome-includes.patch \
|
||||
gnu/packages/patches/xfce4-panel-plugins.patch \
|
||||
gnu/packages/patches/xmodmap-asprintf.patch
|
||||
|
|
|
@ -0,0 +1,72 @@
|
|||
Removes references to mibstore.h and miInitializeBackingStore, which
|
||||
have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
|
||||
wrote: "It was a noop for at least 5 years and it has been removed."
|
||||
See: http://patches.openembedded.org/patch/46133/
|
||||
|
||||
diff -ru xf86-video-nv-2.1.20.orig/src/g80_driver.c xf86-video-nv-2.1.20/src/g80_driver.c
|
||||
--- xf86-video-nv-2.1.20.orig/src/g80_driver.c 2012-07-17 02:47:02.000000000 -0400
|
||||
+++ xf86-video-nv-2.1.20/src/g80_driver.c 2014-12-17 10:11:42.197579082 -0500
|
||||
@@ -34,7 +34,6 @@
|
||||
#include <xf86Resources.h>
|
||||
#endif
|
||||
#include <mipointer.h>
|
||||
-#include <mibstore.h>
|
||||
#include <micmap.h>
|
||||
#include <xf86cmap.h>
|
||||
#include <fb.h>
|
||||
@@ -833,7 +832,6 @@
|
||||
}
|
||||
}
|
||||
|
||||
- miInitializeBackingStore(pScreen);
|
||||
xf86SetBackingStore(pScreen);
|
||||
xf86SetSilkenMouse(pScreen);
|
||||
|
||||
diff -ru xf86-video-nv-2.1.20.orig/src/nv_driver.c xf86-video-nv-2.1.20/src/nv_driver.c
|
||||
--- xf86-video-nv-2.1.20.orig/src/nv_driver.c 2012-07-17 02:47:02.000000000 -0400
|
||||
+++ xf86-video-nv-2.1.20/src/nv_driver.c 2014-12-17 10:11:39.037563413 -0500
|
||||
@@ -2550,7 +2550,6 @@
|
||||
if (!pNv->NoAccel)
|
||||
NVAccelInit(pScreen);
|
||||
|
||||
- miInitializeBackingStore(pScreen);
|
||||
xf86SetBackingStore(pScreen);
|
||||
xf86SetSilkenMouse(pScreen);
|
||||
|
||||
diff -ru xf86-video-nv-2.1.20.orig/src/nv_include.h xf86-video-nv-2.1.20/src/nv_include.h
|
||||
--- xf86-video-nv-2.1.20.orig/src/nv_include.h 2012-07-17 02:48:19.000000000 -0400
|
||||
+++ xf86-video-nv-2.1.20/src/nv_include.h 2014-12-17 10:11:22.089479372 -0500
|
||||
@@ -24,9 +24,6 @@
|
||||
/* All drivers initialising the SW cursor need this */
|
||||
#include "mipointer.h"
|
||||
|
||||
-/* All drivers implementing backing store need this */
|
||||
-#include "mibstore.h"
|
||||
-
|
||||
#include "micmap.h"
|
||||
|
||||
#include "xf86DDC.h"
|
||||
diff -ru xf86-video-nv-2.1.20.orig/src/riva_driver.c xf86-video-nv-2.1.20/src/riva_driver.c
|
||||
--- xf86-video-nv-2.1.20.orig/src/riva_driver.c 2012-07-17 02:47:02.000000000 -0400
|
||||
+++ xf86-video-nv-2.1.20/src/riva_driver.c 2014-12-17 10:11:31.101524060 -0500
|
||||
@@ -1168,7 +1168,6 @@
|
||||
if (!pRiva->NoAccel)
|
||||
RivaAccelInit(pScreen);
|
||||
|
||||
- miInitializeBackingStore(pScreen);
|
||||
xf86SetBackingStore(pScreen);
|
||||
xf86SetSilkenMouse(pScreen);
|
||||
|
||||
diff -ru xf86-video-nv-2.1.20.orig/src/riva_include.h xf86-video-nv-2.1.20/src/riva_include.h
|
||||
--- xf86-video-nv-2.1.20.orig/src/riva_include.h 2012-07-17 02:48:45.000000000 -0400
|
||||
+++ xf86-video-nv-2.1.20/src/riva_include.h 2014-12-17 10:11:12.229430478 -0500
|
||||
@@ -22,9 +22,6 @@
|
||||
/* All drivers initialising the SW cursor need this */
|
||||
#include "mipointer.h"
|
||||
|
||||
-/* All drivers implementing backing store need this */
|
||||
-#include "mibstore.h"
|
||||
-
|
||||
#include "micmap.h"
|
||||
|
||||
#include "xf86DDC.h"
|
|
@ -2742,17 +2742,18 @@ kernel mode setting (KMS).")
|
|||
(define-public xf86-video-nv
|
||||
(package
|
||||
(name "xf86-video-nv")
|
||||
(version "2.1.18")
|
||||
(version "2.1.20")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"mirror://xorg/X11R7.7/src/everything/xf86-video-nv-"
|
||||
"mirror://xorg/individual/driver/xf86-video-nv-"
|
||||
version
|
||||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"05glbi9jc7j9nm4sf4qvl3z87s48ibm3i283lqz85kbphg62dxvc"))))
|
||||
"1gqh1khc4zalip5hh2nksgs7i3piqq18nncgmsx9qvzi05azd5c3"))
|
||||
(patches (list (search-patch "xf86-video-nv-remove-mibstore.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("xorg-server" ,xorg-server)))
|
||||
(native-inputs `(("pkg-config" ,pkg-config)))
|
||||
|
|
Loading…
Reference in New Issue