gnu: openexr: Update to 2.3.0.
* gnu/packages/graphics.scm (openexr): Update to 2.3.0. [source](uri): Change to new download location. [source](snippet): Remove workaround. [source](patches): Remove. * gnu/packages/patches/openexr-missing-samples.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
1ae2c577a6
commit
fcde1d27bb
|
@ -1000,7 +1000,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/ola-readdir-r.patch \
|
%D%/packages/patches/ola-readdir-r.patch \
|
||||||
%D%/packages/patches/openbabel-fix-crash-on-nwchem-output.patch \
|
%D%/packages/patches/openbabel-fix-crash-on-nwchem-output.patch \
|
||||||
%D%/packages/patches/opencascade-oce-glibc-2.26.patch \
|
%D%/packages/patches/opencascade-oce-glibc-2.26.patch \
|
||||||
%D%/packages/patches/openexr-missing-samples.patch \
|
|
||||||
%D%/packages/patches/openfoam-4.1-cleanup.patch \
|
%D%/packages/patches/openfoam-4.1-cleanup.patch \
|
||||||
%D%/packages/patches/openldap-CVE-2017-9287.patch \
|
%D%/packages/patches/openldap-CVE-2017-9287.patch \
|
||||||
%D%/packages/patches/openocd-nrf52.patch \
|
%D%/packages/patches/openocd-nrf52.patch \
|
||||||
|
|
|
@ -320,29 +320,22 @@ graphics.")
|
||||||
(define-public openexr
|
(define-public openexr
|
||||||
(package
|
(package
|
||||||
(name "openexr")
|
(name "openexr")
|
||||||
(version "2.2.1")
|
(version "2.3.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://savannah/openexr/openexr-"
|
(uri (string-append "https://github.com/openexr/openexr/releases"
|
||||||
|
"/download/v" version "/openexr-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1kdf2gqznsdinbd5vcmqnif442nyhdf9l7ckc51410qm2gv5m6lg"))
|
"19jywbs9qjvsbkvlvzayzi81s976k53wg53vw4xj66lcgylb6v7x"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
'(begin
|
'(begin
|
||||||
(substitute* (find-files "." "tmpDir\\.h")
|
(substitute* (find-files "." "tmpDir\\.h")
|
||||||
(("\"/var/tmp/\"")
|
(("\"/var/tmp/\"")
|
||||||
"\"/tmp/\""))
|
"\"/tmp/\""))
|
||||||
|
#t))))
|
||||||
;; Install 'ImfStdIO.h'. Reported at
|
|
||||||
;; <https://lists.nongnu.org/archive/html/openexr-devel/2016-06/msg00001.html>
|
|
||||||
;; and <https://github.com/openexr/openexr/pull/184>.
|
|
||||||
(substitute* "IlmImf/Makefile.in"
|
|
||||||
(("ImfIO\\.h")
|
|
||||||
"ImfIO.h ImfStdIO.h"))
|
|
||||||
#t))
|
|
||||||
(patches (search-patches "openexr-missing-samples.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:phases
|
'(#:phases
|
||||||
|
|
|
@ -1,23 +0,0 @@
|
||||||
This patch comments out tests that rely on files that are missing
|
|
||||||
from the source tarball.
|
|
||||||
|
|
||||||
--- openexr-2.2.0/IlmImfTest/testSampleImages.cpp 2015-02-25 16:19:21.565105625 +0100
|
|
||||||
+++ openexr-2.2.0/IlmImfTest/testSampleImages.cpp 2015-02-25 16:21:46.394128206 +0100
|
|
||||||
@@ -162,16 +162,6 @@ testSampleImages (const std::string&)
|
|
||||||
compareImages (ILM_IMF_TEST_IMAGEDIR "comp_b44.exr",
|
|
||||||
ILM_IMF_TEST_IMAGEDIR "comp_b44_piz.exr");
|
|
||||||
|
|
||||||
- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwaa_v1.exr",
|
|
||||||
- ILM_IMF_TEST_IMAGEDIR "comp_dwaa_piz.exr");
|
|
||||||
- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwaa_v2.exr",
|
|
||||||
- ILM_IMF_TEST_IMAGEDIR "comp_dwaa_piz.exr");
|
|
||||||
-
|
|
||||||
- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwab_v1.exr",
|
|
||||||
- ILM_IMF_TEST_IMAGEDIR "comp_dwab_piz.exr");
|
|
||||||
- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwab_v2.exr",
|
|
||||||
- ILM_IMF_TEST_IMAGEDIR "comp_dwab_piz.exr");
|
|
||||||
-
|
|
||||||
|
|
||||||
cout << "ok\n" << endl;
|
|
||||||
}
|
|
||||||
|
|
Loading…
Reference in New Issue