gnu: libevent: Skip tests that fail on 32bit.
* gnu/packages/patches/libevent-2.1-skip-failing-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/libevent.scm (libevent)[source]: Use it.
This commit is contained in:
parent
47055b273a
commit
fd05d7ecd9
|
@ -676,6 +676,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libevent-2.0-evdns-fix-searching-empty-hostnames.patch \
|
||||
%D%/packages/patches/libevent-2.0-evutil-fix-buffer-overflow.patch \
|
||||
%D%/packages/patches/libevent-2.1-dns-tests.patch \
|
||||
%D%/packages/patches/libevent-2.1-skip-failing-test.patch \
|
||||
%D%/packages/patches/libextractor-ffmpeg-3.patch \
|
||||
%D%/packages/patches/libjxr-fix-function-signature.patch \
|
||||
%D%/packages/patches/libjxr-fix-typos.patch \
|
||||
|
|
|
@ -43,7 +43,10 @@
|
|||
(sha256
|
||||
(base32
|
||||
"1hhxnxlr0fsdv7bdmzsnhdz16fxf3jg2r6vyljcl3kj6pflcap4n"))
|
||||
(patches (search-patches "libevent-2.1-dns-tests.patch"))))
|
||||
(patches (search-patches "libevent-2.1-dns-tests.patch"
|
||||
;; XXX: Try removing this for > 2.1.8.
|
||||
;; https://github.com/libevent/libevent/issues/452
|
||||
"libevent-2.1-skip-failing-test.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("python" ,python-2))) ; for 'event_rpcgen.py'
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
These fail on 32-bit due to an overflow bug in the test program.
|
||||
|
||||
See test/regress_util.c:1448.
|
||||
|
||||
Upstream bug URL:
|
||||
|
||||
https://github.com/libevent/libevent/issues/452
|
||||
|
||||
diff --git a/test/regress_util.c b/test/regress_util.c
|
||||
index ef6a1487..4de501fc 100644
|
||||
--- a/test/regress_util.c
|
||||
+++ b/test/regress_util.c
|
||||
@@ -1413,9 +1413,9 @@ static struct date_rfc1123_case {
|
||||
{ 1323648000, "Mon, 12 Dec 2011 00:00:00 GMT"},
|
||||
#ifndef _WIN32
|
||||
/** In win32 case we have max "23:59:59 January 18, 2038, UTC" for time32 */
|
||||
- { 4294967296, "Sun, 07 Feb 2106 06:28:16 GMT"} /* 2^32 */,
|
||||
+ //{ 4294967296, "Sun, 07 Feb 2106 06:28:16 GMT"} /* 2^32 */,
|
||||
/** In win32 case we have max "23:59:59, December 31, 3000, UTC" for time64 */
|
||||
- {253402300799, "Fri, 31 Dec 9999 23:59:59 GMT"} /* long long future no one can imagine */,
|
||||
+ //{253402300799, "Fri, 31 Dec 9999 23:59:59 GMT"} /* long long future no one can imagine */,
|
||||
{ 1456704000, "Mon, 29 Feb 2016 00:00:00 GMT"} /* leap year */,
|
||||
#endif
|
||||
{ 1435708800, "Wed, 01 Jul 2015 00:00:00 GMT"} /* leap second */,
|
Loading…
Reference in New Issue