gnu: Borg: Update to 1.1.8.

* gnu/packages/backup.scm (borg): Update to 1.1.8.
[source]: Remove obsolete patch.
* gnu/packages/patches/borg-respect-storage-quota.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Leo Famulari 2018-12-10 10:07:44 -05:00
parent f21058dc5c
commit fec2c8532d
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 2 additions and 36 deletions

View File

@ -607,7 +607,6 @@ dist_patch_DATA = \
%D%/packages/patches/blast+-fix-makefile.patch \
%D%/packages/patches/blender-newer-ffmpeg.patch \
%D%/packages/patches/boost-fix-icu-build.patch \
%D%/packages/patches/borg-respect-storage-quota.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/cairo-CVE-2016-9082.patch \
%D%/packages/patches/cairo-setjmp-wrapper.patch \

View File

@ -491,15 +491,14 @@ detection, and lossless compression.")
(define-public borg
(package
(name "borg")
(version "1.1.7")
(version "1.1.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
(patches (search-patches "borg-respect-storage-quota.patch"))
(sha256
(base32
"1p3zia62vyg9vadkdjzzkzbj4dmgijr7ix5lmhfbxpwy5q9imdgp"))
"0qqvcscn1l4y83x4sh3izdpmr8zq38j8chjkpfq4q4d01i470hqb"))
(modules '((guix build utils)))
(snippet
'(begin

View File

@ -1,32 +0,0 @@
Make sure the client respects the storage quota set by the server:
https://github.com/borgbackup/borg/issues/4093
Patch copied from upstream source repository:
https://github.com/borgbackup/borg/commit/975cc33206e0e3644626fb7204c34d2157715b61
From 975cc33206e0e3644626fb7204c34d2157715b61 Mon Sep 17 00:00:00 2001
From: Manu <manu@snapdragon.cc>
Date: Wed, 3 Oct 2018 23:47:36 +0800
Subject: [PATCH] Add storage_quota for forced_result if set by serve command.
---
src/borg/archiver.py | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/borg/archiver.py b/src/borg/archiver.py
index 916725e7..279194c1 100644
--- a/src/borg/archiver.py
+++ b/src/borg/archiver.py
@@ -4276,6 +4276,7 @@ def get_args(self, argv, cmd):
result.restrict_to_paths = forced_result.restrict_to_paths
result.restrict_to_repositories = forced_result.restrict_to_repositories
result.append_only = forced_result.append_only
+ result.storage_quota = forced_result.storage_quota
return result
def parse_args(self, args=None):
--
2.19.1