gnu: valgrind: Fix test failure with glibc 2.26.
* gnu/packages/patches/valgrind-glibc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/valgrind.scm (valgrind)[source](patches): Use it.
This commit is contained in:
parent
1450bd3137
commit
ff9edc2c82
|
@ -1090,6 +1090,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/util-linux-tests.patch \
|
%D%/packages/patches/util-linux-tests.patch \
|
||||||
%D%/packages/patches/upower-builddir.patch \
|
%D%/packages/patches/upower-builddir.patch \
|
||||||
%D%/packages/patches/valgrind-enable-arm.patch \
|
%D%/packages/patches/valgrind-enable-arm.patch \
|
||||||
|
%D%/packages/patches/valgrind-glibc-compat.patch \
|
||||||
%D%/packages/patches/vinagre-revert-1.patch \
|
%D%/packages/patches/vinagre-revert-1.patch \
|
||||||
%D%/packages/patches/vinagre-revert-2.patch \
|
%D%/packages/patches/vinagre-revert-2.patch \
|
||||||
%D%/packages/patches/virglrenderer-CVE-2017-6386.patch \
|
%D%/packages/patches/virglrenderer-CVE-2017-6386.patch \
|
||||||
|
|
|
@ -0,0 +1,18 @@
|
||||||
|
Fix build failure with glibc 2.26.
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
https://sourceware.org/git/?p=valgrind.git;a=commit;h=2b5eab6a8db1b0487a3ad7fc4e7eeda6d3513626
|
||||||
|
|
||||||
|
diff --git a/memcheck/tests/linux/stack_changes.c b/memcheck/tests/linux/stack_changes.c
|
||||||
|
index a978fc2..7f97b90 100644
|
||||||
|
--- a/memcheck/tests/linux/stack_changes.c
|
||||||
|
+++ b/memcheck/tests/linux/stack_changes.c
|
||||||
|
@@ -10,7 +10,7 @@
|
||||||
|
// This test is checking the libc context calls (setcontext, etc.) and
|
||||||
|
// checks that Valgrind notices their stack changes properly.
|
||||||
|
|
||||||
|
-typedef struct ucontext mycontext;
|
||||||
|
+typedef ucontext_t mycontext;
|
||||||
|
|
||||||
|
mycontext ctx1, ctx2, oldc;
|
||||||
|
int count;
|
|
@ -39,7 +39,8 @@
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"18bnrw9b1d55wi1wnl68n25achsp9w48n51n1xw4fwjjnaal7jk7"))
|
"18bnrw9b1d55wi1wnl68n25achsp9w48n51n1xw4fwjjnaal7jk7"))
|
||||||
(patches (search-patches "valgrind-enable-arm.patch"))))
|
(patches (search-patches "valgrind-enable-arm.patch"
|
||||||
|
"valgrind-glibc-compat.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(outputs '("doc" ;16 MB
|
(outputs '("doc" ;16 MB
|
||||||
"out"))
|
"out"))
|
||||||
|
|
Loading…
Reference in New Issue