From 81603e53ebaae0f0b23c4c52c7dab83e808964ec Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sun, 17 Mar 2019 01:32:04 +0100
Subject: [PATCH] This patch silences the byte-compiler.

---
 zones.el | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/zones.el b/zones.el
index ca88d48..594ea36 100644
--- a/zones.el
+++ b/zones.el
@@ -1075,7 +1075,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
 
 This is a destructive operation. The list structure of the variable
 value can be modified."
-  (zz-narrow-advice (interactive-p)))
+  (zz-narrow-advice (called-interactively-p 'interactive)))
 
 (defadvice narrow-to-defun (after zz-add-zone--defun activate)
   "Push the defun limits to the current `zz-izones-var'.
@@ -1083,7 +1083,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
 
 This is a destructive operation. The list structure of the variable
 value can be modified."
-  (zz-narrow-advice (interactive-p)))
+  (zz-narrow-advice (called-interactively-p 'interactive)))
 
 ;; Call `zz-add-zone' if interactive or `zz-add-zone-anyway-p'.
 ;;
@@ -1093,7 +1093,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
 
 This is a destructive operation. The list structure of the variable
 value can be modified."
-  (zz-narrow-advice (interactive-p)))
+  (zz-narrow-advice (called-interactively-p 'interactive)))
 
 ;;(@* "General Commands")
 
-- 
2.22.0