30 lines
874 B
Diff
30 lines
874 B
Diff
Make it possible to build MuPDF with OpenJPEG 2.1, which is the latest
|
|
release series and contains many important bug fixes.
|
|
|
|
Patch adapted from Debian:
|
|
|
|
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=745246
|
|
|
|
And related to this upstream commit:
|
|
|
|
http://git.ghostscript.com/?p=mupdf.git;a=commit;h=f88bfe2e62dbadb96d4f52d7aa025f0a516078da
|
|
|
|
diff --git a/source/fitz/load-jpx.c b/source/fitz/load-jpx.c
|
|
index 6b92e5c..72dea50 100644
|
|
--- a/source/fitz/load-jpx.c
|
|
+++ b/source/fitz/load-jpx.c
|
|
@@ -1,13 +1,5 @@
|
|
#include "mupdf/fitz.h"
|
|
|
|
-/* Without the definition of OPJ_STATIC, compilation fails on windows
|
|
- * due to the use of __stdcall. We believe it is required on some
|
|
- * linux toolchains too. */
|
|
-#define OPJ_STATIC
|
|
-#ifndef _MSC_VER
|
|
-#define OPJ_HAVE_STDINT_H
|
|
-#endif
|
|
-
|
|
#include <openjpeg.h>
|
|
|
|
static void fz_opj_error_callback(const char *msg, void *client_data)
|