43 lines
1.5 KiB
Diff
43 lines
1.5 KiB
Diff
Update previous fix for CVE-2015-1283 to not rely on undefined behavior.
|
|
|
|
Copied from Debian, as found in Debian package version 2.1.0-6+deb8u2.
|
|
|
|
https://sources.debian.net/src/expat/2.1.0-6%2Bdeb8u2/debian/patches/CVE-2015-1283-refix.patch/
|
|
|
|
From 29a11774d8ebbafe8418b4a5ffb4cc1160b194a1 Mon Sep 17 00:00:00 2001
|
|
From: Pascal Cuoq <cuoq@trust-in-soft.com>
|
|
Date: Sun, 15 May 2016 09:05:46 +0200
|
|
Subject: [PATCH] Avoid relying on undefined behavior in CVE-2015-1283 fix.
|
|
|
|
---
|
|
expat/lib/xmlparse.c | 6 ++++--
|
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/lib/xmlparse.c b/lib/xmlparse.c
|
|
index 13e080d..cdb12ef 100644
|
|
--- a/lib/xmlparse.c
|
|
+++ b/lib/xmlparse.c
|
|
@@ -1695,7 +1695,8 @@ XML_GetBuffer(XML_Parser parser, int len
|
|
}
|
|
|
|
if (len > bufferLim - bufferEnd) {
|
|
- int neededSize = len + (int)(bufferEnd - bufferPtr);
|
|
+ /* Do not invoke signed arithmetic overflow: */
|
|
+ int neededSize = (int) ((unsigned)len + (unsigned)(bufferEnd - bufferPtr));
|
|
/* BEGIN MOZILLA CHANGE (sanity check neededSize) */
|
|
if (neededSize < 0) {
|
|
errorCode = XML_ERROR_NO_MEMORY;
|
|
@@ -1729,7 +1730,8 @@ XML_GetBuffer(XML_Parser parser, int len
|
|
if (bufferSize == 0)
|
|
bufferSize = INIT_BUFFER_SIZE;
|
|
do {
|
|
- bufferSize *= 2;
|
|
+ /* Do not invoke signed arithmetic overflow: */
|
|
+ bufferSize = (int) (2U * (unsigned) bufferSize);
|
|
/* BEGIN MOZILLA CHANGE (prevent infinite loop on overflow) */
|
|
} while (bufferSize < neededSize && bufferSize > 0);
|
|
/* END MOZILLA CHANGE */
|
|
--
|
|
2.8.2
|
|
|