34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
changeset: 312068:73cc9a2d8fc1
|
|
user: Timothy Nikkel <tnikkel@gmail.com>
|
|
Date: Tue May 10 22:58:47 2016 -0500
|
|
summary: Bug 1261752. Part 2. r=mats a=ritu
|
|
|
|
diff -r 380ddd689680 -r 73cc9a2d8fc1 view/nsViewManager.cpp
|
|
--- a/view/nsViewManager.cpp Tue May 10 22:58:26 2016 -0500
|
|
+++ b/view/nsViewManager.cpp Tue May 10 22:58:47 2016 -0500
|
|
@@ -372,7 +372,7 @@
|
|
}
|
|
}
|
|
if (rootShell->GetViewManager() != this) {
|
|
- return; // 'this' might have been destroyed
|
|
+ return; // presentation might have been torn down
|
|
}
|
|
if (aFlushDirtyRegion) {
|
|
nsAutoScriptBlocker scriptBlocker;
|
|
@@ -1069,6 +1069,7 @@
|
|
if (mPresShell) {
|
|
mPresShell->GetPresContext()->RefreshDriver()->RevokeViewManagerFlush();
|
|
|
|
+ RefPtr<nsViewManager> strongThis(this);
|
|
CallWillPaintOnObservers();
|
|
|
|
ProcessPendingUpdatesForView(mRootView, true);
|
|
@@ -1085,6 +1086,7 @@
|
|
|
|
if (mHasPendingWidgetGeometryChanges) {
|
|
mHasPendingWidgetGeometryChanges = false;
|
|
+ RefPtr<nsViewManager> strongThis(this);
|
|
ProcessPendingUpdatesForView(mRootView, false);
|
|
}
|
|
}
|