81 lines
2.6 KiB
Diff
81 lines
2.6 KiB
Diff
Patch copied from:
|
|
https://android.googlesource.com/platform/system/core/+/e5dd71a290f664d3f3bf0dd8a4bad411dc7ad416
|
|
|
|
From e5dd71a290f664d3f3bf0dd8a4bad411dc7ad416 Mon Sep 17 00:00:00 2001
|
|
From: Elliott Hughes <enh@google.com>
|
|
Date: Thu, 28 Jul 2016 15:15:28 -0700
|
|
Subject: [PATCH] libbase should use its own logging!
|
|
|
|
Not doing so led to us using a bogus log tag.
|
|
|
|
Bug: http://b/30281203
|
|
Change-Id: I3ac91758a1a043146c65f2ae0f36fcfbe372c30f
|
|
---
|
|
base/file.cpp | 11 +++++------
|
|
base/logging.cpp | 3 +--
|
|
2 files changed, 6 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/base/file.cpp b/base/file.cpp
|
|
index da1adba19..4e7ac82d1 100644
|
|
--- a/base/file.cpp
|
|
+++ b/base/file.cpp
|
|
@@ -24,9 +24,8 @@
|
|
#include <string>
|
|
|
|
#include "android-base/macros.h" // For TEMP_FAILURE_RETRY on Darwin.
|
|
+#include "android-base/logging.h"
|
|
#include "android-base/utf8.h"
|
|
-#define LOG_TAG "base.file"
|
|
-#include "cutils/log.h"
|
|
#include "utils/Compat.h"
|
|
|
|
namespace android {
|
|
@@ -86,22 +85,22 @@ bool WriteStringToFile(const std::string& content, const std::string& path,
|
|
int flags = O_WRONLY | O_CREAT | O_TRUNC | O_CLOEXEC | O_NOFOLLOW | O_BINARY;
|
|
int fd = TEMP_FAILURE_RETRY(open(path.c_str(), flags, mode));
|
|
if (fd == -1) {
|
|
- ALOGE("android::WriteStringToFile open failed: %s", strerror(errno));
|
|
+ PLOG(ERROR) << "android::WriteStringToFile open failed";
|
|
return false;
|
|
}
|
|
|
|
// We do an explicit fchmod here because we assume that the caller really
|
|
// meant what they said and doesn't want the umask-influenced mode.
|
|
if (fchmod(fd, mode) == -1) {
|
|
- ALOGE("android::WriteStringToFile fchmod failed: %s", strerror(errno));
|
|
+ PLOG(ERROR) << "android::WriteStringToFile fchmod failed";
|
|
return CleanUpAfterFailedWrite(path);
|
|
}
|
|
if (fchown(fd, owner, group) == -1) {
|
|
- ALOGE("android::WriteStringToFile fchown failed: %s", strerror(errno));
|
|
+ PLOG(ERROR) << "android::WriteStringToFile fchown failed";
|
|
return CleanUpAfterFailedWrite(path);
|
|
}
|
|
if (!WriteStringToFd(content, fd)) {
|
|
- ALOGE("android::WriteStringToFile write failed: %s", strerror(errno));
|
|
+ PLOG(ERROR) << "android::WriteStringToFile write failed";
|
|
return CleanUpAfterFailedWrite(path);
|
|
}
|
|
close(fd);
|
|
diff --git a/base/logging.cpp b/base/logging.cpp
|
|
index 769c266c9..959bb8b05 100644
|
|
--- a/base/logging.cpp
|
|
+++ b/base/logging.cpp
|
|
@@ -43,12 +43,11 @@
|
|
|
|
#include "android-base/macros.h"
|
|
#include "android-base/strings.h"
|
|
-#include "cutils/threads.h"
|
|
|
|
// Headers for LogMessage::LogLine.
|
|
#ifdef __ANDROID__
|
|
#include <android/set_abort_message.h>
|
|
-#include "cutils/log.h"
|
|
+#include "log/log.h"
|
|
#else
|
|
#include <sys/types.h>
|
|
#include <unistd.h>
|
|
--
|
|
2.11.0
|
|
|