62 lines
2.1 KiB
Diff
62 lines
2.1 KiB
Diff
Fix CVE-2018-14647:
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14647
|
|
https://bugs.python.org/issue34623
|
|
|
|
Taken from upstream:
|
|
https://github.com/python/cpython/commit/f7666e828cc3d5873136473ea36ba2013d624fa1
|
|
|
|
diff --git Include/pyexpat.h Include/pyexpat.h
|
|
index 44259bf6d7..07020b5dc9 100644
|
|
--- Include/pyexpat.h
|
|
+++ Include/pyexpat.h
|
|
@@ -3,7 +3,7 @@
|
|
|
|
/* note: you must import expat.h before importing this module! */
|
|
|
|
-#define PyExpat_CAPI_MAGIC "pyexpat.expat_CAPI 1.0"
|
|
+#define PyExpat_CAPI_MAGIC "pyexpat.expat_CAPI 1.1"
|
|
#define PyExpat_CAPSULE_NAME "pyexpat.expat_CAPI"
|
|
|
|
struct PyExpat_CAPI
|
|
@@ -48,6 +48,8 @@ struct PyExpat_CAPI
|
|
enum XML_Status (*SetEncoding)(XML_Parser parser, const XML_Char *encoding);
|
|
int (*DefaultUnknownEncodingHandler)(
|
|
void *encodingHandlerData, const XML_Char *name, XML_Encoding *info);
|
|
+ /* might be none for expat < 2.1.0 */
|
|
+ int (*SetHashSalt)(XML_Parser parser, unsigned long hash_salt);
|
|
/* always add new stuff to the end! */
|
|
};
|
|
|
|
diff --git Modules/_elementtree.c Modules/_elementtree.c
|
|
index 707ab2912b..53f05f937f 100644
|
|
--- Modules/_elementtree.c
|
|
+++ Modules/_elementtree.c
|
|
@@ -3261,6 +3261,11 @@ _elementtree_XMLParser___init___impl(XMLParserObject *self, PyObject *html,
|
|
PyErr_NoMemory();
|
|
return -1;
|
|
}
|
|
+ /* expat < 2.1.0 has no XML_SetHashSalt() */
|
|
+ if (EXPAT(SetHashSalt) != NULL) {
|
|
+ EXPAT(SetHashSalt)(self->parser,
|
|
+ (unsigned long)_Py_HashSecret.expat.hashsalt);
|
|
+ }
|
|
|
|
if (target) {
|
|
Py_INCREF(target);
|
|
diff --git Modules/pyexpat.c Modules/pyexpat.c
|
|
index 47c3e86c20..aa21d93c11 100644
|
|
--- Modules/pyexpat.c
|
|
+++ Modules/pyexpat.c
|
|
@@ -1887,6 +1887,11 @@ MODULE_INITFUNC(void)
|
|
capi.SetStartDoctypeDeclHandler = XML_SetStartDoctypeDeclHandler;
|
|
capi.SetEncoding = XML_SetEncoding;
|
|
capi.DefaultUnknownEncodingHandler = PyUnknownEncodingHandler;
|
|
+#if XML_COMBINED_VERSION >= 20100
|
|
+ capi.SetHashSalt = XML_SetHashSalt;
|
|
+#else
|
|
+ capi.SetHashSalt = NULL;
|
|
+#endif
|
|
|
|
/* export using capsule */
|
|
capi_object = PyCapsule_New(&capi, PyExpat_CAPSULE_NAME, NULL);
|