83 lines
3.7 KiB
Diff
83 lines
3.7 KiB
Diff
Clang attempts to guess file names based on the OS and distro (yes!),
|
|
but unfortunately, that doesn't work for us.
|
|
|
|
This patch makes it easy to insert libc's $libdir so that Clang passes the
|
|
correct absolute file name of crt1.o etc. to 'ld'. It also disables all
|
|
the distro-specific stuff and removes the hard-coded FHS directory names
|
|
to make sure Clang also works on non-GuixSD systems.
|
|
|
|
--- a/lib/Driver/ToolChains/Linux.cpp
|
|
+++ b/lib/Driver/ToolChains/Linux.cpp
|
|
@@ -225,7 +225,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
PPaths.push_back(Twine(GCCInstallation.getParentLibPath() + "/../" +
|
|
GCCInstallation.getTriple().str() + "/bin")
|
|
.str());
|
|
-
|
|
+ // Comment out the distro-specific tweaks so that they don't bite when
|
|
+ // using Guix on a foreign distro.
|
|
+#if 0
|
|
Distro Distro(D.getVFS());
|
|
|
|
if (Distro.IsAlpineLinux()) {
|
|
@@ -284,6 +286,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
|
|
if (IsAndroid || Distro.IsOpenSUSE())
|
|
ExtraOpts.push_back("--enable-new-dtags");
|
|
+#endif
|
|
|
|
// The selection of paths to try here is designed to match the patterns which
|
|
// the GCC driver itself uses, as this is part of the GCC-compatible driver.
|
|
@@ -342,7 +345,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
// the cross. Note that GCC does include some of these directories in some
|
|
// configurations but this seems somewhere between questionable and simply
|
|
// a bug.
|
|
- if (StringRef(LibPath).startswith(SysRoot)) {
|
|
+ if (0) {
|
|
addPathIfExists(D, LibPath + "/" + MultiarchTriple, Paths);
|
|
addPathIfExists(D, LibPath + "/../" + OSLibDir, Paths);
|
|
}
|
|
@@ -361,6 +364,8 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
addPathIfExists(D, SysRoot + "/lib/" + MultiarchTriple, Paths);
|
|
addPathIfExists(D, SysRoot + "/lib/../" + OSLibDir, Paths);
|
|
|
|
+ // This requires the commented distro tweaks above.
|
|
+#if 0
|
|
if (IsAndroid) {
|
|
// Android sysroots contain a library directory for each supported OS
|
|
// version as well as some unversioned libraries in the usual multiarch
|
|
@@ -389,10 +394,14 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
addPathIfExists(D, SysRoot + "/" + OSLibDir + "/" + ABIName, Paths);
|
|
addPathIfExists(D, SysRoot + "/usr/" + OSLibDir + "/" + ABIName, Paths);
|
|
}
|
|
+#endif
|
|
|
|
// Try walking via the GCC triple path in case of biarch or multiarch GCC
|
|
// installations with strange symlinks.
|
|
if (GCCInstallation.isValid()) {
|
|
+ // The following code would end up adding things like
|
|
+ // "/usr/lib/x86_64-unknown-linux-gnu/../../lib64" to the search path.
|
|
+#if 0
|
|
addPathIfExists(D,
|
|
SysRoot + "/usr/lib/" + GCCInstallation.getTriple().str() +
|
|
"/../../" + OSLibDir,
|
|
@@ -405,6 +414,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
BiarchSibling.gccSuffix(),
|
|
Paths);
|
|
}
|
|
+#endif
|
|
|
|
// See comments above on the multilib variant for details of why this is
|
|
// included even from outside the sysroot.
|
|
@@ -429,8 +439,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
if (StringRef(D.Dir).startswith(SysRoot))
|
|
addPathIfExists(D, D.Dir + "/../lib", Paths);
|
|
|
|
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
|
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
|
+ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
|
|
+ // and friends can be found.
|
|
+ addPathIfExists(D, "@GLIBC_LIBDIR@", Paths);
|
|
}
|
|
|
|
bool Linux::HasNativeLLVMSupport() const { return true; }
|