47 lines
2.0 KiB
Diff
47 lines
2.0 KiB
Diff
Add an extra layer of quoting to ltmain.sh sanity check.
|
|
|
|
--- a/configure 2005-05-07 14:19:31.000000000 +0200
|
|
+++ b/configure 2015-02-10 11:16:32.456146934 +0100
|
|
@@ -6266,7 +6266,7 @@
|
|
exit 1
|
|
fi
|
|
gentoo_lt_version="1.5.16"
|
|
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
|
|
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
|
|
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
|
|
echo "$as_me:$LINENO: result: no" >&5
|
|
echo "${ECHO_T}no" >&6
|
|
--- a/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
|
|
+++ b/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
|
|
@@ -246,7 +246,7 @@
|
|
exit 1
|
|
fi
|
|
gentoo_lt_version="1.5.16"
|
|
-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
|
|
+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
|
|
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
|
|
AC_MSG_RESULT(no)
|
|
echo
|
|
--- a/libcpufreq/configure 2005-05-07 14:19:31.000000000 +0200
|
|
+++ b/libcpufreq/configure 2015-02-10 11:16:32.456146934 +0100
|
|
@@ -6266,7 +6266,7 @@
|
|
exit 1
|
|
fi
|
|
gentoo_lt_version="1.5.16"
|
|
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
|
|
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
|
|
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
|
|
echo "$as_me:$LINENO: result: no" >&5
|
|
echo "${ECHO_T}no" >&6
|
|
--- a/libcpufreq/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
|
|
+++ b/libcpufreq/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
|
|
@@ -246,7 +246,7 @@
|
|
exit 1
|
|
fi
|
|
gentoo_lt_version="1.5.16"
|
|
-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
|
|
+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
|
|
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
|
|
AC_MSG_RESULT(no)
|
|
echo
|