539 lines
21 KiB
Diff
539 lines
21 KiB
Diff
https://src.fedoraproject.org/cgit/rpms/freeimage.git/tree/FreeImage-3.17.0_unbundle.patch
|
|
|
|
diff -rupN FreeImage/genfipsrclist.sh FreeImage-new/genfipsrclist.sh
|
|
--- FreeImage/genfipsrclist.sh 2015-02-20 10:52:16.000000000 +0100
|
|
+++ FreeImage-new/genfipsrclist.sh 2015-09-05 02:13:52.041353305 +0200
|
|
@@ -1,6 +1,6 @@
|
|
#!/bin/sh
|
|
|
|
-DIRLIST=". Source Source/Metadata Source/FreeImageToolkit Source/LibJPEG Source/LibPNG Source/LibTIFF4 Source/ZLib Source/LibOpenJPEG Source/OpenEXR Source/OpenEXR/Half Source/OpenEXR/Iex Source/OpenEXR/IlmImf Source/OpenEXR/IlmThread Source/OpenEXR/Imath Source/OpenEXR/IexMath Source/LibRawLite Source/LibRawLite/dcraw Source/LibRawLite/internal Source/LibRawLite/libraw Source/LibRawLite/src Source/LibWebP Source/LibJXR Source/LibJXR/common/include Source/LibJXR/image/sys Source/LibJXR/jxrgluelib Wrapper/FreeImagePlus"
|
|
+DIRLIST="Wrapper/FreeImagePlus"
|
|
|
|
|
|
echo "VER_MAJOR = 3" > fipMakefile.srcs
|
|
@@ -19,5 +19,6 @@ echo -n "INCLUDE =" >> fipMakefile.srcs
|
|
for DIR in $DIRLIST; do
|
|
echo -n " -I$DIR" >> fipMakefile.srcs
|
|
done
|
|
+echo -n " -IDist" >> fipMakefile.srcs
|
|
echo >> fipMakefile.srcs
|
|
|
|
diff -rupN FreeImage/gensrclist.sh FreeImage-new/gensrclist.sh
|
|
--- FreeImage/gensrclist.sh 2015-02-20 10:51:50.000000000 +0100
|
|
+++ FreeImage-new/gensrclist.sh 2015-09-05 02:13:52.041353305 +0200
|
|
@@ -1,6 +1,6 @@
|
|
#!/bin/sh
|
|
|
|
-DIRLIST=". Source Source/Metadata Source/FreeImageToolkit Source/LibJPEG Source/LibPNG Source/LibTIFF4 Source/ZLib Source/LibOpenJPEG Source/OpenEXR Source/OpenEXR/Half Source/OpenEXR/Iex Source/OpenEXR/IlmImf Source/OpenEXR/IlmThread Source/OpenEXR/Imath Source/OpenEXR/IexMath Source/LibRawLite Source/LibRawLite/dcraw Source/LibRawLite/internal Source/LibRawLite/libraw Source/LibRawLite/src Source/LibWebP Source/LibJXR Source/LibJXR/common/include Source/LibJXR/image/sys Source/LibJXR/jxrgluelib"
|
|
+DIRLIST=". Source Source/Metadata Source/FreeImageToolkit Source/LibJXR Source/LibJXR/common/include Source/LibJXR/image/sys Source/LibJXR/jxrgluelib"
|
|
|
|
echo "VER_MAJOR = 3" > Makefile.srcs
|
|
echo "VER_MINOR = 17.0" >> Makefile.srcs
|
|
diff -rupN FreeImage/Makefile.fip FreeImage-new/Makefile.fip
|
|
--- FreeImage/Makefile.fip 2015-03-08 18:03:56.000000000 +0100
|
|
+++ FreeImage-new/Makefile.fip 2015-09-05 02:14:09.212684028 +0200
|
|
@@ -17,20 +17,22 @@ MODULES = $(SRCS:.c=.o)
|
|
MODULES := $(MODULES:.cpp=.o)
|
|
CFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden
|
|
# OpenJPEG
|
|
-CFLAGS += -DOPJ_STATIC
|
|
+override CFLAGS += -DOPJ_STATIC
|
|
# LibRaw
|
|
-CFLAGS += -DNO_LCMS
|
|
+override CFLAGS += -DNO_LCMS
|
|
# LibJXR
|
|
-CFLAGS += -DDISABLE_PERF_MEASUREMENT -D__ANSI__
|
|
-CFLAGS += $(INCLUDE)
|
|
+override CFLAGS += -DDISABLE_PERF_MEASUREMENT -D__ANSI__
|
|
+override CFLAGS += $(INCLUDE)
|
|
CXXFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
|
|
# LibJXR
|
|
-CXXFLAGS += -D__ANSI__
|
|
-CXXFLAGS += $(INCLUDE)
|
|
+override CXXFLAGS += -D__ANSI__
|
|
+override CXXFLAGS += $(INCLUDE)
|
|
+LDFLAGS ?=
|
|
+override LDFLAGS += -LDist -lfreeimage-$(VER_MAJOR).$(VER_MINOR)
|
|
|
|
ifeq ($(shell sh -c 'uname -m 2>/dev/null || echo not'),x86_64)
|
|
- CFLAGS += -fPIC
|
|
- CXXFLAGS += -fPIC
|
|
+ override CFLAGS += -fPIC
|
|
+ override CXXFLAGS += -fPIC
|
|
endif
|
|
|
|
TARGET = freeimageplus
|
|
@@ -68,7 +70,7 @@ $(STATICLIB): $(MODULES)
|
|
$(AR) r $@ $(MODULES)
|
|
|
|
$(SHAREDLIB): $(MODULES)
|
|
- $(CC) -s -shared -Wl,-soname,$(VERLIBNAME) $(LDFLAGS) -o $@ $(MODULES) $(LIBRARIES)
|
|
+ $(CC) -shared -Wl,-soname,$(VERLIBNAME) $(LDFLAGS) -o $@ $(MODULES) $(LIBRARIES)
|
|
|
|
install:
|
|
install -d $(INCDIR) $(INSTALLDIR)
|
|
diff -rupN FreeImage/Makefile.gnu FreeImage-new/Makefile.gnu
|
|
--- FreeImage/Makefile.gnu 2015-03-08 18:04:00.000000000 +0100
|
|
+++ FreeImage-new/Makefile.gnu 2015-09-05 02:14:04.810599259 +0200
|
|
@@ -16,21 +16,11 @@ LIBRARIES = -lstdc++
|
|
MODULES = $(SRCS:.c=.o)
|
|
MODULES := $(MODULES:.cpp=.o)
|
|
CFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden
|
|
-# OpenJPEG
|
|
-CFLAGS += -DOPJ_STATIC
|
|
-# LibRaw
|
|
-CFLAGS += -DNO_LCMS
|
|
-# LibJXR
|
|
-CFLAGS += -DDISABLE_PERF_MEASUREMENT -D__ANSI__
|
|
-CFLAGS += $(INCLUDE)
|
|
-CXXFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
|
|
-# LibJXR
|
|
-CXXFLAGS += -D__ANSI__
|
|
-CXXFLAGS += $(INCLUDE)
|
|
+override CFLAGS += $(INCLUDE) -D__ANSI__ $(shell pkg-config --cflags OpenEXR libopenjp2 libraw libpng libtiff-4 libwebp libwebpmux zlib)
|
|
+override LDFLAGS += -ljpeg $(shell pkg-config --libs OpenEXR libopenjp2 libraw libpng libtiff-4 libwebp libwebpmux zlib)
|
|
|
|
ifeq ($(shell sh -c 'uname -m 2>/dev/null || echo not'),x86_64)
|
|
- CFLAGS += -fPIC
|
|
- CXXFLAGS += -fPIC
|
|
+ override CFLAGS += -fPIC
|
|
endif
|
|
|
|
TARGET = freeimage
|
|
@@ -61,13 +51,13 @@ FreeImage: $(STATICLIB) $(SHAREDLIB)
|
|
$(CC) $(CFLAGS) -c $< -o $@
|
|
|
|
.cpp.o:
|
|
- $(CXX) $(CXXFLAGS) -c $< -o $@
|
|
+ $(CXX) $(CFLAGS) -c $< -o $@
|
|
|
|
$(STATICLIB): $(MODULES)
|
|
$(AR) r $@ $(MODULES)
|
|
|
|
$(SHAREDLIB): $(MODULES)
|
|
- $(CC) -s -shared -Wl,-soname,$(VERLIBNAME) $(LDFLAGS) -o $@ $(MODULES) $(LIBRARIES)
|
|
+ $(CC) -shared -Wl,-soname,$(VERLIBNAME) $(LDFLAGS) -o $@ $(MODULES) $(LIBRARIES)
|
|
|
|
install:
|
|
install -d $(INCDIR) $(INSTALLDIR)
|
|
diff -rupN FreeImage/Source/FreeImage/J2KHelper.cpp FreeImage-new/Source/FreeImage/J2KHelper.cpp
|
|
--- FreeImage/Source/FreeImage/J2KHelper.cpp 2015-03-02 02:07:08.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/J2KHelper.cpp 2015-09-05 02:13:52.042353324 +0200
|
|
@@ -21,7 +21,7 @@
|
|
|
|
#include "FreeImage.h"
|
|
#include "Utilities.h"
|
|
-#include "../LibOpenJPEG/openjpeg.h"
|
|
+#include <openjpeg.h>
|
|
#include "J2KHelper.h"
|
|
|
|
// --------------------------------------------------------------------------
|
|
diff -rupN FreeImage/Source/FreeImage/Plugin.cpp FreeImage-new/Source/FreeImage/Plugin.cpp
|
|
--- FreeImage/Source/FreeImage/Plugin.cpp 2015-03-02 02:07:08.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/Plugin.cpp 2015-09-05 02:13:52.042353324 +0200
|
|
@@ -263,7 +263,12 @@ FreeImage_Initialise(BOOL load_local_plu
|
|
s_plugins->AddNode(InitDDS);
|
|
s_plugins->AddNode(InitGIF);
|
|
s_plugins->AddNode(InitHDR);
|
|
- s_plugins->AddNode(InitG3);
|
|
+/* The G3 fax format plugin is deliberately disabled in the Fedora build of
|
|
+ FreeImage as it requires that FreeImage uses a private copy of libtiff
|
|
+ which is a no no because of security reasons. */
|
|
+#if 0
|
|
+ s_plugins->AddNode(InitG3);
|
|
+#endif
|
|
s_plugins->AddNode(InitSGI);
|
|
s_plugins->AddNode(InitEXR);
|
|
s_plugins->AddNode(InitJ2K);
|
|
diff -rupN FreeImage/Source/FreeImage/PluginEXR.cpp FreeImage-new/Source/FreeImage/PluginEXR.cpp
|
|
--- FreeImage/Source/FreeImage/PluginEXR.cpp 2015-03-02 02:07:08.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/PluginEXR.cpp 2015-09-05 02:13:52.042353324 +0200
|
|
@@ -28,16 +28,16 @@
|
|
#pragma warning (disable : 4800) // ImfVersion.h - 'const int' : forcing value to bool 'true' or 'false' (performance warning)
|
|
#endif
|
|
|
|
-#include "../OpenEXR/IlmImf/ImfIO.h"
|
|
-#include "../OpenEXR/Iex/Iex.h"
|
|
-#include "../OpenEXR/IlmImf/ImfOutputFile.h"
|
|
-#include "../OpenEXR/IlmImf/ImfInputFile.h"
|
|
-#include "../OpenEXR/IlmImf/ImfRgbaFile.h"
|
|
-#include "../OpenEXR/IlmImf/ImfChannelList.h"
|
|
-#include "../OpenEXR/IlmImf/ImfRgba.h"
|
|
-#include "../OpenEXR/IlmImf/ImfArray.h"
|
|
-#include "../OpenEXR/IlmImf/ImfPreviewImage.h"
|
|
-#include "../OpenEXR/Half/half.h"
|
|
+#include <OpenEXR/ImfIO.h>
|
|
+#include <OpenEXR/Iex.h>
|
|
+#include <OpenEXR/ImfOutputFile.h>
|
|
+#include <OpenEXR/ImfInputFile.h>
|
|
+#include <OpenEXR/ImfRgbaFile.h>
|
|
+#include <OpenEXR/ImfChannelList.h>
|
|
+#include <OpenEXR/ImfRgba.h>
|
|
+#include <OpenEXR/ImfArray.h>
|
|
+#include <OpenEXR/ImfPreviewImage.h>
|
|
+#include <OpenEXR/half.h>
|
|
|
|
|
|
// ==========================================================
|
|
diff -rupN FreeImage/Source/FreeImage/PluginJ2K.cpp FreeImage-new/Source/FreeImage/PluginJ2K.cpp
|
|
--- FreeImage/Source/FreeImage/PluginJ2K.cpp 2015-03-02 02:07:08.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/PluginJ2K.cpp 2015-09-05 02:13:52.043353343 +0200
|
|
@@ -21,7 +21,7 @@
|
|
|
|
#include "FreeImage.h"
|
|
#include "Utilities.h"
|
|
-#include "../LibOpenJPEG/openjpeg.h"
|
|
+#include <openjpeg.h>
|
|
#include "J2KHelper.h"
|
|
|
|
// ==========================================================
|
|
diff -rupN FreeImage/Source/FreeImage/PluginJP2.cpp FreeImage-new/Source/FreeImage/PluginJP2.cpp
|
|
--- FreeImage/Source/FreeImage/PluginJP2.cpp 2015-03-02 02:07:08.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/PluginJP2.cpp 2015-09-05 02:13:52.043353343 +0200
|
|
@@ -21,7 +21,7 @@
|
|
|
|
#include "FreeImage.h"
|
|
#include "Utilities.h"
|
|
-#include "../LibOpenJPEG/openjpeg.h"
|
|
+#include <openjpeg.h>
|
|
#include "J2KHelper.h"
|
|
|
|
// ==========================================================
|
|
diff -rupN FreeImage/Source/FreeImage/PluginJPEG.cpp FreeImage-new/Source/FreeImage/PluginJPEG.cpp
|
|
--- FreeImage/Source/FreeImage/PluginJPEG.cpp 2015-03-02 02:07:08.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/PluginJPEG.cpp 2015-09-05 02:13:52.043353343 +0200
|
|
@@ -35,9 +35,9 @@ extern "C" {
|
|
#undef FAR
|
|
#include <setjmp.h>
|
|
|
|
-#include "../LibJPEG/jinclude.h"
|
|
-#include "../LibJPEG/jpeglib.h"
|
|
-#include "../LibJPEG/jerror.h"
|
|
+#include <stdio.h>
|
|
+#include <jpeglib.h>
|
|
+#include <jerror.h>
|
|
}
|
|
|
|
#include "FreeImage.h"
|
|
diff -rupN FreeImage/Source/FreeImage/PluginPNG.cpp FreeImage-new/Source/FreeImage/PluginPNG.cpp
|
|
--- FreeImage/Source/FreeImage/PluginPNG.cpp 2015-03-10 20:16:12.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/PluginPNG.cpp 2015-09-05 02:13:52.044353363 +0200
|
|
@@ -40,8 +40,8 @@
|
|
|
|
// ----------------------------------------------------------
|
|
|
|
-#include "../ZLib/zlib.h"
|
|
-#include "../LibPNG/png.h"
|
|
+#include <zlib.h>
|
|
+#include <png.h>
|
|
|
|
// ----------------------------------------------------------
|
|
|
|
diff -rupN FreeImage/Source/FreeImage/PluginRAW.cpp FreeImage-new/Source/FreeImage/PluginRAW.cpp
|
|
--- FreeImage/Source/FreeImage/PluginRAW.cpp 2015-03-08 20:12:04.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/PluginRAW.cpp 2015-09-05 02:13:52.044353363 +0200
|
|
@@ -19,7 +19,7 @@
|
|
// Use at your own risk!
|
|
// ==========================================================
|
|
|
|
-#include "../LibRawLite/libraw/libraw.h"
|
|
+#include <libraw/libraw.h>
|
|
|
|
#include "FreeImage.h"
|
|
#include "Utilities.h"
|
|
diff -rupN FreeImage/Source/FreeImage/PluginTIFF.cpp FreeImage-new/Source/FreeImage/PluginTIFF.cpp
|
|
--- FreeImage/Source/FreeImage/PluginTIFF.cpp 2015-03-02 02:07:08.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/PluginTIFF.cpp 2015-09-05 02:13:52.044353363 +0200
|
|
@@ -37,9 +37,9 @@
|
|
|
|
#include "FreeImage.h"
|
|
#include "Utilities.h"
|
|
-#include "../LibTIFF4/tiffiop.h"
|
|
+#include <tiffio.h>
|
|
#include "../Metadata/FreeImageTag.h"
|
|
-#include "../OpenEXR/Half/half.h"
|
|
+#include <OpenEXR/half.h>
|
|
|
|
#include "FreeImageIO.h"
|
|
#include "PSDParser.h"
|
|
@@ -194,16 +194,6 @@ TIFFFdOpen(thandle_t handle, const char
|
|
return tif;
|
|
}
|
|
|
|
-/**
|
|
-Open a TIFF file for reading or writing
|
|
-@param name
|
|
-@param mode
|
|
-*/
|
|
-TIFF*
|
|
-TIFFOpen(const char* name, const char* mode) {
|
|
- return 0;
|
|
-}
|
|
-
|
|
// ----------------------------------------------------------
|
|
// TIFF library FreeImage-specific routines.
|
|
// ----------------------------------------------------------
|
|
diff -rupN FreeImage/Source/FreeImage/PluginWebP.cpp FreeImage-new/Source/FreeImage/PluginWebP.cpp
|
|
--- FreeImage/Source/FreeImage/PluginWebP.cpp 2015-03-02 02:07:08.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/PluginWebP.cpp 2015-09-05 02:13:52.044353363 +0200
|
|
@@ -24,10 +24,10 @@
|
|
|
|
#include "../Metadata/FreeImageTag.h"
|
|
|
|
-#include "../LibWebP/src/webp/decode.h"
|
|
-#include "../LibWebP/src/webp/encode.h"
|
|
-#include "../LibWebP/src/enc/vp8enci.h"
|
|
-#include "../LibWebP/src/webp/mux.h"
|
|
+#include <webp/decode.h>
|
|
+#include <webp/encode.h>
|
|
+// #include "../LibWebP/src/enc/vp8enci.h"
|
|
+#include <webp/mux.h>
|
|
|
|
// ==========================================================
|
|
// Plugin Interface
|
|
diff -rupN FreeImage/Source/FreeImage/ZLibInterface.cpp FreeImage-new/Source/FreeImage/ZLibInterface.cpp
|
|
--- FreeImage/Source/FreeImage/ZLibInterface.cpp 2015-03-02 02:07:10.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage/ZLibInterface.cpp 2015-09-05 02:13:52.044353363 +0200
|
|
@@ -19,10 +19,9 @@
|
|
// Use at your own risk!
|
|
// ==========================================================
|
|
|
|
-#include "../ZLib/zlib.h"
|
|
+#include <zlib.h>
|
|
#include "FreeImage.h"
|
|
#include "Utilities.h"
|
|
-#include "../ZLib/zutil.h" /* must be the last header because of error C3163 in VS2008 (_vsnprintf defined in stdio.h) */
|
|
|
|
/**
|
|
Compresses a source buffer into a target buffer, using the ZLib library.
|
|
@@ -115,7 +114,7 @@ FreeImage_ZLibGZip(BYTE *target, DWORD t
|
|
return 0;
|
|
case Z_OK: {
|
|
// patch header, setup crc and length (stolen from mod_trace_output)
|
|
- BYTE *p = target + 8; *p++ = 2; *p = OS_CODE; // xflags, os_code
|
|
+ BYTE *p = target + 8; *p++ = 2; *p = 0x03; // xflags, os_code (unix)
|
|
crc = crc32(crc, source, source_size);
|
|
memcpy(target + 4 + dest_len, &crc, 4);
|
|
memcpy(target + 8 + dest_len, &source_size, 4);
|
|
diff -rupN FreeImage/Source/FreeImage.h FreeImage-new/Source/FreeImage.h
|
|
--- FreeImage/Source/FreeImage.h 2015-03-04 02:17:54.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImage.h 2015-09-05 02:13:52.045353382 +0200
|
|
@@ -155,8 +155,11 @@ typedef uint8_t BYTE;
|
|
typedef uint16_t WORD;
|
|
typedef uint32_t DWORD;
|
|
typedef int32_t LONG;
|
|
+// Disable these, they conflict with the (wrong) ones of libraw
|
|
+#if 0
|
|
typedef int64_t INT64;
|
|
typedef uint64_t UINT64;
|
|
+#endif
|
|
#else
|
|
// MS is not C99 ISO compliant
|
|
typedef long BOOL;
|
|
@@ -410,7 +413,12 @@ FI_ENUM(FREE_IMAGE_FORMAT) {
|
|
FIF_DDS = 24,
|
|
FIF_GIF = 25,
|
|
FIF_HDR = 26,
|
|
- FIF_FAXG3 = 27,
|
|
+/* The G3 fax format plugin is deliberately disabled in the Fedora build of
|
|
+ FreeImage as it requires that FreeImage uses a private copy of libtiff
|
|
+ which is a no no because of security reasons. */
|
|
+#if 0
|
|
+ FIF_FAXG3 = 27,
|
|
+#endif
|
|
FIF_SGI = 28,
|
|
FIF_EXR = 29,
|
|
FIF_J2K = 30,
|
|
@@ -473,6 +481,10 @@ FI_ENUM(FREE_IMAGE_DITHER) {
|
|
FID_BAYER16x16 = 6 //! Bayer ordered dispersed dot dithering (order 4 dithering matrix)
|
|
};
|
|
|
|
+/* The FreeImage_JPEGTransform functions are deliberately disabled in the
|
|
+ Fedora build of FreeImage as they require that FreeImage uses a private copy
|
|
+ of libjpeg which is a no no because of security reasons. */
|
|
+#if 0
|
|
/** Lossless JPEG transformations
|
|
Constants used in FreeImage_JPEGTransform
|
|
*/
|
|
@@ -486,6 +498,7 @@ FI_ENUM(FREE_IMAGE_JPEG_OPERATION) {
|
|
FIJPEG_OP_ROTATE_180 = 6, //! 180-degree rotation
|
|
FIJPEG_OP_ROTATE_270 = 7 //! 270-degree clockwise (or 90 ccw)
|
|
};
|
|
+#endif
|
|
|
|
/** Tone mapping operators.
|
|
Constants used in FreeImage_ToneMapping.
|
|
@@ -1076,7 +1089,10 @@ DLL_API const char* DLL_CALLCONV FreeIma
|
|
// --------------------------------------------------------------------------
|
|
// JPEG lossless transformation routines
|
|
// --------------------------------------------------------------------------
|
|
-
|
|
+/* The FreeImage_JPEGTransform functions are deliberately disabled in the
|
|
++ Fedora build of FreeImage as they require that FreeImage uses a private copy
|
|
++ of libjpeg which is a no no because of security reasons. */
|
|
+#if 0
|
|
DLL_API BOOL DLL_CALLCONV FreeImage_JPEGTransform(const char *src_file, const char *dst_file, FREE_IMAGE_JPEG_OPERATION operation, BOOL perfect FI_DEFAULT(TRUE));
|
|
DLL_API BOOL DLL_CALLCONV FreeImage_JPEGTransformU(const wchar_t *src_file, const wchar_t *dst_file, FREE_IMAGE_JPEG_OPERATION operation, BOOL perfect FI_DEFAULT(TRUE));
|
|
DLL_API BOOL DLL_CALLCONV FreeImage_JPEGCrop(const char *src_file, const char *dst_file, int left, int top, int right, int bottom);
|
|
@@ -1085,6 +1101,7 @@ DLL_API BOOL DLL_CALLCONV FreeImage_JPEG
|
|
DLL_API BOOL DLL_CALLCONV FreeImage_JPEGTransformCombined(const char *src_file, const char *dst_file, FREE_IMAGE_JPEG_OPERATION operation, int* left, int* top, int* right, int* bottom, BOOL perfect FI_DEFAULT(TRUE));
|
|
DLL_API BOOL DLL_CALLCONV FreeImage_JPEGTransformCombinedU(const wchar_t *src_file, const wchar_t *dst_file, FREE_IMAGE_JPEG_OPERATION operation, int* left, int* top, int* right, int* bottom, BOOL perfect FI_DEFAULT(TRUE));
|
|
DLL_API BOOL DLL_CALLCONV FreeImage_JPEGTransformCombinedFromMemory(FIMEMORY* src_stream, FIMEMORY* dst_stream, FREE_IMAGE_JPEG_OPERATION operation, int* left, int* top, int* right, int* bottom, BOOL perfect FI_DEFAULT(TRUE));
|
|
+#endif
|
|
|
|
|
|
// --------------------------------------------------------------------------
|
|
diff -rupN FreeImage/Source/FreeImageToolkit/JPEGTransform.cpp FreeImage-new/Source/FreeImageToolkit/JPEGTransform.cpp
|
|
--- FreeImage/Source/FreeImageToolkit/JPEGTransform.cpp 2015-03-02 02:07:10.000000000 +0100
|
|
+++ FreeImage-new/Source/FreeImageToolkit/JPEGTransform.cpp 2015-09-05 02:13:52.045353382 +0200
|
|
@@ -26,10 +26,10 @@ extern "C" {
|
|
#undef FAR
|
|
#include <setjmp.h>
|
|
|
|
-#include "../LibJPEG/jinclude.h"
|
|
-#include "../LibJPEG/jpeglib.h"
|
|
-#include "../LibJPEG/jerror.h"
|
|
-#include "../LibJPEG/transupp.h"
|
|
+#include <jinclude.h>
|
|
+#include <jpeglib.h>
|
|
+#include <jerror.h>
|
|
+#include <transupp.h>
|
|
}
|
|
|
|
#include "FreeImage.h"
|
|
diff -rupN FreeImage/Source/Metadata/TagConversion.cpp FreeImage-new/Source/Metadata/TagConversion.cpp
|
|
--- FreeImage/Source/Metadata/TagConversion.cpp 2015-03-02 02:07:10.000000000 +0100
|
|
+++ FreeImage-new/Source/Metadata/TagConversion.cpp 2015-09-05 02:13:52.045353382 +0200
|
|
@@ -30,6 +30,11 @@
|
|
|
|
#define MAX_TEXT_EXTENT 512
|
|
|
|
+// These were in FreeImage.h, but are moved here to avoid conflicts (see note in FreeImage.h)
|
|
+typedef int64_t INT64;
|
|
+typedef uint64_t UINT64;
|
|
+
|
|
+
|
|
/**
|
|
Convert a tag to a C string
|
|
*/
|
|
diff -rupN FreeImage/Source/Metadata/XTIFF.cpp FreeImage-new/Source/Metadata/XTIFF.cpp
|
|
--- FreeImage/Source/Metadata/XTIFF.cpp 2015-03-02 02:07:10.000000000 +0100
|
|
+++ FreeImage-new/Source/Metadata/XTIFF.cpp 2015-09-05 02:13:52.045353382 +0200
|
|
@@ -29,13 +29,18 @@
|
|
#pragma warning (disable : 4786) // identifier was truncated to 'number' characters
|
|
#endif
|
|
|
|
-#include "../LibTIFF4/tiffiop.h"
|
|
+#include <tiffio.h>
|
|
|
|
#include "FreeImage.h"
|
|
#include "Utilities.h"
|
|
#include "FreeImageTag.h"
|
|
#include "FIRational.h"
|
|
|
|
+extern "C"
|
|
+{
|
|
+ int _TIFFDataSize(TIFFDataType type);
|
|
+}
|
|
+
|
|
// ----------------------------------------------------------
|
|
// Extended TIFF Directory GEO Tag Support
|
|
// ----------------------------------------------------------
|
|
@@ -224,6 +229,33 @@ tiff_write_geotiff_profile(TIFF *tif, FI
|
|
// TIFF EXIF tag reading & writing
|
|
// ----------------------------------------------------------
|
|
|
|
+static uint32 exif_tag_ids[] = {
|
|
+ EXIFTAG_EXPOSURETIME, EXIFTAG_FNUMBER, EXIFTAG_EXPOSUREPROGRAM,
|
|
+ EXIFTAG_SPECTRALSENSITIVITY, EXIFTAG_ISOSPEEDRATINGS, EXIFTAG_OECF,
|
|
+ EXIFTAG_EXIFVERSION, EXIFTAG_DATETIMEORIGINAL, EXIFTAG_DATETIMEDIGITIZED,
|
|
+ EXIFTAG_COMPONENTSCONFIGURATION, EXIFTAG_COMPRESSEDBITSPERPIXEL,
|
|
+ EXIFTAG_SHUTTERSPEEDVALUE, EXIFTAG_APERTUREVALUE,
|
|
+ EXIFTAG_BRIGHTNESSVALUE, EXIFTAG_EXPOSUREBIASVALUE,
|
|
+ EXIFTAG_MAXAPERTUREVALUE, EXIFTAG_SUBJECTDISTANCE, EXIFTAG_METERINGMODE,
|
|
+ EXIFTAG_LIGHTSOURCE, EXIFTAG_FLASH, EXIFTAG_FOCALLENGTH,
|
|
+ EXIFTAG_SUBJECTAREA, EXIFTAG_MAKERNOTE, EXIFTAG_USERCOMMENT,
|
|
+ EXIFTAG_SUBSECTIME, EXIFTAG_SUBSECTIMEORIGINAL,
|
|
+ EXIFTAG_SUBSECTIMEDIGITIZED, EXIFTAG_FLASHPIXVERSION, EXIFTAG_COLORSPACE,
|
|
+ EXIFTAG_PIXELXDIMENSION, EXIFTAG_PIXELYDIMENSION,
|
|
+ EXIFTAG_RELATEDSOUNDFILE, EXIFTAG_FLASHENERGY,
|
|
+ EXIFTAG_SPATIALFREQUENCYRESPONSE, EXIFTAG_FOCALPLANEXRESOLUTION,
|
|
+ EXIFTAG_FOCALPLANEYRESOLUTION, EXIFTAG_FOCALPLANERESOLUTIONUNIT,
|
|
+ EXIFTAG_SUBJECTLOCATION, EXIFTAG_EXPOSUREINDEX, EXIFTAG_SENSINGMETHOD,
|
|
+ EXIFTAG_FILESOURCE, EXIFTAG_SCENETYPE, EXIFTAG_CFAPATTERN,
|
|
+ EXIFTAG_CUSTOMRENDERED, EXIFTAG_EXPOSUREMODE, EXIFTAG_WHITEBALANCE,
|
|
+ EXIFTAG_DIGITALZOOMRATIO, EXIFTAG_FOCALLENGTHIN35MMFILM,
|
|
+ EXIFTAG_SCENECAPTURETYPE, EXIFTAG_GAINCONTROL, EXIFTAG_CONTRAST,
|
|
+ EXIFTAG_SATURATION, EXIFTAG_SHARPNESS, EXIFTAG_DEVICESETTINGDESCRIPTION,
|
|
+ EXIFTAG_SUBJECTDISTANCERANGE, EXIFTAG_GAINCONTROL, EXIFTAG_GAINCONTROL,
|
|
+ EXIFTAG_IMAGEUNIQUEID
|
|
+};
|
|
+static int nExifTags = sizeof(exif_tag_ids) / sizeof(exif_tag_ids[0]);
|
|
+
|
|
/**
|
|
Read a single Exif tag
|
|
|
|
@@ -575,45 +607,11 @@ tiff_read_exif_tags(TIFF *tif, TagLib::M
|
|
|
|
// loop over all Core Directory Tags
|
|
// ### uses private data, but there is no other way
|
|
+ // -> Fedora: Best we can do without private headers is to hard-code a list of known EXIF tags and read those
|
|
if(md_model == TagLib::EXIF_MAIN) {
|
|
- const TIFFDirectory *td = &tif->tif_dir;
|
|
-
|
|
- uint32 lastTag = 0; //<- used to prevent reading some tags twice (as stored in tif_fieldinfo)
|
|
-
|
|
- for (int fi = 0, nfi = (int)tif->tif_nfields; nfi > 0; nfi--, fi++) {
|
|
- const TIFFField *fld = tif->tif_fields[fi];
|
|
-
|
|
- const uint32 tag_id = TIFFFieldTag(fld);
|
|
-
|
|
- if(tag_id == lastTag) {
|
|
- continue;
|
|
- }
|
|
-
|
|
- // test if tag value is set
|
|
- // (lifted directly from LibTiff _TIFFWriteDirectory)
|
|
-
|
|
- if( fld->field_bit == FIELD_CUSTOM ) {
|
|
- int is_set = FALSE;
|
|
-
|
|
- for(int ci = 0; ci < td->td_customValueCount; ci++ ) {
|
|
- is_set |= (td->td_customValues[ci].info == fld);
|
|
- }
|
|
-
|
|
- if( !is_set ) {
|
|
- continue;
|
|
- }
|
|
-
|
|
- } else if(!TIFFFieldSet(tif, fld->field_bit)) {
|
|
- continue;
|
|
- }
|
|
-
|
|
- // process *all* other tags (some will be ignored)
|
|
-
|
|
- tiff_read_exif_tag(tif, tag_id, dib, md_model);
|
|
-
|
|
- lastTag = tag_id;
|
|
+ for (int i = 0; i < nExifTags; ++i) {
|
|
+ tiff_read_exif_tag(tif, exif_tag_ids[i], dib, md_model);
|
|
}
|
|
-
|
|
}
|
|
|
|
return TRUE;
|
|
@@ -723,10 +721,9 @@ tiff_write_exif_tags(TIFF *tif, TagLib::
|
|
|
|
TagLib& tag_lib = TagLib::instance();
|
|
|
|
- for (int fi = 0, nfi = (int)tif->tif_nfields; nfi > 0; nfi--, fi++) {
|
|
- const TIFFField *fld = tif->tif_fields[fi];
|
|
-
|
|
- const uint32 tag_id = TIFFFieldTag(fld);
|
|
+ for (int fi = 0; fi < nExifTags; fi++) {
|
|
+ const uint32 tag_id = exif_tag_ids[fi];
|
|
+ const TIFFField *fld = TIFFFieldWithTag(tif, tag_id);
|
|
|
|
if(skip_write_field(tif, tag_id)) {
|
|
// skip tags that are already handled by the LibTIFF writing process
|