26 lines
982 B
Diff
26 lines
982 B
Diff
Allow the configuration file to be specified via an environment variable.
|
|
|
|
--- geoclue-2.1.10/src/gclue-config.c 2015-04-07 09:50:07.721074380 +0200
|
|
+++ geoclue-2.1.10/src/gclue-config.c 2015-04-07 10:27:26.613171960 +0200
|
|
@@ -235,6 +235,11 @@
|
|
gclue_config_init (GClueConfig *config)
|
|
{
|
|
GError *error = NULL;
|
|
+ const char *config_file_path;
|
|
+
|
|
+ config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
|
|
+ if (config_file_path == NULL)
|
|
+ config_file_path = CONFIG_FILE_PATH;
|
|
|
|
config->priv =
|
|
G_TYPE_INSTANCE_GET_PRIVATE (config,
|
|
@@ -242,7 +247,7 @@
|
|
GClueConfigPrivate);
|
|
config->priv->key_file = g_key_file_new ();
|
|
g_key_file_load_from_file (config->priv->key_file,
|
|
- CONFIG_FILE_PATH,
|
|
+ config_file_path,
|
|
0,
|
|
&error);
|
|
if (error != NULL) {
|