34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 4876e3a692739bb9ca00d0f500fd5f4b3eb16ce3 Mon Sep 17 00:00:00 2001
|
|
From: Tom Callaway <spot@fedoraproject.org>
|
|
Date: Fri, 7 Sep 2012 11:39:29 -0400
|
|
Subject: apply fix for CVE-2012-4409 (thanks to Raphael Geissert)
|
|
|
|
---
|
|
mcrypt-CVE-2012-4409.patch | 12 ++++++++++++
|
|
mcrypt.spec | 10 +++++++++-
|
|
2 files changed, 21 insertions(+), 1 deletion(-)
|
|
create mode 100644 mcrypt-CVE-2012-4409.patch
|
|
|
|
diff --git a/mcrypt-CVE-2012-4409.patch b/mcrypt-CVE-2012-4409.patch
|
|
new file mode 100644
|
|
index 0000000..747f428
|
|
--- /dev/null
|
|
+++ b/mcrypt-CVE-2012-4409.patch
|
|
@@ -0,0 +1,12 @@
|
|
+diff -up mcrypt-2.6.8/src/extra.c.CVE-2012-4409 mcrypt-2.6.8/src/extra.c
|
|
+--- mcrypt-2.6.8/src/extra.c.CVE-2012-4409 2012-09-07 11:00:55.906870746 -0400
|
|
++++ mcrypt-2.6.8/src/extra.c 2012-09-07 11:00:27.967858365 -0400
|
|
+@@ -242,6 +242,8 @@ int check_file_head(FILE * fstream, char
|
|
+ if (m_getbit(0, sflag) != 0) { /* if the first bit is set */
|
|
+ *salt_size = m_setbit(0, sflag, 0);
|
|
+ if (*salt_size > 0) {
|
|
++ if (*salt_size > sizeof(tmp_buf))
|
|
++ err_quit(_("Salt is too long\n"));
|
|
+ fread(tmp_buf, 1, *salt_size,
|
|
+ fstream);
|
|
+ memmove(salt, tmp_buf, *salt_size);
|
|
|
|
--
|
|
cgit v0.12
|
|
|