guix-devel/gnu/packages/patches/python-genshi-isstring-help...

38 lines
953 B
Diff

From cc5e07284f44cdd9beec178c69070a53f55d1323 Mon Sep 17 00:00:00 2001
From: Simon Cross <hodgestar@gmail.com>
Date: Sun, 16 Feb 2014 18:43:20 +0000
Subject: [PATCH 03/15] Add isstring helper.
---
genshi/compat.py | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/genshi/compat.py b/genshi/compat.py
index 9787325..6574e39 100644
--- a/genshi/compat.py
+++ b/genshi/compat.py
@@ -35,6 +35,15 @@ else:
'Python 2 compatibility function. Not usable in Python 3.')
+# We need to test if an object is an instance of a string type in places
+
+if IS_PYTHON2:
+ def isstring(obj):
+ return isinstance(obj, basestring)
+else:
+ def isstring(obj):
+ return isinstance(obj, str)
+
# We need to differentiate between StringIO and BytesIO in places
if IS_PYTHON2:
@@ -112,4 +121,3 @@ except NameError:
if not x:
return False
return True
-
--
2.12.0