32 lines
1.0 KiB
Diff
32 lines
1.0 KiB
Diff
This patch comes from Debian.
|
|
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=771052
|
|
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835737
|
|
|
|
--- gcr-3.20.0.old/gcr/test-gnupg-collection.c 2017-06-29 14:26:33.810838197 -0400
|
|
+++ gcr-3.20.0/gcr/test-gnupg-collection.c 2017-06-30 17:25:09.149383067 -0400
|
|
@@ -115,6 +115,14 @@
|
|
|
|
g_object_unref (test->collection);
|
|
|
|
+ /* remove potential gpg 2.1 extras, ignore any errors. */
|
|
+ cmd = g_strdup_printf ("rm -rf %s/*.d", test->directory);
|
|
+ system(cmd);
|
|
+ g_free(cmd);
|
|
+ cmd = g_strdup_printf ("rm -f %s/.gpg-v21-migrated", test->directory);
|
|
+ system(cmd);
|
|
+ g_free(cmd);
|
|
+
|
|
cmd = g_strdup_printf ("rm -f %s/*", test->directory);
|
|
g_spawn_check_exit_status (system (cmd), &error);
|
|
g_assert_no_error (error);
|
|
@@ -202,7 +210,7 @@
|
|
GcrGnupgKey *key;
|
|
|
|
_gcr_gnupg_collection_load_async (test->collection, NULL, on_async_ready, test);
|
|
- egg_test_wait_until (500);
|
|
+ egg_test_wait_until (2500);
|
|
g_assert (test->result);
|
|
_gcr_gnupg_collection_load_finish (test->collection, test->result, &error);
|
|
g_assert_no_error (error);
|