25 lines
1.1 KiB
Diff
25 lines
1.1 KiB
Diff
After wrapping gnc-fq-check and gnc-fq-helper we can no longer execute them
|
|
with perl, so execute them directly instead.
|
|
|
|
diff -ur gnucash-3.2.old/libgnucash/scm/price-quotes.scm gnucash-3.2/libgnucash/scm/price-quotes.scm
|
|
--- gnucash-3.2.old/libgnucash/scm/price-quotes.scm 2018-09-15 00:48:33.718389646 -0400
|
|
+++ gnucash-3.2/libgnucash/scm/price-quotes.scm 2018-09-15 13:51:49.249862724 -0400
|
|
@@ -74,7 +74,7 @@
|
|
(define (start-program)
|
|
(if (not (string-null? gnc:*finance-quote-check*))
|
|
(set! program (gnc-spawn-process-async
|
|
- (list "perl" "-w" gnc:*finance-quote-check*) #t))))
|
|
+ (list gnc:*finance-quote-check*) #t))))
|
|
|
|
(define (get-sources)
|
|
(if (not (null? program))
|
|
@@ -158,7 +158,7 @@
|
|
(define (start-quoter)
|
|
(if (not (string-null? gnc:*finance-quote-helper*))
|
|
(set! quoter (gnc-spawn-process-async
|
|
- (list "perl" "-w" gnc:*finance-quote-helper*) #t))))
|
|
+ (list gnc:*finance-quote-helper*) #t))))
|
|
|
|
(define (get-quotes)
|
|
(if (not (null? quoter))
|