51 lines
1.8 KiB
Diff
51 lines
1.8 KiB
Diff
Fix qmake build with glibc 2.28.
|
|
|
|
Taken from upstream:
|
|
https://code.qt.io/cgit/qt/qtbase.git/commit/?id=25feee4e061b99edab79503d81f5bd045c6c8e3d
|
|
|
|
diff --git a/src/corelib/global/qconfig-bootstrapped.h b/src/corelib/global/qconfig-bootstrapped.h
|
|
index 3469ebe5e6..c5585ea32a 100644
|
|
--- a/src/corelib/global/qconfig-bootstrapped.h
|
|
+++ b/src/corelib/global/qconfig-bootstrapped.h
|
|
@@ -98,10 +98,18 @@
|
|
#define QT_NO_QOBJECT
|
|
#define QT_FEATURE_process -1
|
|
#define QT_FEATURE_regularexpression -1
|
|
-#define QT_FEATURE_renameat2 -1
|
|
+#ifdef __GLIBC_PREREQ
|
|
+# define QT_FEATURE_renameat2 (__GLIBC_PREREQ(2, 28) ? 1 : -1)
|
|
+#else
|
|
+# define QT_FEATURE_renameat2 -1
|
|
+#endif
|
|
#define QT_FEATURE_sharedmemory -1
|
|
#define QT_FEATURE_slog2 -1
|
|
-#define QT_FEATURE_statx -1
|
|
+#ifdef __GLIBC_PREREQ
|
|
+# define QT_FEATURE_statx (__GLIBC_PREREQ(2, 28) ? 1 : -1)
|
|
+#else
|
|
+# define QT_FEATURE_statx -1
|
|
+#endif
|
|
#define QT_FEATURE_syslog -1
|
|
#define QT_NO_SYSTEMLOCALE
|
|
#define QT_FEATURE_systemsemaphore -1
|
|
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
|
|
index 0c9cdb8667..deb4a9f220 100644
|
|
--- a/src/corelib/io/qfilesystemengine_unix.cpp
|
|
+++ b/src/corelib/io/qfilesystemengine_unix.cpp
|
|
@@ -91,7 +91,6 @@ extern "C" NSString *NSTemporaryDirectory();
|
|
# include <sys/syscall.h>
|
|
# include <sys/sendfile.h>
|
|
# include <linux/fs.h>
|
|
-# include <linux/stat.h>
|
|
|
|
// in case linux/fs.h is too old and doesn't define it:
|
|
#ifndef FICLONE
|
|
@@ -112,6 +111,7 @@ static int renameat2(int oldfd, const char *oldpath, int newfd, const char *newp
|
|
# endif
|
|
|
|
# if !QT_CONFIG(statx) && defined(SYS_statx)
|
|
+# include <linux/stat.h>
|
|
static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
|
|
{ return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
|
|
# elif !QT_CONFIG(statx) && !defined(SYS_statx)
|