23 lines
823 B
Diff
23 lines
823 B
Diff
Fix <https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9169>.
|
|
|
|
Taken from this upstream commit, sans ChangeLog updates:
|
|
https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=583dd860d5b833037175247230a328f0050dbfe9
|
|
|
|
diff --git a/posix/regexec.c b/posix/regexec.c
|
|
index 91d5a797b8..084b1222d9 100644
|
|
--- a/posix/regexec.c
|
|
+++ b/posix/regexec.c
|
|
@@ -1293,8 +1293,10 @@ proceed_next_node (const re_match_context_t *mctx, Idx nregs, regmatch_t *regs,
|
|
else if (naccepted)
|
|
{
|
|
char *buf = (char *) re_string_get_buffer (&mctx->input);
|
|
- if (memcmp (buf + regs[subexp_idx].rm_so, buf + *pidx,
|
|
- naccepted) != 0)
|
|
+ if (mctx->input.valid_len - *pidx < naccepted
|
|
+ || (memcmp (buf + regs[subexp_idx].rm_so, buf + *pidx,
|
|
+ naccepted)
|
|
+ != 0))
|
|
return -1;
|
|
}
|
|
}
|