100 lines
2.8 KiB
Diff
100 lines
2.8 KiB
Diff
From b0716eac4e800a0ea53e1b949250f671702f28a0 Mon Sep 17 00:00:00 2001
|
|
From: Tom Callaway <spot@fedoraproject.org>
|
|
Date: Tue, 30 Oct 2012 15:39:24 -0400
|
|
Subject: apply workaround to CVE-2012-4527
|
|
|
|
--- mcrypt-2.6.8.orig/src/mcrypt.c
|
|
+++ mcrypt-2.6.8/src/mcrypt.c
|
|
@@ -41,6 +41,8 @@
|
|
# include <time.h>
|
|
#endif
|
|
|
|
+#define WIDTH 80
|
|
+
|
|
static char rcsid[] =
|
|
"$Id: mcrypt.c,v 1.2 2007/11/07 17:10:21 nmav Exp $";
|
|
|
|
@@ -482,7 +484,7 @@
|
|
#ifdef HAVE_STAT
|
|
if (stream_flag == FALSE) {
|
|
if (is_normal_file(file[i]) == FALSE) {
|
|
- sprintf(tmperr,
|
|
+ snprintf(tmperr, WIDTH,
|
|
_
|
|
("%s: %s is not a regular file. Skipping...\n"),
|
|
program_name, file[i]);
|
|
@@ -501,7 +503,7 @@
|
|
dinfile = file[i];
|
|
if ((isatty(fileno((FILE *) (stdin))) == 1)
|
|
&& (stream_flag == TRUE) && (force == 0)) { /* not a tty */
|
|
- sprintf(tmperr,
|
|
+ snprintf(tmperr, WIDTH,
|
|
_
|
|
("%s: Encrypted data will not be read from a terminal.\n"),
|
|
program_name);
|
|
@@ -520,7 +522,7 @@
|
|
einfile = file[i];
|
|
if ((isatty(fileno((FILE *) (stdout))) == 1)
|
|
&& (stream_flag == TRUE) && (force == 0)) { /* not a tty */
|
|
- sprintf(tmperr,
|
|
+ snprintf(tmperr, WIDTH,
|
|
_
|
|
("%s: Encrypted data will not be written to a terminal.\n"),
|
|
program_name);
|
|
@@ -544,7 +546,7 @@
|
|
strcpy(outfile, einfile);
|
|
/* if file has already the .nc ignore it */
|
|
if (strstr(outfile, ".nc") != NULL) {
|
|
- sprintf(tmperr,
|
|
+ snprintf(tmperr, WIDTH,
|
|
_
|
|
("%s: file %s has the .nc suffix... skipping...\n"),
|
|
program_name, outfile);
|
|
@@ -590,10 +592,10 @@
|
|
|
|
if (x == 0) {
|
|
if (stream_flag == FALSE) {
|
|
- sprintf(tmperr, _("File %s was decrypted.\n"), dinfile);
|
|
+ snprintf(tmperr, WIDTH, _("File %s was decrypted.\n"), dinfile);
|
|
err_warn(tmperr);
|
|
} else {
|
|
- sprintf(tmperr, _("Stdin was decrypted.\n"));
|
|
+ snprintf(tmperr, WIDTH, _("Stdin was decrypted.\n"));
|
|
err_warn(tmperr);
|
|
}
|
|
#ifdef HAVE_STAT
|
|
@@ -610,7 +612,7 @@
|
|
|
|
} else {
|
|
if (stream_flag == FALSE) {
|
|
- sprintf(tmperr,
|
|
+ snprintf(tmperr, WIDTH,
|
|
_
|
|
("File %s was NOT decrypted successfully.\n"),
|
|
dinfile);
|
|
@@ -636,10 +638,10 @@
|
|
|
|
if (x == 0) {
|
|
if (stream_flag == FALSE) {
|
|
- sprintf(tmperr, _("File %s was encrypted.\n"), einfile);
|
|
+ snprintf(tmperr, WIDTH, _("File %s was encrypted.\n"), einfile);
|
|
err_warn(tmperr);
|
|
} else {
|
|
- sprintf(tmperr, _("Stdin was encrypted.\n"));
|
|
+ snprintf(tmperr, WIDTH, _("Stdin was encrypted.\n"));
|
|
err_warn(tmperr);
|
|
}
|
|
#ifdef HAVE_STAT
|
|
@@ -655,7 +657,7 @@
|
|
|
|
} else {
|
|
if (stream_flag == FALSE) {
|
|
- sprintf(tmperr,
|
|
+ snprintf(tmperr, WIDTH,
|
|
_
|
|
("File %s was NOT encrypted successfully.\n"),
|
|
einfile);
|
|
-
|
|
git v0.12
|
|
|